none
Problemas no FQDN do Certificado SSL RRS feed

  • Pergunta


  • Pessoal, 

    Estou tendo um problema complicado com o certificado SSL aqui da empresa e não estou sabendo solucionar

    Tenho 2 sites Site A e Site B e cada um deles tem um servidor Exchange Server 2010 com todas as funções ( CAS / HUB e Mailbox) um com conexão internet e outro sem, até ai tudo bem, só que ai vem meu grande problema

    Fizemos a requisição de um certificado externo valido com os seguintes apontamentos DNS

    webmail.empresa.com.br

    autodiscover.empresa.com.br

    smtp.empresa.com.br

    legacy.empresa.com.br

    E pedimos também para adicionar os FQDN dos servidores internos, só que ai é que esta o problema.

    Quando criaram o domínio aqui da empresa antigamente, criaram como empresa.br e agora quando precisamos adicionar ele dentro do certificado a empresa certificadora disse q não é possivel porque teoricamente se trata de um domínio valido apenas .br

    Fizemos um certificado interno apenas adicionando os FQDN dos servidores internos SPEXCH01.empresa.br e SP2EXCH02.empresa.br e apontamos o RpcClientAccessServer de todas as mailbox para webmail.empresa.com.br.

    Só que quando os usuários abrem o outlook aparece erro de certificado informando que não consegue encontrar o FQDN do servidor interno e quando abrimos o certificado para saber qual é ele esta apontando para o SSL externo valido, onde não consta os nomes internos, mas realizamos a instalação tanto do externo, quando to interno nas estações dos usuários.


    Att,

    quinta-feira, 9 de maio de 2013 17:18

Respostas

  • Felipe, 

    Consegui resolver o problema alterando o nome de conexão do Autodiscover.

    Fiz o seguinte procedimento

    Executei o comando no shell

    Get-ClientAccessServer | fl Name,AutoDiscoverServiceInternalUri

    e verifiquei os apontamentos de cada um dos servidores CAS e em seguida executei o comando

     Set-ClientAccessServer NomeServidor -AutoDiscoverServiceInternalUri https://autodiscover.empresa.com.br/Autodiscover/Autodiscover.xml

    Após essa alteração o popup com erro de certificado quando os usuários abrem o outlook.

    sexta-feira, 10 de maio de 2013 16:29

Todas as Respostas

  • Juliano,

    isso é um bug que muitas pessoas tem com certificados SAN, os que tem nomes alternativos.

    Normalmente eles funcionam, mas em alguns casos, como o que PODE estar contecendo com vc, o autodiscover nao funciona por não ser o nome principal do certificado.

    Isso já aconteceu comigo por exemplo e a solução foi regerar o certificado com o nome principal sendo autodiscover.dominio.com, e algumas pessoas resolvem simplesmente trocando por um certificado WildCard.

    Um teste que você pode fazer é configurar no outlook para conectar primeiro em HTTPS mesmo em redes rapida, que teoricamente seria a sua rede interna, dessa forma ele Teoricamente tentaria conectar no RPCoverHTTPS, usando o nome externo, e nao o nome interno do servidor.


    JATOBA - MCITP EMA 2010 / Caminhando para o MCSM Exchange 2010

    quinta-feira, 9 de maio de 2013 20:37
    Moderador
  • Felipe, 

    Consegui resolver o problema alterando o nome de conexão do Autodiscover.

    Fiz o seguinte procedimento

    Executei o comando no shell

    Get-ClientAccessServer | fl Name,AutoDiscoverServiceInternalUri

    e verifiquei os apontamentos de cada um dos servidores CAS e em seguida executei o comando

     Set-ClientAccessServer NomeServidor -AutoDiscoverServiceInternalUri https://autodiscover.empresa.com.br/Autodiscover/Autodiscover.xml

    Após essa alteração o popup com erro de certificado quando os usuários abrem o outlook.

    sexta-feira, 10 de maio de 2013 16:29