locked
Falha na adição de rota RRS feed

  • Pergunta

  • Galera,

    Tenho um script de logon no meu AD (Win 2008), que checa se determinada rota existe. Se não existe, o script adiciona ela.

    O comando executado para adicionar a rota é: route add 192.168.0.0 mask 255.255.255.0 192.168.2.12

    O problema é que o comando só funciona para os usuários que estão setados como administrador local da estação. Para os demais aparece o erro "Falha na adição da rota: 644568"

    Acredito que exista alguma policy ligada à permissão de adicionar rota na estação para usuários que não tem permissões administrativas sobre o computador.

    Alguém poderia me indicar esta policy (se é que ela existe) ?

    quarta-feira, 28 de abril de 2010 12:36

Respostas

  • Esse gateway 192.168.2.12 está na mesma rede que a estação onde vc está adicionando a rota? Por exemplo seu ip ser 192.168.2.xx? Isso é um requisito básico para que vc possa adicionar uma rota.

    Você pode adicionar rotas através do seu servidor DHCP (opção 249 - ClassLess Static Routes) se preferir, isso irá diminuir os esforços administrativos necessários.

    Qualquer dúvida poste.

    Abraço.


    Gabriel Nascimento MCP / MCSA / CCNA http://gabrielnascimentoit.spaces.live.com -- Se for útil vote.
    • Marcado como Resposta Cembranel quarta-feira, 28 de abril de 2010 17:08
    quarta-feira, 28 de abril de 2010 13:16

Todas as Respostas

  • Esse gateway 192.168.2.12 está na mesma rede que a estação onde vc está adicionando a rota? Por exemplo seu ip ser 192.168.2.xx? Isso é um requisito básico para que vc possa adicionar uma rota.

    Você pode adicionar rotas através do seu servidor DHCP (opção 249 - ClassLess Static Routes) se preferir, isso irá diminuir os esforços administrativos necessários.

    Qualquer dúvida poste.

    Abraço.


    Gabriel Nascimento MCP / MCSA / CCNA http://gabrielnascimentoit.spaces.live.com -- Se for útil vote.
    • Marcado como Resposta Cembranel quarta-feira, 28 de abril de 2010 17:08
    quarta-feira, 28 de abril de 2010 13:16
  • Perfeito Gabriel ! Funcionou 100%

    O gateway 192.168.2.12 está na mesma rede sim.

    Usei a configuração do ClassLess Static Routes no DHCP como você sugeriu, realizei testes e está tudo OK agora.

    Muito obrigado pela dica !

    quarta-feira, 28 de abril de 2010 17:10