none
Acesso negado a compartilhamento em servidor por endereço de IP RRS feed

  • Pergunta

  • Olá pessoALL.

    Estou com um problema muito estranho na rede que administro. Já procurei em fóruns em inglês e português e não achei a resposta.

    Tenho um File Server (Windows Server 2003 R2 Service Pack2) que está num domínio X e tem vários compartilhamentos.

    São 4 domínios que acessam pastas neste file server (vou chamá-los de domínios X, Y, W,Z).

    Num destes compartilhamentos (vou chamá-lo de EMPRESA1) haviam vários grupos globais com acesso de todos os domínios citados. Resolvi então adotar a metodologia da Microsoft.

    Depois de adotar a metodologia AGDLP (accounts > global > domain local < permissions). os usuários pararam de acessar o compartilhamento por IP, só acessam por nome. 

    Exemplo: havia um grupo global no domínio Y que acessava esse compartilhamento. Depois de inserir este grupo global em um grupo domain local (no domínio X ao qual está o FILE SERVER). Os usuários que faziam parte do grupo global do domínio Y, só acessam o compartilhamento por nome. por IP não.

    Se um usuário do domínio Y ou de outro domínio citado tentar acessar o compartilhamento, a mensagem abaixo aparece: 

    \\a.b.c.d\EMPRESA1 não está acessível. Talvez você não tenha permissão para usar este recurso da rede. Contate o administrador deste servidor para saber se você tem permissões de acesso.

     Se este mesmo usuário digitar \\nomedoservidor\EMPRESA1 o acesso é permitido.

    O mais incrível é que algumas máquinas acessam por IP, dentre as quais a minha. Peguei o PC de um colega que está no mesma sub rede, com firewall desabilitado e faz parte dos mesmos grupos que eu e ele não acessa.

    Estou ficando louco com isso já.

    A solução encontrada até agora (workaround) foi mudar no script o mapeamento. Era feito por IP, agora é feito por nome. Mas isto não resolveu o problema.

    Já verifiquei configuração de IP, DNS, WINS. Até onde vi parece estar ok.

    Alguém tem alguma idéia do porque isso ocorreu?

     

     

     

    sábado, 26 de março de 2011 06:23

Respostas

  • Então pessoal.

    Agradeço a ajuda.

    Descobri que o problema era o DNS reverso. Este servidor não estava na zona reversa dos outros domínios.

    Assim que criei o registro PTR para ele, o problema cessou.

    • Marcado como Resposta Jub1sk0 quinta-feira, 7 de abril de 2011 16:22
    quinta-feira, 7 de abril de 2011 16:21

Todas as Respostas

  • Jub1sk0,

    Foi alterado algo em relação as subnets?


    Yuri de Rezende
    quinta-feira, 31 de março de 2011 11:01
  • OLa,

     

    Poderia posta um nslookup com testes para IP e para NOME?

    []s


    Erick Albuquerque
    Blog: http://erickalbuquerque.com.br |
    Artigos IIS: http://iisbrasil.wordpress.com
    Twitter: @_ealbuquerque
    Linkedin: http://br.linkedin.com/in/easantos
    Winseg.Org
    quinta-feira, 31 de março de 2011 22:02
    Moderador
  • Olá Jub1sk0.

    Alguma novidade sobre o problema?

     

    Abraço.

     


    Richard Juhasz - Microsoft LATAM Forum Support Engineer
    http://www.forumguys.com.br
    sexta-feira, 1 de abril de 2011 20:08
  • Então pessoal.

    Agradeço a ajuda.

    Descobri que o problema era o DNS reverso. Este servidor não estava na zona reversa dos outros domínios.

    Assim que criei o registro PTR para ele, o problema cessou.

    • Marcado como Resposta Jub1sk0 quinta-feira, 7 de abril de 2011 16:22
    quinta-feira, 7 de abril de 2011 16:21