none
Página de Erro do isa server 2006 RRS feed

  • Pergunta

  • Olá pessoal, perdoe se estou criando uma pergunta que já foi feita. Mas já procurei muito e não achei.

    Fui até o diretório de páginas de erro do Isa e editei a Default, fiz um título e dei um link numa imagem que quero que apresente. Reiniciei o isa.

    A página carrega o título, mas não carrega a imagem, apesar de mostrar todo o espaço onde deveria ficra a imagem com um pequeno quadrado com um X, como se ele não encontrasse a devida imagem. Não sei onde errei, pois coloquei a imagem na mesma pasta da página, respeitando o caminho que foi feito na edição da mesma.

    Percebi que no link mostra o nome da imagem completando o link. Exemplo: Se alguém tenta utilizar o orkut (bloqueado) mostra no link: "http://www.orkut.com.br/seti.jpg" acho que é isso que está acontecendo, ele tá buscando a imagem na URL do Orkut e não no isa. O que devo fazer?

    quinta-feira, 29 de março de 2012 21:01

Respostas

Todas as Respostas

  • Willker, como você referenciou a imagem dentro do arquivo HTM de erro do ISA?




    Outra coisa porque você não cria um regra bloqueando e coloca um redirect para uma página sua personalizada.



    Espere no Senhor, confia Nele,e o mais Ele fará

    quinta-feira, 29 de março de 2012 21:32
  • Bom, a imagem estava dentro do mesmo diretório da página default. Logo, fiz só direciona-la. Daria errado se eu tivesse procurado uma imagem dentro de um local e depois a colocasse em outro, certo? Logo, se as duas estão numa mesma pasta, é só colocar as duas na mesma pasta que quero, nesse caso, na de erros do ISA.

    Homero, nunca fiz isso antes, o ISA server é totalmente novo pra mim. Eu vi que na regra eu posso colocar uma URL, ai ia solicitar que a empresa que criou o site da empresa, criasse uma página só pra isso. Assim eu pegaria a URL e direcionava, mas vi que isso poderia ser feito só editando a Default e foi isso que fiz.

    O engraçado é que a página abre com o título que dei e com o espaço da imagem, só n carrega. Não sei se tenho que colocar mais alguma coisa pra carregar a imagem. Pois nesse "quadrado com X" eu copio a URL e mostra "www.determinadosite.com.br/imagem.jpg" não sei porque ele coloca a "/imagem.jpg" no final da URL requisitada. Pensei que a "Default" direcionaria o caminho da imagem.

    Desculpe se fiz confusão ou senão foi isso que você me perguntou. Se puder ajudar agradeço muito.

    quinta-feira, 29 de março de 2012 22:41
  • Willker, quando perguntei como você referenciou a imagem dentro do html do ISA eu quis dizer o seguinte.

    <img src="teste.jpg">

    Esse código acima é um referencia de uma imagem que se pode colocar dentro de um arquivo HTML, ou seja ao abrir o arquivo HTML que contem esse código o browser procura uma imagem chamada teste.jpg no mesmo diretório do arquivo HTML.


    Espere no Senhor, confia Nele,e o mais Ele fará

    sexta-feira, 30 de março de 2012 13:15
  • Eu sei Homero, foi justamente isso que eu fiz. <img src="seti.jpg">. Onde, se a imagem estivesse dentro de alguma pasta deveria ser <img src=""pasta"/seti.jpg">. Mas é ai que está, ela está dentro da pasta de erro do isa, junto cm a default. Logo ela só deveria estar <img src="seti.jpg"> pois esse é o caminho.

    Testei algo aqui e vou ver se funciona, se funcionar eu aviso.

    sexta-feira, 30 de março de 2012 14:48
  • OK.... do contrário eu testo editando aqui a página do servidor de testes que temos aqui e lhe aviso.

    Espere no Senhor, confia Nele,e o mais Ele fará

    sexta-feira, 30 de março de 2012 15:52
  • Não consegui. A única coisa que fiz na default foi adicionar a imagem. Simples. A página carrega, menos a imagem. Só aparece o quadrado. Ai vou nesse quadrado e mando abrir a URL pra ver se ele abre a imagem, mas só mostra a página com a imagem do lado. Tipo entro no redtube ai mostra www.redtube.com/seti.jpg por isso não abre, pois ele tá buscando a imagem como se ela tivesse hospedada no redtube.

    Todos tutoriais que eu vi, só dizem pra editar a default e pronto. Não sei porque ele joga a imagem no final da URL requisitada em vez de abrir um caminho que levasse a imagem que está locada no servidor =/

    sexta-feira, 30 de março de 2012 16:56
  • Olá Wilker,

    para que funcione da maneira que você espera, é preciso que esta imagem esteja em um web server acessível para o usuário (melhor dos casos, na sua rede interna). Ao alterar a página default do ISA, você deve referenciar o caminho completo onde a imagem se encontra, por exemplo: http://webserver.local/imagem.jpg. Somente dessa forma a imagem aparecerá para o usuário.

    Outra coisa que você deve ter em mente ao alterar qualquer página de erro do ISA é somente alterar os campos suportados pela Microsoft. Para maiores informações consulte este link: http://technet.microsoft.com/en-us/library/bb794832.aspx

    Atenciosamente,

    Paulo Oliveira.


    Dúvidas, divulgação de blogs, discussões sobre ISA/TMG: Participe do grupo ISA/TMG Firewall Admins Brasil no LinkedIn: http://www.linkedin.com/groups? mostPopular=&gid=3774142

    Blog: http://poliveirasilva.wordpress.com

    TI Especialistas: http://www.tiespecialistas.com.br/author/paulo-oliveira/

     

    • Marcado como Resposta Richard Juhasz segunda-feira, 16 de abril de 2012 18:55
    sexta-feira, 30 de março de 2012 19:26