none
Calcular tempo de execução de tarefa, considerando apenas as horas de trabalho úteis no EXCEL RRS feed

  • Pergunta

  • Boa tarde .

    Estou precisando de ajuda em um projeto, onde preciso calcular o tempo gasto na execução de uma tarefa, que pode iniciar em um dia e terminar no outro. Preciso que o Excel calcule isso, desprezando as horas fora do horário de trabalho, os fins de semana e os feriados. 

    Meus dados estão dispostos na planilha da seguinte forma:

    Coluna A - Data da entrada / Coluna B - Hora da Entrada / Coluna C - Data da Saída / Coluna D Hora Saída

     O funcionário tem uma meta de sair com o documento até 3 horas a partir da entrada. O Horário de trabalho é de 8 as 17:30 de segunda a sexta, portanto se o documento entrar na sexta as 17:25 , só vai ser tratado e dar saída na segunda pela manhã.

    Preciso de uma fórmula que calcule esse tempo desprezando as horas a partir das 17:31 de sexta feira até 7:59 da segunda. 

    Existe como? 

    Tentei seguir este outro post mas não consegui o resultado que desejo. Podem me ajudar? https://social.technet.microsoft.com/Forums/pt-BR/58539176-da33-440a-a8f0-d6f0b7c23133/calcular-horas-teis-no-excel?forum=officept

    Desde já agradeço.

    Att

    Lidia azevedo


    sábado, 29 de outubro de 2016 14:43

Todas as Respostas

  • Fiz uma planilha que em meus testes atende sua necessidade.

    Obs.: Na linha 9, está o inicio e término do expediente e quantas horas de almoço. Você pode alterar conforme sua necessidade.

    Seguem as fórmulas:

    E2-> = SE(B2<=13/24;(C2+D2)-(A2+B2)-1/24;(C2+D2)-(A2+B2))

    F2-> =SE(H2>0;SE(D2>=12/24;(C2+A9)-(A2+B9)+(C9*H2);(C2+A9)-(A2+B9));0)

    G2-> =SE(E2>F2;E2-F2;F2-E2)

    H2-> =SE(C2>A2;DIATRABALHOTOTAL.INTL(A2+B2;C2+D2;1;Feriados!A1:A12);0)

    Na fórmula da célula H2, uso uma planilha auxiliar para os feriados

    Não testei massivamente, pode conter algum bug. Qualquer coisa só replicar.


    • Editado J. Maurício terça-feira, 1 de novembro de 2016 18:30
    terça-feira, 1 de novembro de 2016 18:23
  • Bom dia 

    foi muito uteis, a formula mais a minha esta dando erro esta descontando 10h + do que previsto, nas horas desprezíveis.

    terça-feira, 9 de janeiro de 2018 19:16