none
EXCHANGE 2010 RECOVERY DATABASE DE OUTRO SERVDIRO RRS feed

  • Pergunta

  • BOA TARDE SENHORES.

    SEMANA PASSADA ACONTECEU UMA COISA MUITO DESAGRADAVEL EM UM CLIENTE.

    ELE TEM UMA AD E UMA EXCHANGE 2010.

    ACONTECEU UM PROBLEMA NO SERVIDOR ONDE SE ENCONTRAVA O AD, A MAQUINA FOI PRO SACO. COMO ERA NECESSARIO DEIXAR O SISTEMA DA EMPRESA E-MAIL E OUTROS ONLINE O MAIS RAPIDO POSSIVEL, FIZEMOS A INSTALAÇÃO DE UMA NOVO AD, CONTA DE USUARIO E EXCHANGE 2010.

    AGORA TUDO ESTÁ FUNCIONANDO OK, PORÉM EU PRECISO RESTAURAR AS E-MAILBOX E OUTROS DO ENTIGO EXCHANGE 2010.

    PERGUNTA.

    COMO EU POSSO RESTAURAR AS MAILBOX DA DATA STORAGE DO MEU ANTIGO EXCHANGE PARA O NOVO.

     

    vALEW GALERA

     

     


    Fazzani - MCP, MCSA, MCTS-ISA,VISTA
    segunda-feira, 11 de abril de 2011 13:13

Respostas

  • Ainda nada amigos.

    Mais eu tiver que usar o OST convert to PST, meus e-mails estão todos recuperados.

    Database ainda não conseguir da mount nela, e está com todas atualizações do Exchange e do Servidor windows 2008r2.

    Mais eu ainda quero tentar montar o Base, saber o porque disso.

    Valew galera

     


    Fazzani - MCP, MCSA, MCTS-ISA,VISTA
    sábado, 16 de abril de 2011 14:20
  • É amigão também acho que é a unica solução.

    Mais vou deixa isso para la. Ja estou com meu novo exchange 2010 rodando.

     

    Valew amigos pela atenção.


    Fazzani - MCP, MCSA, MCTS-ISA,VISTA
    quinta-feira, 21 de abril de 2011 02:04

Todas as Respostas

  • Qual a estratégia de Backup que voce utiliza?

    Windows Server Backup? Data Protection Manager?

    A base de dados foi protegida integralmente ?

    Repasse essas informações pra que possa ser mais fácil identificar a estrutura.

    Sem mais.


    Ajudou? Classifique. MCITP Windows Server 2008. Profissional 5 estrelas Windows Server 2008. Bacharel em Ciência da Computação pela UFMT. MCTS Exchange 2010 em Formação. Estudante de BI.
    segunda-feira, 11 de abril de 2011 13:45
  • Estava usando o BackupExec 2010, porém por algum motivo ele não está crestaurando.

    O que eu tenho em mãos no momento é somente o arquivo da Base e do log do exchange antigo.


    Fazzani - MCP, MCSA, MCTS-ISA,VISTA
    segunda-feira, 11 de abril de 2011 13:49
  • Primeiramente lember-se que o servidor tem que estar com as mesmas configurações do servidor antigo. Atualizações, Service pack caso tenha sido instalado, Rollups... Caso o novo servidor possua uma versão anterior ao que foi feito o backup da base de dados a base não será montada.

    Após isso faça as verificações utilizando o eseutil para confirmar a integridade dos dados e efetuar reparos caso necessário.

    Acredito que seu erro seja apenas a questão da versão do servidor conflitando com o banco de dados. Verifique isso e tente montar a base, caso não de parta para o uso do eseutil.

    Sem mais.


    Ajudou? Classifique. MCITP Windows Server 2008. Profissional 5 estrelas Windows Server 2008. Bacharel em Ciência da Computação pela UFMT. MCTS Exchange 2010 em Formação. Estudante de BI.
    segunda-feira, 11 de abril de 2011 13:58
  • Eh estava tentando montar e realmente não estava dando, vou dar uma verificada o que esta acontecendo e post aqui para vcs.


    Fazzani - MCP, MCSA, MCTS-ISA,VISTA
    segunda-feira, 11 de abril de 2011 14:32
  • Amigos por favor verifique se o procedimento para eu montar a DB antigo no novo esta correto.

    Primeiramente no Exchange 2010 eu ja tenho uma nova DB com os e-mails novos. Então estou criando uma DB CHAMADA RECOVERY.

    Depois eu Dismont Data Base.

    Depois eu excluo ou renomeio essta data e copio a antiga para essa pasta. Renomeio a base com o nome RECOVERY e tento montar.

    Porem estou recebendo um erro.

    Valew.


    Fazzani - MCP, MCSA, MCTS-ISA,VISTA
    segunda-feira, 11 de abril de 2011 17:11
  • So para complementar na hora de montar a Data base gera o seguinte ero.

     

    --------------------------------------------------------
    Microsoft Exchange Error
    --------------------------------------------------------
    Failed to mount database 'RECOVERY'.

    RECOVERY
    Failed
    Error:
    Couldn't mount the database that you specified. Specified database: RECOVERY; Error code: An Active Manager operation failed. Error: The database action failed. Error: Operation failed with message: MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=-550)
    . [Database: RECOVERY, Server: PRN-EXC01.parana.local].

    An Active Manager operation failed. Error: The database action failed. Error: Operation failed with message: MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=-550)
    . [Database: RECOVERY, Server: PRN-EXC01.parana.local]

    An Active Manager operation failed. Error: Operation failed with message: MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=-550)
    . [Server: PRN-EXC01.parana.local]

    MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=-550)

     

     

    --------------------------------------------------------
    OK
    --------------------------------------------------------


    Fazzani - MCP, MCSA, MCTS-ISA,VISTA
    segunda-feira, 11 de abril de 2011 17:17
  • Eu obtive esse mesmo problema no meu ambiente, mas ele era resultante de diferenças de versão entre o banco de dados e o antigo servidor.

    Teste criar um novo banco de dados apontando o caminho do arquivo edb e o log diretamente para os seus arquivos de backup.

    Novamente, o servidor e a base estão na mesma versão?


    Ajudou? Classifique. MCITP Windows Server 2008. Profissional 5 estrelas Windows Server 2008. Bacharel em Ciência da Computação pela UFMT. MCTS Exchange 2010 em Formação. Estudante de BI.
    segunda-feira, 11 de abril de 2011 17:26
  • Então foi exatamente o que eu fiz e deu esse erro.

    Cara num sei te fala se esta a mesma versão, será que eu atualizar meu exchange para as ultimas atualizações disponivel vai da Zebra?


    Fazzani - MCP, MCSA, MCTS-ISA,VISTA
    segunda-feira, 11 de abril de 2011 18:22
  • Um dos problemas que eu achei é que a copia da minha Base esta com problemas, eu dei o comando

    eseutil /mh

    E mostrou que minha Base estava Dirty Shutdown.

    Vou tentar fazer um outra copia da Base e posto aqui.


    Fazzani - MCP, MCSA, MCTS-ISA,VISTA
    segunda-feira, 11 de abril de 2011 18:40
  • Você possuía o Service Pack 1 instalado no Exchange?
    Ajudou? Classifique. MCITP Windows Server 2008. Profissional 5 estrelas Windows Server 2008. Bacharel em Ciência da Computação pela UFMT. MCTS Exchange 2010 em Formação. Estudante de BI.
    segunda-feira, 11 de abril de 2011 22:35
  • Tinha sim


    Fazzani - MCP, MCSA, MCTS-ISA,VISTA
    terça-feira, 12 de abril de 2011 01:19
  • O novo servidor que voce levantou tem o SP instalado já? Caso não instale e tente montar a base nele. Caso sim utilize o eseutil pra limpar o estado de dirty shutdown da base e tente montar criando uma base nova e apontando diretamente para o arquivo de dados e log.
    terça-feira, 12 de abril de 2011 01:21
  • Amigão meu Exchange está com SP1 instalado.

    Minha base estava mostrando-se Dirty Shutdown, resolvi isso com eseutil /p.

    Criei uma base da maneira que vc me disse

    [PS] C:\recovery>Mount-Database RecoveryDatabasenew-mailBOXdatabase -recovery -Name "RecoveryDataBase" -Server "PRN-EXC01"

    Depois dei  o comando ESEUTIL /R E00 /I /D

    Depois tentei montar a base Mount-Database RecoveryDatabase

    e Recebi o erro a baixo.


    Couldn't mount the database that you specified. Specified database: RecoveryDatabase; Error code: An Active Manager ope
    ration failed. Error: The database action failed. Error: Operation failed with message: MapiExceptionCallFailed: Unable
     to mount database. (hr=0x80004005, ec=1276)
    . [Database: RecoveryDataBase, Server: PRN-EXC01.parana.local].
        + CategoryInfo          : InvalidOperation: (RecoveryDataBase:ADObjectId) [Mount-Database], InvalidOperationExcept
       ion
        + FullyQualifiedErrorId : 6C83847D,Microsoft.Exchange.Management.SystemConfigurationTasks.MountDatabase


    Fazzani - MCP, MCSA, MCTS-ISA,VISTA
    terça-feira, 12 de abril de 2011 14:20
  • Verifique esse KB.

    http://support.microsoft.com/kb/925825


    Ajudou? Classifique. MCITP Windows Server 2008. Profissional 5 estrelas Windows Server 2008. Bacharel em Ciência da Computação pela UFMT. MCTS Exchange 2010 em Formação. Estudante de BI.
    terça-feira, 12 de abril de 2011 14:35
  • Ola Felipe!!!

    Alguma novidade?


    Jonathan Santos | http://jonathanrsantos.wordpress.com MCP | MCSA | MCSA Messaging | MCSE Messaging
    terça-feira, 12 de abril de 2011 19:15
    Moderador
  • Cara hoje não tive mais tempo de vê, quando eu da uma checada eu passo pra vcs.

    Mais uma noticia boa, Sistema, AD file servers e outros Ja esta OK.

    Valew.


    Fazzani - MCP, MCSA, MCTS-ISA,VISTA
    quarta-feira, 13 de abril de 2011 03:20
  • Verifique esse KB.

    http://support.microsoft.com/kb/925825


    Ajudou? Classifique. MCITP Windows Server 2008. Profissional 5 estrelas Windows Server 2008. Bacharel em Ciência da Computação pela UFMT. MCTS Exchange 2010 em Formação. Estudante de BI.

    É amigão esse KB ai num me ajuda não.

    Valew pela atenção


    Fazzani - MCP, MCSA, MCTS-ISA,VISTA
    quarta-feira, 13 de abril de 2011 03:48
  • Ola felipe!!

    A opção "Este banco de dados pode ser substituir por uma restauração" esta marcada?
    Se não marque e tente montar novamente. 


    Jonathan Santos | http://jonathanrsantos.wordpress.com MCP | MCSA | MCSA Messaging | MCSE Messaging
    quarta-feira, 13 de abril de 2011 20:24
    Moderador
  • Está marcada sim!

    Agora estou me lembrando que ja me deparei com esse tipo de problema em uma outra empresa com exchange 2003.

     

    Mais alguma ideia?


    Fazzani - MCP, MCSA, MCTS-ISA,VISTA
    quinta-feira, 14 de abril de 2011 01:08
  • Felipe!!!

    Faz assim...

    Instala os Rollups 1,2 e 3 no seu servidor Exchange 2010, a alguns dias um amigo deparou-se com um erro parecido com o seu e corrigiu com o Rollup 3.


    Jonathan Santos | http://jonathanrsantos.wordpress.com MCP | MCSA | MCSA Messaging | MCSE Messaging
    quinta-feira, 14 de abril de 2011 21:02
    Moderador
  • Quando eu tive o problema desse no meu servidor eu restaurei a base apenas após a instalação do SP1 e tooodos os Rollup's.

    Verifique isso.


    Ajudou? Classifique. MCITP Windows Server 2008. Profissional 5 estrelas Windows Server 2008. Bacharel em Ciência da Computação pela UFMT. MCTS Exchange 2010 em Formação. Estudante de BI.
    quinta-feira, 14 de abril de 2011 21:39
  • Ola Felipe!!!

    Alguma novidade?

     


    Jonathan Santos | http://jonathanrsantos.wordpress.com MCP | MCSA | MCSA Messaging | MCSE Messaging
    sexta-feira, 15 de abril de 2011 15:24
    Moderador
  • Ainda nada amigos.

    Mais eu tiver que usar o OST convert to PST, meus e-mails estão todos recuperados.

    Database ainda não conseguir da mount nela, e está com todas atualizações do Exchange e do Servidor windows 2008r2.

    Mais eu ainda quero tentar montar o Base, saber o porque disso.

    Valew galera

     


    Fazzani - MCP, MCSA, MCTS-ISA,VISTA
    sábado, 16 de abril de 2011 14:20
  • Ola Felipe,

    Estranho seu problema,

    Tem certeza que o Rollup 3 esta instalado?
    Tenho certeza que foi com esse Rollup que conseguimos corrigir esse erro.


    Jonathan Santos | http://jonathanrsantos.wordpress.com MCP | MCSA | MCSA Messaging | MCSE Messaging
    terça-feira, 19 de abril de 2011 15:47
    Moderador
  • Sim está instalado sim.

    Num sei mais o que fazer, ainda bem que eu consegui recuperar os e-mails.

    UFA.

    Mais isso pra mim virou caso de estudo.


    Fazzani - MCP, MCSA, MCTS-ISA,VISTA
    terça-feira, 19 de abril de 2011 16:33
  • Felipe,

    Agora a unica solução que posso indicar pra você é a abertura de um chamado com a MS, assim os Engenheiros vão acessar seu ambiente e verificar esse erro.


    Jonathan Santos | http://jonathanrsantos.wordpress.com MCP | MCSA | MCSA Messaging | MCSE Messaging
    quarta-feira, 20 de abril de 2011 15:11
    Moderador
  • É amigão também acho que é a unica solução.

    Mais vou deixa isso para la. Ja estou com meu novo exchange 2010 rodando.

     

    Valew amigos pela atenção.


    Fazzani - MCP, MCSA, MCTS-ISA,VISTA
    quinta-feira, 21 de abril de 2011 02:04