none
URGENTISSÍMO - adprep32.exe /rodcprep com erro RRS feed

  • Pergunta

  • Estou trocando o servidor Windows Server 2003 para uma nova máquina Windows Server 2008 R2 e preciso migrar o dominio

    Para tanto, já fiz:

    Aumentei o nível funciona do dominio Server 2003 - Com  sucesso
    Rodei adprep32.exe /forestprep - Com Sucesso
    Rodei adprep32.exe.exe /domainprep - Com sucesso
    Rodei adprep32.exe /rodcprep - FALHA com o erro abaixo:

    Adprep could teh Domain Naming FSMO to read the partitions. The Domain Naming FSMO must be reachable for this operation to proceed.[Status/Consequense]
    The Active Directory Domain Service DNS partitions are not prepared for Read Only DCs.
    [user Action]
    Check the log file ADPrep.log

    O que devo fazer? Obrigado pela ajuda !


    • Editado RRTZ quarta-feira, 24 de abril de 2013 14:32
    terça-feira, 23 de abril de 2013 16:18

Respostas

  • Caro Raddatz

    Este erro pode ser causado se as partições referenciadas não existirem mais, ou se a FSMO mestre de infra-estrutura foi rebaixada ou está offline.

    Este KB fornece explicações sobre o caso, bem como soluções para o mesmo, sguiro que dê uma olhada:

    http://support.microsoft.com/kb/949257/pt-br

    Se precisar de algo mais, estamos a disposição.

    SDS


    Fernando H. da Silva - Microsoft Contingent Staff

    quarta-feira, 24 de abril de 2013 20:24
  • Boa noite Raddatz,

    Esse erro está ocorrendo, porque o comando não encontrou um controlador mestre em seu domínio atual. Isso pode ocorrer por uma falha interna, ou algum arquivo em seu domínio.

    Minhas dúvidas:

    .
    Quais partições esta se referindo??

    São as partições referentes ao mestre de operações em seu controlador de domínio.

    Como posso identificar se existem ou não??

    Ele existe com certeza em seu domínio, mas pode estar com problemas. Uma forma simples de verificar se não há erros nas funções mestres é clicando com o botão direito no servidor e escolher "Mestre de Operações". Veja na imagem abaixo:

     

    Veja se não está com problemas em algumas das abas. Caso encontre um problema, aconselho a tentar utilizar a ferramenta ntdsutil para transferir novamente as funções mestre para seu controlador de domínio principal.

    .

    Segue literatura abaixo:

    http://support.microsoft.com/kb/255504/pt-br

    .

    Veja se dá uma clareada e post os resultados.

    Vinicius Mozart



    quinta-feira, 25 de abril de 2013 22:41
    Moderador
  • Veja se o servidor está marcado como Catálogo Global, como na imagem abaixo:

    Caso não esteja marcado, marque e rode o comando novamente.

    Vinicius Mozart

    sexta-feira, 26 de abril de 2013 16:05
    Moderador
  • Boa tarde,

    Para chegar nessa tela de catálogo global:

    Vá em Ferramentas Administrativas/Serviços e sites do Active Directory  e siga a imagem abaixo:


    Vinicius Mozart

    sexta-feira, 28 de junho de 2013 18:50
    Moderador

Todas as Respostas

  • Boa tarde Rad!!!!

    Voce analisou o log?!?! Tem como postar pra nós?!?!?

    Vlw...

    terça-feira, 23 de abril de 2013 16:29
  • Obrigado pela resposta.

    Segue o log:

    [2013/04/23:12:37:33.015]
    Adprep created the log file ADPrep.log under C:\WINDOWS\debug\adprep\logs\20130423123733 directory.
    [2013/04/23:12:37:33.031]
    Adprep could not contact the Domain Naming FSMO to read the partitions. The Domain Naming FSMO must be reachable for this operation to proceed.

    [Status/Consequence]

    The Active Directory Domain Services DNS partitions are not prepared for Read Only DCs.

    [User Action]

    Check the log file ADPrep.log in the C:\WINDOWS\debug\adprep\logs\20130423123733 directory for possible cause of failure.
    [2013/04/23:12:37:33.046]
    Adprep encountered a Win32 error.

    Error code: 0x54b Error message: O domínio especificado não existe ou não pôde ser contatado..

    terça-feira, 23 de abril de 2013 16:31
  • Rad ambos o servers estão na mesma rede?!?!?!

    Se você pingar de um para o outro, pelo nome eles respondem?!? E pelo "ip -a" retorna os nomes numa boa?!?!?

    terça-feira, 23 de abril de 2013 16:36
  • Odecio

    Sim pinga pelo host e pelo ip.
    Inclusive já coloquei o Windows 2008 no dominio.

    Obrigado

    terça-feira, 23 de abril de 2013 16:46
  • Show de bola!!!!

    Ja deu uma olhada nesse topico:

    http://social.technet.microsoft.com/Forums/pt-BR/winsrv2008pt/thread/bbb668d2-0e6f-4ea7-a793-61a33b2b1772

    Talvez te possa te ajudar...

    terça-feira, 23 de abril de 2013 16:49
  • Vou verificar! Obrigado.

    Mais alguém já passou por essa situação?

    Obrigado a todos.


    • Editado RRTZ terça-feira, 23 de abril de 2013 17:35
    terça-feira, 23 de abril de 2013 17:35
  • Por favor,

    Alguém para ajudar nesse caso.

    Urgentíssimo.

    Muito Obrigado

    quarta-feira, 24 de abril de 2013 14:31
  • Caro Raddatz

    Este erro pode ser causado se as partições referenciadas não existirem mais, ou se a FSMO mestre de infra-estrutura foi rebaixada ou está offline.

    Este KB fornece explicações sobre o caso, bem como soluções para o mesmo, sguiro que dê uma olhada:

    http://support.microsoft.com/kb/949257/pt-br

    Se precisar de algo mais, estamos a disposição.

    SDS


    Fernando H. da Silva - Microsoft Contingent Staff

    quarta-feira, 24 de abril de 2013 20:24
  • Caro Fernando

    Quero te agradecer muito pela ajuda.
    Apareceu uma luz no túnel!

    Mas li varias vezes esse link, mas não entendi direito como proceder.
    Talvez por nunca ter passado por esse problema, me falte experiência técnica nesse quesito.
    Esse link me mostra dois problemas que posso estar enfrentando. Veja:

    --------------------------

    CAUSA:

    Esse problema ocorre quando o comando Adprep /rodcprep tenta entrar em contato com o mestre de infra-estrutura para cada partição de aplicativo na floresta. O comando faz isso para definir as permissões que são necessárias para replicação do controlador de domínio somente leitura (RODC). O comando Adprep /rodcprep falhará se uma das seguintes condições for verdadeira:
    • A partição ou partições que são referenciadas na mensagem de erro não existem.
    • O mestre de infraestrutura para a referência de partição ou partições tem sido rebaixados ou está off-line.

    ---------------------------

    Minhas dúvidas:
    Quais partições esta se referindo??
    Como posso identificar se existem ou não??

    ---------------------------

    Detalhes:

    O Domínio que esta no Windows 2003 esta em perfeito uso e sem logs de erro.
    Isso já mostra que as partições estão ok????

    ----------------------------

    Peço desculpas se estou exagerando nas perguntas.

    Mais uma vez muito obrigado.

    quinta-feira, 25 de abril de 2013 18:48
  • Boa noite Raddatz,

    Esse erro está ocorrendo, porque o comando não encontrou um controlador mestre em seu domínio atual. Isso pode ocorrer por uma falha interna, ou algum arquivo em seu domínio.

    Minhas dúvidas:

    .
    Quais partições esta se referindo??

    São as partições referentes ao mestre de operações em seu controlador de domínio.

    Como posso identificar se existem ou não??

    Ele existe com certeza em seu domínio, mas pode estar com problemas. Uma forma simples de verificar se não há erros nas funções mestres é clicando com o botão direito no servidor e escolher "Mestre de Operações". Veja na imagem abaixo:

     

    Veja se não está com problemas em algumas das abas. Caso encontre um problema, aconselho a tentar utilizar a ferramenta ntdsutil para transferir novamente as funções mestre para seu controlador de domínio principal.

    .

    Segue literatura abaixo:

    http://support.microsoft.com/kb/255504/pt-br

    .

    Veja se dá uma clareada e post os resultados.

    Vinicius Mozart



    quinta-feira, 25 de abril de 2013 22:41
    Moderador
  • Grande Vinicius!

    Raddatz, exatamente o que o nosso amigo Vinicius postou! Qualquer dúvida, conte conosco!

    Abraço!


    Fernando H. da Silva - Microsoft Contingent Staff

    sexta-feira, 26 de abril de 2013 13:14
  • Vinicius e Fernando

    Bom dia e Obrigado pela força !!!!

    Verifiquei conforme a ajuda de vocês. Veja:

    Não encontrei nenhum problema com eles. Nem no RID, nem Controlador de Domínio e nem Infraestrutura.

    --------------------------------------------------------

    Fiz um teste com o DCDIAG

    Todos os testes passaram com exceção da FSMO. Veja resultado

    Basta saber como resolver esse problema !!!!!!

    ------------------------------------------------------

    Agradeço mais uma vez.!!!!

    Ricardo Raddatz


    • Editado RRTZ sexta-feira, 26 de abril de 2013 15:13
    sexta-feira, 26 de abril de 2013 14:35
  • Veja se o servidor está marcado como Catálogo Global, como na imagem abaixo:

    Caso não esteja marcado, marque e rode o comando novamente.

    Vinicius Mozart

    sexta-feira, 26 de abril de 2013 16:05
    Moderador
  • Vinicius e Fernando !!!!

    Deu certo (Nem acredito)!!!!!! Realmente o que estava faltando era esse "simples" clique no catalogo global.
    Meu AD já esta na nova máquina com o novo SO.

    Muito obrigado pela atenção e colaboração de todos vocês.

    Sucesso à todos!!!

    Ricardo Raddatz

    sexta-feira, 26 de abril de 2013 17:10
  • Boa tarde,

    Que bom Raddatz. Bom trabalho e boa sorte.

    Vinicius Mozart

    sexta-feira, 26 de abril de 2013 17:32
    Moderador
  • como eu faço para chegar nessa tela no windows 2003 server ?
    • Editado tialexandre sexta-feira, 28 de junho de 2013 18:40 duvida
    sexta-feira, 28 de junho de 2013 18:35
  • Boa tarde,

    Para chegar nessa tela de catálogo global:

    Vá em Ferramentas Administrativas/Serviços e sites do Active Directory  e siga a imagem abaixo:


    Vinicius Mozart

    sexta-feira, 28 de junho de 2013 18:50
    Moderador