none
Subsites herdar banner do site principal RRS feed

  • Pergunta

  • Boa tarde,

    Estou com o meu site em sharepoint onde a página principal tem um banner com o logo da empresa e nome do site, quando crio subsites ele não herda o banner da página pai, fazendo com que fique com o layout default da configuração.

    Já visitei vários sites e tutoriais e nenhum foi claro quanto a herança de banner para subsites. Como poderei solucionar este problema?

    segunda-feira, 20 de agosto de 2012 18:59

Todas as Respostas

  • Olá, caso todos os subsites usem a mesma master page, você tem que editar a master page do site principal e colocar uma webpart de imagem já com o valor da imagem preenchido, pesquise como já preencher webparts com CDATA ou crie uma DIV e ponha um código personalizado para o banner. Sendo o código inserido via sharepoint designer na master page que é utilizada por todos os subsites a master page já vai com o banner pra todos. Espero ter ajudado.


    Caso a reposta tenha resolvido por favor Marque esse post como "RESPOSTA" para que se encerre essa Thread. E se lhe foi util também Marque como "votar como Útil" Caso não tenha resolvido, sinta-se a vontade para fazer novas perguntas. MCP - Win2k3 server | MCP - Windows XP | MCDST - Windows XP | MCSA - Win2k3 Server| MCTS - MOSS 2007, WSS 3.0 |

    terça-feira, 21 de agosto de 2012 11:17
  • Olá Daniel Barroso,

    Eu já tenho um banner como padrão para a minha página principal e os subsites feitos anteriormente estão herdando este banner.

    Porém os novos subsites não estão mais herdando esta configuração de banner, acredito que possa ser alguma linha de código que eu tenha que inserir chamando minha "master.master" (como esta denominada minha asp.net que contém o banner) ou configurar alguma outra coisa nos novos subsites.

    Você tem mais alguma sugestão?

    terça-feira, 21 de agosto de 2012 16:42
  • Por ser também a V4.master ou a custom.master, não sei ao certo qual você personalizou, mas você pode tentar forçar a herança da master page usada no site principal para os subsites, este post diz o passo a passo, http://virtualizesharepoint.com/2011/03/29/how-to-apply-custom-master-page-and-theme-to-all-sharepoint-2010-sub-sites/ .

    Qualquer dúvida não deixe de postar o resultado aqui, para darmos continuidade na resolução do problema.


    Caso a reposta tenha resolvido por favor Marque esse post como "RESPOSTA" para que se encerre essa Thread. E se lhe foi util também Marque como "votar como Útil" Caso não tenha resolvido, sinta-se a vontade para fazer novas perguntas. MCP - Win2k3 server | MCP - Windows XP | MCDST - Windows XP | MCSA - Win2k3 Server| MCTS - MOSS 2007, WSS 3.0 |

    terça-feira, 21 de agosto de 2012 18:35
  • Já viu se o problema não esteja no não carregamento do CSS?

    Atenciosamente, Rafael Fausto

    quarta-feira, 22 de agosto de 2012 17:02
  • Boa tarde,

    Já verifiquei todas as configurações mencionadas e nada. Tenho outros subsites que herdam o banner mas os criados recentementes ainda nada.

    sexta-feira, 31 de agosto de 2012 15:46