none
Autenticação dos usuários no Reporting Services RRS feed

  • Pergunta

  • Bom dia Prezados colegas,

                   Eu estou passando pelo seguinte problema: Eu tenho um ambiente com Windows server 2008 r2 e SQL Server 2008 r2, quando eu instalo o Reports Server ele acessa normal colocando o localhost/reports na máquina que foi instalado, mas quando eu vou acessar de qualquer outra máquina do domínio ele pede usuário e senha da rede. O que eu tenho que fazer para ele não pedir essa autenticação?

    sábado, 28 de junho de 2014 13:06

Respostas

  • Fredy, se o usuário está devidamente autenticado na estação dentro do domínio e este usuário tiver permissão para acessar o rerporting services, o problema é configuração do browser.

    Vc está utilizando o IE ?

    Se sim, veja esse post.

    http://www.soheib.com/technical-knowledge/ssrs-prompt-for-username-and-password-in-ie/

    Veja também no vível personalizado na aba "segurança", conforme a imagem abaixo.


    Eduardo Gomes - http://www.h1solucoes.com.br - Twitter: @edugp_sp

    segunda-feira, 30 de junho de 2014 18:33

Todas as Respostas

  • Fredy, se o usuário está devidamente autenticado na estação dentro do domínio e este usuário tiver permissão para acessar o rerporting services, o problema é configuração do browser.

    Vc está utilizando o IE ?

    Se sim, veja esse post.

    http://www.soheib.com/technical-knowledge/ssrs-prompt-for-username-and-password-in-ie/

    Veja também no vível personalizado na aba "segurança", conforme a imagem abaixo.


    Eduardo Gomes - http://www.h1solucoes.com.br - Twitter: @edugp_sp

    segunda-feira, 30 de junho de 2014 18:33
  • Boa noite Eduardo,

    Eu fiz todas essas configurações e até agora nada, me pergunto se tem alguma permissão no IIS que tem que ser configurada?

    Abs.

    terça-feira, 1 de julho de 2014 01:01
  • Na criação do relatório ou até mesmo na criação de uma pasta no reporting service vc tem que dá as devidas permissões. Essa pasta é compartilhada basta vc colocar as permissões nela que os usuário terão acesso.

    Veja se esse link te ajuda.

    http://technet.microsoft.com/pt-br/library/aa337491(v=sql.105).aspx


    Junior

    • Sugerido como Resposta Edinaldo Junior quinta-feira, 3 de julho de 2014 11:59
    terça-feira, 1 de julho de 2014 11:07
  • Fredy,

    Você já verificou nas configurações do Datasource ou até mesmo se existe algum parâmetro no seu Report que possa esta solicitando algum tipo de login!!!

    Já tive problemas com este tipo de situação, onde as permissões do Datasource estavam sobrepondo as permissões de acesso ao relatório com as permissões de domínio.


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário | MSIT.com]

    quinta-feira, 3 de julho de 2014 14:33