none
Botoes de Seleçao no Excel 2007 RRS feed

  • Pergunta

  • Ola Amigos,

    Estou trabalhando em uma planilha de custos no Excel 2007 e gostaria de adicionar uma funçao para facilitar o calculo de contas que ja foram pagas e quem ainda serao. A ideia seria ter um botao ao lado de cada custo, com as condiçoes Sim ou Nao, que dependendo da seleçao alterariam as formulas.

    E teria dois calculos, contas pagas e contas a pagar que seriam as somas das celulas marcadas como sim e nao.

    Por exemplo: eu tenho as contas Luz, Agua e Telefone nos valores de 100, 50 e 100. As tres marcadas como nao pagas. Ai teria uma formula calculando contas a pagar com o total 250. Entao eu pago a conta de Luz e marco como Paga, ai essa conta sairia do a pagar e entaria como paga, teria entao dois totais: a pagar 150 e pago 100.

    Espero que a explicaçao nao esteja muito confusa.

    Att.

    Carlos Augusto.

    quinta-feira, 8 de abril de 2010 14:42

Respostas

  • Se fosse comigo criaria três colunas. Uma contendo resposta se foram pagas (Sim/Não), outra do lado com condição SE para considerar o valor caso tenha sido paga e outra do lado com a mesma condição SE para considerar a que ainda não foi paga. Totalizaria no final destas colunas... Por exemplo, sendo colunas C para valor da conta, D para resposta Sim/Não, E e F para exibição do valor condicional...

    Na célula D2 entraria SIM ou NÃO, digitado

    Na célula E2 entraria a fórmula =SE(D2="SIM";C2;0)

    Na célula F2 entraria a fórmula = SE(D2="NÃO";C2;0)

    Lá embaixo, no final da coluna E uma função AutoSoma, assim como no final da coluna F. Pronto, total de contas pagas em E e não-pagas ainda em F.

    Colocaria ainda uma formatação condiconal nas colunas E e F para exibir com fonte cor branco as células que tenham zero (para ficar mais limpa a planilha). Acho que se colocar espaço em branco no lugar do zero, deve dar erro na somatória.


    Fernando Nishimura de Aragão . Se a resposta foi útil, clique no ícone ao lado para avaliar positivamente o participante. Obrigado.
    • Marcado como Resposta Richard Juhasz quarta-feira, 16 de janeiro de 2013 16:13
    quinta-feira, 8 de abril de 2010 17:30

Todas as Respostas

  • Se fosse comigo criaria três colunas. Uma contendo resposta se foram pagas (Sim/Não), outra do lado com condição SE para considerar o valor caso tenha sido paga e outra do lado com a mesma condição SE para considerar a que ainda não foi paga. Totalizaria no final destas colunas... Por exemplo, sendo colunas C para valor da conta, D para resposta Sim/Não, E e F para exibição do valor condicional...

    Na célula D2 entraria SIM ou NÃO, digitado

    Na célula E2 entraria a fórmula =SE(D2="SIM";C2;0)

    Na célula F2 entraria a fórmula = SE(D2="NÃO";C2;0)

    Lá embaixo, no final da coluna E uma função AutoSoma, assim como no final da coluna F. Pronto, total de contas pagas em E e não-pagas ainda em F.

    Colocaria ainda uma formatação condiconal nas colunas E e F para exibir com fonte cor branco as células que tenham zero (para ficar mais limpa a planilha). Acho que se colocar espaço em branco no lugar do zero, deve dar erro na somatória.


    Fernando Nishimura de Aragão . Se a resposta foi útil, clique no ícone ao lado para avaliar positivamente o participante. Obrigado.
    • Marcado como Resposta Richard Juhasz quarta-feira, 16 de janeiro de 2013 16:13
    quinta-feira, 8 de abril de 2010 17:30
  • Vc tb pode simplificar ainda mais esta solução apresentada acima.

    Utlize a fómula "somase" e tudo ficará mais leve.

    domingo, 3 de abril de 2011 06:20