none
Atualizacao pos SP3 - desativa DHCP RRS feed

  • Pergunta

  • Apos formatar uma maq. e instalar o win XP com SP3, pude instalar e configurar o antivirus (via web) e tudo ok..

    na sequencia fui atualizar o win xp, (creio que, Software Distribution Service 3.0) este procedimento desabilitou

    o cliente DHCP, com isto nao tive mais IP automatico e recebo a msg conectividade nula ou limitada...   Tentei varias alternativas para contornar (atribuir um ip estatico) mas nao tive mais acesso a web...

    Resultado, voltei um ponto de restauracao para antes da atualizacao do xp e... voltou a funcionar tudo ok... DHCP-IP.. etc..   Tentei uma vez mais fazer o update e deu novamente o erro...

     

    Este é um bug conhecido ?  existe alguma solucao (como devo proceder)

     

    Thaededan

    quarta-feira, 1 de outubro de 2008 17:36

Todas as Respostas

  •  

    Corvalao

    Isso não é bug, é um problema incomum

    Você verificou se o serviço DHCP estava inicializando?

     

    Seu problema pode ser driver de rede.. tente atualizar

    Modo Seguro com rede navega

    qual seu antivírus?

    quarta-feira, 1 de outubro de 2008 18:02
  • No primeiro teste q fiz tava com AVG...  no 2o passei para o Avira como antivirus...

    e em ambas deu este prob com o acesso a web

     

    sem fazer a atualizacao, o DHCP inicializa e atribui os IPs... (verifiquei no SERVICES, tanto clientes DHCP quanto DNS estao inicializados )   .. funciona a web...

     

    Nas 2 vezes que testei, atualizar o XP (q ja tem o SP3) o sistema "desativa" o DHCP..

    e a partir dai nao tenho IP e nem acesso a web....    (nesta situacao vou no SERVICES e

    consta que o DHCP nao foi inicializado, apenas o DNS...   com isto no start do XP

    demora um tempao e da a msg <conectividade nula ou limitada>)

     

    Para corrigir isto eu restauro o XP para a situacao anterior à atualizacao e tudo volta ao normal, apos reiniciar

    a maq...    DHCP funciona, atribui IP e tenho acesso a web...

     

    =======

    Vou verificar se tem atualizacao do driver de rede... mas nao estou muito entusiasmado que esta seja o

    problema para a atualizacao do xp

     

    obrigado e aguardo outras ideias

    Corvalao

    quarta-feira, 1 de outubro de 2008 18:51
  •  

    e se você iniciar o serviço obtém IP?

    ou ao tentar iniciar gera erro?

     

    tenta isso

    Com CD na unidade vá no  prompt de comando,

    na pasta c:\windows\system32
    Renomeie o arquivo: ren ipnat.sys ipnat.old
     
    ren tcpip.sys tcpip.old

    Expand d:\i386\ipnat.sy_ c:\windows\system32\drivers\ipnat.sys 
    Expand d:\i386\tcpip.sy_ c:\windows\system32\drivers\tcpip.sys 

    Reinicie a máquina em modo normal.


    quarta-feira, 1 de outubro de 2008 19:14