none
Problemas com DNS não permite inserir Servidor no domínio RRS feed

  • Pergunta

  • Boa Tarde a todos

    Tenho um Windows Server 2003 R2 que usamos como File Server, este servidor começou a apresentar alguns erros de acesso, tais como ao logar no servidor remotamente via TS com um usuário do domínio não permitir o acesso e retornar o erro "An invalid argument was supplied" , verifiquei que haviam diversos erros de DNS no Event Viewer, notei também que ao executar o camando "ipconfig /registerdns" o servidor apresenta o evento DnsApi ID:11167 informando que não conseguiu fazer o registro de DNS. O endereço de DNS está configurado manualmente na placa de rede.

    Para tentar solucionar o problema retirei a máquina do domínio, limpei todos os registros do nome da máquina no DNS server e no AD. Ao tentar ingressar a máquina novamente no domínio ocorre o erro:

    "An error occurred when DNS was queried for the service location (SRV) resource record used to locate a domain controller for domain rdom.local.

    The error was: "An invalid argument was supplied."
    (error code 0x00002726 WSAEINVAL)

    The query was for the SRV record for _ldap._tcp.dc._msdcs.rdom.local"

    Para isolar algum possível problema de hardware mudamos de placa de rede e ponto e o problema persiste, O problema ocorre somente neste servidor, pois não temos problemas com o dns de outras máquinas nem encontramos problemas ao inserir novas máquinas no dominio.

    O que posso fazer para corrigir este problema?

     

    quinta-feira, 27 de maio de 2010 19:23

Respostas

  • Rossi,

    Sua zona _MSDCS.DOMINIOexiste? Caso positivo tente apenas parar o servidor e iniciar o serviço de DNS novamente.

    No prompt de comando, digite NET STOP DNS<enter>
    depois NET START DNS <enter>

     Caso não exista a zona _MSDCS.DOMINIO recrie a zona seguindo o procedimento no link abaixo:
    http://www.linhadecodigo.com.br/ArtigoImpressao.aspx?id=2118

    Poste os erros do log de eventos, se possível.

    []'s


    Danilo G. Lima - MCT, MCSA, MCTS, MCP - Blog: http://daniloglima.spaces.live.com
    • Marcado como Resposta Richard Juhasz segunda-feira, 31 de maio de 2010 13:56
    quinta-feira, 27 de maio de 2010 19:50

Todas as Respostas

  • Rossi,

    Sua zona _MSDCS.DOMINIOexiste? Caso positivo tente apenas parar o servidor e iniciar o serviço de DNS novamente.

    No prompt de comando, digite NET STOP DNS<enter>
    depois NET START DNS <enter>

     Caso não exista a zona _MSDCS.DOMINIO recrie a zona seguindo o procedimento no link abaixo:
    http://www.linhadecodigo.com.br/ArtigoImpressao.aspx?id=2118

    Poste os erros do log de eventos, se possível.

    []'s


    Danilo G. Lima - MCT, MCSA, MCTS, MCP - Blog: http://daniloglima.spaces.live.com
    • Marcado como Resposta Richard Juhasz segunda-feira, 31 de maio de 2010 13:56
    quinta-feira, 27 de maio de 2010 19:50
  • Rossi,

    curiosidade, qual versão do windwos do teu AD?

    outra coisa, executou o prompt com "runs as" e usou as credenciais do domain admin?


    Éder Mércio Bampi
    quinta-feira, 27 de maio de 2010 20:44
  • Deleta as zonas integradas do ad aquelas "msdcs". daí reinicia o serviço de Net logon para o servidor recriar os registro do AD.
    Caso a reposta tenha resolvido por favor Marque esse post como "RESPOSTA" para que se encerre essa Thread. E se lhe foi util também Marque como "votar como Útil" Caso não tenha resolvido, sinta-se a vontade para fazer novas perguntas. MCP - Win2k3 server | MCP - Windows XP | MCDST - Windows XP | MCSA - Win2k3 Server.
    sexta-feira, 28 de maio de 2010 12:50