none
"O banco de dados de segurança no servidor não tem uma conta de computador para a relação de confiança desta estação de trabalho." RRS feed

  • Pergunta

  • Pessoal, antes de mais nada, já li todas as soluções postadas por aqui para esse tipo de problema e nenhuma delas resolveu. Meu cenário parece um pouco diferente.

    Eu tenho 3 DCs Windows Server 2008 R2 e 13 DCs Windows Server 2008 Standard. Todos os DCs são replicação do DC primário.

    De uns dois dias pra cá, alguns usuários começaram a relatar que quando iam trocar a senha após ter expirado, recebiam essa mensagem "O banco de dados de segurança no servidor não tem uma conta de computador para a relação de confiança desta estação de trabalho." Se eu reseto a senha no AD e não marco para trocar na primeira vez que loga, o usuário consegue autenticar e acessar a máquina numa boa. Se precisa trocar a senha, a mensagem aparece.

    Pedi para que tentassem fazer a troca da senha em outra máquina (são usuários diferentes, em diferentes locais autenticando em diferentes ADs). O erro persiste! Ou seja, o problema não é da máquina. Mesmo removendo a máquina do domínio, reiniciando, colocando novamente no domínio, reiniciando, ao tentar trocar a senha, o usuário recebe a mesma mensagem. Criei um usuário de teste e tentei fazer o acesso nas máquinas. Recebo a mesma mensagem.

    Eu disse que não era a máquina porque ocorre em qualquer máquina, correto? Agora vem a melhor parte: também não é o usuário. Ao tentar trocar a senha em uma máquina que autentica pelo DC primário, a senha é alterada numa boa. Assim como, se, no Active Directory Sites and Services, eu mudo aquela faixa de IP para se autenticar no DC primário, aquela máquina que antes dava a mensagem, agora também consegue efetuar a troca da senha, confirmando que não é a máquina e também não é o usuário. 

    Como isso começou a ocorrer com vários DCs, sendo todos Windows Server 2008 Standard (os DCs 2008 R2 ainda não apresentaram problemas), desconfio que o problema possa estar no próprio DC. Achei que pudesse ser algum update, mas não achei nada no tipo no Google.

    Minhas tentativas de descobrir o problema. Eu disse que ao resetar a senha, desmarcando aquela opção de alterar a senha na primeira vez que efetuar o login, o usuário consegue autenticar, certo? Pois para confirmar que estava autenticando no DC correto para aquele site, ao rodar o comando "set logon" no CMD, mostra que estou no DC correto. Ou seja, consigo autenticar, mas ao tentar trocar a senha, recebo a mensagem. Tentei rodar um telnet para o IP do DC nas portas 389, 88 e 464 e todas passam, o que também significa que a comunicação está aberta.

    O máximo que achei que poderia estar mais parecido com o meu problema é isso: https://technet.microsoft.com/pt-br/library/ee849847(v=ws.10).aspx , porém, não descobri o que fazer, qual passo a passo realizar para resolver o problema. E o mais estranho é que até poucos dias atrás estava tudo funcionando, e agora, de repente, começam a pipocar reclamações de diferentes sites do mesmo problema.

    Ah e quando tento fazer a replicação manual pelo repadmin, ela ocorre numa boa sem erro algum.

    Algum mestre dos magos me ajude, por favor!

    quarta-feira, 14 de junho de 2017 23:52

Todas as Respostas