none
como verificar a existência de um determinado algarismo num número qualquer RRS feed

  • Pergunta

  • boa tarde galera.

    preciso da ajuda de vcs. preciso de uma fórmula que verifica se existe um determinado algarismo num número. Os números não se repetem, mas podem ser 1 a 7. ex: 2567. verificar se existe o algarismo 5 no número 2567 e retornar um valor verdadeiro ou falso.

    segunda-feira, 24 de dezembro de 2018 16:21

Todas as Respostas

  • Bom dia Odilon.

    Você pode usar a fórmula Localizar. =LOCALIZAR(texto_procurado;no_texto;[núm_inicial])

    Supondo que o dado 2567 esteja na célula A1, em B2 a fórmula ficaria assim:

    =LOCALIZAR(5;A1;1)

    O resultado seria 2 que é a posição em que se encontra o valor procurado! Caso o valor não exista, retornará um erro! Ai teria que usar uma fórmula de tratamento de erros!

    quarta-feira, 26 de dezembro de 2018 09:40
  • Suponha o seu número em "A1":

    =SEERRO(SE(LOCALIZAR(5;A1)>0; "Verdadeiro"); "Falso")

    O ideal, porém, seria colocar o número a procurar em outra célula, como em "B1":
    =SEERRO(SE(LOCALIZAR(B1;A1)>0; "Verdadeiro"); "Falso")

    Abraço.


    Filipe Magno

    terça-feira, 1 de janeiro de 2019 23:47