locked
Intellisense não esta funcionando - SQL RRS feed

  • Pergunta

  • Por algum motivo o auto-complete do SQL Server não está funcionando.

    Dei uma olhada no Intellisense, e não consegui resolver.

    Se alguém tiver alguma ideia do que pode ser, eu agradeço.

    Abraços

    sexta-feira, 12 de julho de 2013 17:57

Respostas

  • Wescley, revendo o topico, vi que o SP que voce tem instalado no SQL é o SP1, de uma olhada no link abaixo da MS onde diz que em alguns casos no 2008 R2 quando esta com o SP1 o intellisense pode não funcionar, para isto ja tem uma atualização disponivel e até mesmo o SP2, tente instalar esta atualização ou o SP2.

    http://support.microsoft.com/kb/2531482/pt


    Alexandre Matayosi Conde Mauricio.

    • Sugerido como Resposta Alexandre Matayosi terça-feira, 16 de julho de 2013 12:49
    • Marcado como Resposta WFrohlich terça-feira, 16 de julho de 2013 12:53
    terça-feira, 16 de julho de 2013 12:41

Todas as Respostas

  • Wescley, qual a versão do seu SQL ?

    rode "select @@version" e veja se é 2008 ou superior...


    Alexandre Matayosi Conde Mauricio.

    sexta-feira, 12 de julho de 2013 18:21
  • Alexandre,

     Microsoft SQL Server 2008 R2 (RTM) -  (X64)   Apr 22 2011 19:23:43   Copyright (c) Microsoft Corporation  Standard Edition (64-bit) on Windows NT 6.1 <X64> (Build 7601: Service Pack 1) 

    sexta-feira, 12 de julho de 2013 18:37
  • O botão do Intellisense esta habilitado ? é o sexto botão depois do executar no SSMS.

    veja esta outra solução tambem:

    http://msdn.microsoft.com/pt-br/library/ms174207(v=sql.105).aspx


    Alexandre Matayosi Conde Mauricio.

    sexta-feira, 12 de julho de 2013 18:52
  • Está habilitado sim, e também já havia testado essas opções referente ao link mencionado.

    Também não funcionou.

    sexta-feira, 12 de julho de 2013 19:04
  • Geralmente ele demora alguns minutos para identificar os objetos do DB. 
    sexta-feira, 12 de julho de 2013 20:06
  • Reinicia o software, pode ter acontecido algum erro na memória do mesmo.
    sexta-feira, 12 de julho de 2013 20:47
  • É pessoal, não deu certo não.

    Até reinstalar o SQL eu fiz. Mas não está funcionando o auto-complete na criação das Querys.

    Alguma outra ideia ?

    Abraços

    terça-feira, 16 de julho de 2013 12:34
  • Wescley, revendo o topico, vi que o SP que voce tem instalado no SQL é o SP1, de uma olhada no link abaixo da MS onde diz que em alguns casos no 2008 R2 quando esta com o SP1 o intellisense pode não funcionar, para isto ja tem uma atualização disponivel e até mesmo o SP2, tente instalar esta atualização ou o SP2.

    http://support.microsoft.com/kb/2531482/pt


    Alexandre Matayosi Conde Mauricio.

    • Sugerido como Resposta Alexandre Matayosi terça-feira, 16 de julho de 2013 12:49
    • Marcado como Resposta WFrohlich terça-feira, 16 de julho de 2013 12:53
    terça-feira, 16 de julho de 2013 12:41
  • Fiz a atualização para o SP 2 e funcionou!

    Muito Obrigado Alexandre e a todos que tentaram ajudar!

    Abraços

    terça-feira, 16 de julho de 2013 12:47
  • Show de bola Wescley, só não se esqueça sempre de marcar como respostas as que te ajudaram a resolver o problema, assim sempre mantemos o forum atualizado para quem estiver com o mesmo problema buscarem por topicos respondidos.

    abs


    Alexandre Matayosi Conde Mauricio.

    terça-feira, 16 de julho de 2013 12:50