none
Somar valores com criterio de mes e ano RRS feed

  • Pergunta

  •  Boa Noite a todos,

     Estou com uma dúvida e gostaria de saber se vocês poderiam me ajudar. Tenho uma planilha da seguinte forma: Coluna A eu tenho datas (Ex:04/02/2018) e na coluna B eu tenho valores (Ex:100, 376,...). Gostaria de definir, em uma célula um ano escolhido e em outra, um mês escolhido. Gostaria de realizar a soma dos valores da coluna B, apenas do mês e do Ano devidamente escolhidos.

     Eu consigo realizar essa operação, apenas com um dos criterios com o "somarproduto", porém, não consigo com 2 criterios.

     Alguem consegue me ajudar?

    Ex

            A              B                            C           D

    04/02/2018     100                         2018      03

    05/03/2018     200  

    10/05/2018     400  

    15/10/2017     540 

    quarta-feira, 7 de março de 2018 23:34

Todas as Respostas

  • Boa noite Marcos,

    segue uma sugestão utilizando fórmulas de Banco de Dados (BDSOMA):

    Outra opção seria a utilização de fórmulas matriciais (Ctrl+Shift+Enter):

    {=SOMA(SE((MÊS(A2:A5)=D2)*(ANO(A2:A5)=C2);B2:B5;0))}

    Abraço.


    Filipe Magno

    terça-feira, 20 de março de 2018 01:15