none
Transferencia AD/GC/FSMO RRS feed

  • Pergunta

  • Boa tarde a todos da Comunidade,

    Afim de melhorar o desempenho do Controlador de Domínio em um Windows Server 2003, comprei um computador para substituir o atual DC. Aproveitando-me disto, não preciso manter o mesmo Nome/IP pois agora colocarei da minha forma, tendo em vista que não trabalhava aqui quando o mesmo foi instalado e configurado.

    Instalei e configurei todo o Server 2003 na nova máquina e agora estou com um problema nos procedimentos de transferencia:

    Segui o seguinte passo para TROCA DE FUNÇÃO FSMO:

    http://support.microsoft.com/kb/324801/pt-br

    Segui estes passos para TROCA DE GLOBAL CATALOG (Acho que aqui está o problema)

    http://support.microsoft.com/default.aspx?scid=KB;en-us;313994


    Também configurei o DNS no novo servidor e o mesmo funciona corretamente.

    Até aqui tudo OK.

    >>>> PROBLEMA <<<<<<<

    Mesmo com tudo transferido, ainda dependo do SERVIDOR ANTIGO ligado para que todos possam logar no Domínio. Com ele desligado o Domínio é dado como INEXISTENTE para todos na rede.

    Outra coisa é que quando vou RETIRAR o SERVIDOR ANTIGO do dominio, diz que ele é o ÚNICO GLOBAL CATALOG.

    O que eu posso ter feito de errado? Ou devo aguardar mais de 1h para a replicação do GLOBAL CATALOG para retirá-lo?

    OBRIGADO! Espero que possam me ajudar!

    quarta-feira, 24 de agosto de 2011 17:18

Respostas

  • Eduardo, pelo que está descrevendo o procedimento foi feito corretamente, porém, o DNS está causando falhas ainda.

    O DNS do Server01 você consegue visualizar a zona do seu dominio?

    Ela está como primária, neh!?

     

    Se puder, desligue o SERVIDOR e tente abrir o DNS no PDC - pare e inicie novamente o serviço de NETLOGON e DNS.


    Gustavo Valle | http://grvalle.com
    • Marcado como Resposta Richard Juhasz quarta-feira, 31 de agosto de 2011 19:05
    quinta-feira, 25 de agosto de 2011 18:02
    Moderador

Todas as Respostas

  • Execute o comando: netdom query fsmo

    Veja se todas FSMO estão no servidor novo.

    Acesse Sites e Serviços e nagegue até o server e NTDS do novo servidor e habilite-o como Catalogo Global.

     

    As estações estão apontado o DNS para o novo servidor?

     


    Gustavo Valle | http://grvalle.com
    quarta-feira, 24 de agosto de 2011 17:48
    Moderador
  • Olá amigo! Obrigado por responder.

    Vamos dar nome aos bois, correto?

    O ANTIGO SERVIDOR se chama "SERVIDOR" e o novo que quero instalar se chama "Server01". Ok!

     

    Executei o netdom query fsmo no Server01 (Novo) e ele é Owner de todas as configurações, logo parece estar OK esta parte.

    Em Sites e Serviços os dois servidores, tanto o ANTIGO, quanto o NOVO estão marcados como CATÁLOGO GLOBAL.

    Sobre o DNS, o meu DHCP está configurado e distribuindo o IP do NOVO CONTROLADOR.

    ----

    Ainda assim, quando eu executo o DCPROMO para RETIRAR o SERVIDOR ANTIGO, o mesmo ainda diz que é o ÚNICO CATALOGO GLOBAL DO DOMINIO.

    Sendo que tudo já está repassado e OK.

    Quando desligo o Controlador de Dominio Antigo, nem mesmo consigo logar via RDP no servidor novo, alegando que NãO EXISTE DOMÍNIO.

    Teria alguma outra dica?

     

    Obrigado novamente!


    quarta-feira, 24 de agosto de 2011 18:22
  • Outra coisa que notei foi que nas propriedades do NTDS o GERADOR DE TOPOLOGIA ENTRE SITES é o ANTIGO SERVIDOR.

    Seria isso o problema? Como mudo esse parametro? Estou na pesquisa para poder resolver.

    \

     

    Obrigado a todos! Continuarei nos testes.

    quarta-feira, 24 de agosto de 2011 19:09
  • Quando você promoveu o server01 ?
    Gustavo Valle | http://grvalle.com
    quarta-feira, 24 de agosto de 2011 19:13
    Moderador
  • Ele foi promovido para CONTROLADOR ADICIONAL na SEGUNDA-FEIRA.

    Hoje ao 12h segui estes procedimentos:

    1) Fiz as transferencias de FSMO.

    2) Configuração do DNS no NOVO Servidor.

    3) Ativo como Global Catalog, juntamente com o antigo.

    ------

    Mesmo o NOVO SERVIDOR como OWNER de todas as funções, se eu DESLIGAR o ANTIGO SERVIDOR, nada funciona. O domínio de alguma forma está ligado ao ANTIGO SERVIDOR.

    Quando vou RETIRAR o ANTIGO SERVIDOR das funções pelo DCPROMO, diz que ele é o ÚNICO na rede e que vou perder meu domínio.

    Basicamente foi isso.

    quarta-feira, 24 de agosto de 2011 19:19
  • Amigo se você está desligando o servidor antigo e ninguem consegue se logar pode ser que o erro o novo servidor não esteja com o CG.

     

    Tenta fazer o seguinte, Passa todos os mestres de operação para o servidor Antigo, Re mova o servidor novo do dominio.

    Verifique se a versão do Windows do Servidor Antigo (Windows 2003 ou Windows 2003 r2). Agora atualize o mesmo.

    No servidor novo Instale a mesma versão do Antigo e Atualize o mesmo.

     

    Servidor novo Add ele como DC adicional e um dominio existente.

    Agora Coloque ele como CG tb.

    Desligue o Servidor antigo e Veja se todos os consegue se logar. (Só lembrando que o DNS dos clientes tem que estar apontando para o Servidor NOVO).

    Se funcionar passe os mestre de operação para ele e deixe o Servidor Antigo desligado uma semana para vê alquem reclama.

     

    Espero ter ajudado.


    Fazzani - MCP, MCSA, MCTS-ISA,VISTA
    quarta-feira, 24 de agosto de 2011 19:23
  • Boa tarde a todos da Comunidade,

    Afim de melhorar o desempenho do Controlador de Domínio em um Windows Server 2003, comprei um computador para substituir o atual DC. Aproveitando-me disto, não preciso manter o mesmo Nome/IP pois agora colocarei da minha forma, tendo em vista que não trabalhava aqui quando o mesmo foi instalado e configurado.

    Instalei e configurei todo o Server 2003 na nova máquina e agora estou com um problema nos procedimentos de transferencia:

    Segui o seguinte passo para TROCA DE FUNÇÃO FSMO:

    http://support.microsoft.com/kb/324801/pt-br

    Segui estes passos para TROCA DE GLOBAL CATALOG (Acho que aqui está o problema)

    http://support.microsoft.com/default.aspx?scid=KB;en-us;313994


    Também configurei o DNS no novo servidor e o mesmo funciona corretamente.

    Até aqui tudo OK.

    >>>> PROBLEMA <<<<<<<

    Mesmo com tudo transferido, ainda dependo do SERVIDOR ANTIGO ligado para que todos possam logar no Domínio. Com ele desligado o Domínio é dado como INEXISTENTE para todos na rede.

    Outra coisa é que quando vou RETIRAR o SERVIDOR ANTIGO do dominio, diz que ele é o ÚNICO GLOBAL CATALOG.

    O que eu posso ter feito de errado? Ou devo aguardar mais de 1h para a replicação do GLOBAL CATALOG para retirá-lo?

    OBRIGADO! Espero que possam me ajudar!


    Os clientes estão apontando para o novo servidor DNS?
    Fazzani - MCP, MCSA, MCTS-ISA,VISTA
    quarta-feira, 24 de agosto de 2011 19:24
  • A replicação está sendo feita ? se criar um objeto no AD, é replicado automaticamente?

    Faça o mesmo teste com um registro DNS.

    O Server01 também está com DNS configurado neh!?

    Acredito que possa ser algo relacionado ao "prazo" para entendimento do dominio, para estas alterações.

     

    Execute também:

    nslookup

    set q=ns

    seudominio

    Veja se aparece os 2 servidores.

    E o comando:

    netdom query pdc

    É para aparecer o Server01


    Gustavo Valle | http://grvalle.com
    quarta-feira, 24 de agosto de 2011 19:27
    Moderador
  • A replicação está sendo feita ? se criar um objeto no AD, é replicado automaticamente?

    Faça o mesmo teste com um registro DNS.

    O Server01 também está com DNS configurado neh!?

    Acredito que possa ser algo relacionado ao "prazo" para entendimento do dominio, para estas alterações.

     

    Execute também:

    nslookup

    set q=ns

    seudominio

    Veja se aparece os 2 servidores.

    E o comando:

    netdom query pdc

    É para aparecer o Server01


    Gustavo Valle | http://grvalle.com

    1) Tudo está sendo replicado de um para o outro.

    2) O DNS também está duplicando.

    3) Seguem testes pedidos, deu um erro:

    quarta-feira, 24 de agosto de 2011 19:48
  • Olá galera! Como faço para alterar esse valor em Sites e Serviços do Active Directory, no NTDS Settings do Primeiro-site-Padrão.

    Queria tirar o SERVIDOR e inserir o Server01.

    quinta-feira, 25 de agosto de 2011 11:00
  • Eduardo, isso não influencia em nada. Quando despromover, não aparecerá mais.

    Tem coisas, que é melhor deixar o sistema alterar :)

     

    Tentou hoje novamente ? (após algumas horas)

    Desligue o SERVIDOR e veja no Server01 os logs que vão aparecer, caso continue com as falhas.


    Gustavo Valle | http://grvalle.com
    quinta-feira, 25 de agosto de 2011 12:04
    Moderador
  • Bom dia.

    Faça um teste da seguinte forma.

    Desligue o servidor antigo, sem despormove-lo, para que você possa volta-lo a rede caso necessário.

    Ficara apenas os servidor novo na rede, sigua os passos desse link: http://matheusbertuco.wordpress.com/2011/04/01/transferindo-fsmo-de-um-servidor-que-nao-existe-mais-para-um-novo/ e veja se resolve seu problema, se sim você pode formatar seu servidor antigo, se não você deve voltar o servidor antigo e refazer o servidor secundário.

    Abraço.


    Se útil, classifique.
    Matheus M. Bertuco
    MCT, MCSA, MCTS, MCP.
    Meu Blog: http://matheusbertuco.wordpress.com/
    Uma nova comunidade técnica: http://www.msitpro.com.br/

    quinta-feira, 25 de agosto de 2011 12:32
    Moderador
  • Ok.

    Ontem fiz o que Felipe pediu.

    Repassei tudo para o antigo servidor, despromovi o Server01 (NOVO). Ontem mesmo recoloquei-o como DC Adicional e passei o Catálogo Global.

    Hoje quando desligo o SERVIDOR ANTIGO, o domínio para.

    Segue os logs do SERVER NOVO.

     

     

    Tipo de evento: Erro

    Fonte de evento: DNS

    Id. do evento: 4015

    Computador: SERVER01

    O servidor DNS encontrou um erro crítico no Active Directory. Verifique se o Active Directory está funcionando corretamente. As informações estendidas de depuração de erro (que podem estar em branco) são "". Os dados do evento contêm o erro.

     

    ------------------------------------------------------------------------------------------------------

    Tipo de evento: Erro

    Fonte de evento: DNS

    Id. do evento: 4007

    Computador: SERVER01

    O servidor DNS não pôde abrir a zona _msdcs.guidoni.local no Active Directory da partição de diretório de aplicativos ForestDnsZones.guidoni.local. O servidor DNS está configurado para obter e usar informações do diretório para essa zona e não pode carregar a zona sem elas. Verifique se o Active Directory está funcionando corretamente e recarregue a zona. Os dados do evento são o código de erro.

     

    Amigos! Dá esse erro quando desligo o ANTIGO SERVIDOR. O que pode ser?

    Acho que estamos chegando perto do erro. Estou testando e verificando configurações.

    Obrigado novamente!

     

     

    quinta-feira, 25 de agosto de 2011 14:37
  • Bom dia.

    Faça um teste da seguinte forma.

    Desligue o servidor antigo, sem despormove-lo, para que você possa volta-lo a rede caso necessário.

    Ficara apenas os servidor novo na rede, sigua os passos desse link: http://matheusbertuco.wordpress.com/2011/04/01/transferindo-fsmo-de-um-servidor-que-nao-existe-mais-para-um-novo/ e veja se resolve seu problema, se sim você pode formatar seu servidor antigo, se não você deve voltar o servidor antigo e refazer o servidor secundário.

    Abraço.


    Se útil, classifique.
    Matheus M. Bertuco
    MCT, MCSA, MCTS, MCP.
    Meu Blog: http://matheusbertuco.wordpress.com/
    Uma nova comunidade técnica: http://www.msitpro.com.br/

    Olá Matheus!

    Rapaz, eu retirei ele como DC Adicional e adicionei novamente, fiz seus passos e continua o problema.

    Estou com problema no DNS.

    Se eu desativar o DNS do servidor antigo, a rede não loga, não encontra o domínio e etc.

    O problema está no DNS.

    quinta-feira, 25 de agosto de 2011 17:58
  • Eduardo, pelo que está descrevendo o procedimento foi feito corretamente, porém, o DNS está causando falhas ainda.

    O DNS do Server01 você consegue visualizar a zona do seu dominio?

    Ela está como primária, neh!?

     

    Se puder, desligue o SERVIDOR e tente abrir o DNS no PDC - pare e inicie novamente o serviço de NETLOGON e DNS.


    Gustavo Valle | http://grvalle.com
    • Marcado como Resposta Richard Juhasz quarta-feira, 31 de agosto de 2011 19:05
    quinta-feira, 25 de agosto de 2011 18:02
    Moderador
  • Olá Eduardo.

    Alguma novidade sobre o problema?

     

    Abraço.


    Richard Juhasz - Microsoft LATAM Forum Support Engineer
    http://www.forumguys.com.br
    sexta-feira, 26 de agosto de 2011 17:28