none
Não foi possivel iniciar a máquina virtual porque o hypervisor não esta em execução. RRS feed

  • Pergunta

  • Saudações amigos, tenho um servidor HP proliant dl380 G5, com processador intel xeon E4205 2.ooGHz no qual instalei o Hyper-v server 2008 R2.Após instalado e configurado, acesso o mesmo atraves da console de gerenciamento mas ao tentar startar uma VM aparece a mensagem:Não foi possivel iniciar a máquina virtual porque o hypervisor não esta em execução. Vi em alguns fóruns que 3 opção devem estar ativas: 1° Processor hyper-threading - Não existe esta opção.
                2° No-Execute Memory Protection - Se eu coloco ENABLE da "Tela Azul" e não deixa iniciar.
                3° Intel(R) Virtualization Technology - Esta eu  habilitei e esta OK.

    Outra procedimento que tentei fazer, é um diagnóstico com o software Securable, o mesmo acusa que o DEP esta OFF, tentei ativá-lo por linha de comando e procurar algo pela bios, mas nada resolveu.

    Desde ja agradeço a atenção de todos e aguardo um retorno positivo de alguem que ja tenha tido este problema.


    quarta-feira, 18 de janeiro de 2012 18:20

Respostas

  • Boa Tarde.

    Estava sofrendo com esta bendita Tela azul, apos ativar o   2° No-Execute Memory Protection -       3° Intel(R) Virtualization Technology -
    1º Desative estas duas opções, e inicie o Windows normalmente
    2º Baixa esta atualizaçao abaixo da microsoft -> http://support.microsoft.com/kb/974598
    3º Aplique a atualização  no Servidor Windows 2008 R2 ou Hyperv R2
    4º Reinicie, Entre na Bios do Dl380 G5  ative aquelas duas opções:  No-Execute Memory Protection -   Intel(R) Virtualization Technology -
    5º Desligue a maquina da energia aguarde 5 minutos, inicie novamente
    Pronto graças a deus a maquina vai iniciar"
    Vlwww...
    Funciono comigo....

    Pacote:

     

    -----------------------------------------------------------

    -----------------------------------------------------------

    Número(s) do artigo(s) da Base de Dados de Conhecimento: 974598

    Idioma: All (Global)

    Plataforma: x64

     

    Localização: (http://hotfixv4.microsoft.com/Windows%207/WindowsServer%202008%20R2/sp1/fix287338/7600/free/396293_intl_x64_zip.exe
    • Marcado como Resposta Richard Juhasz terça-feira, 7 de fevereiro de 2012 12:51
    sexta-feira, 27 de janeiro de 2012 18:01

Todas as Respostas

  • Marcelo, Boa tarde

    Dê uma olhada nessa Threads irá te ajudar: 

    http://social.technet.microsoft.com/Forums/pt-BR/virserverpt/thread/0478f32e-68e5-47b5-aec0-75253f718e53/

    [ ]'s


    ITIL V3 Foundations | http://guilhermemaia.org
    quarta-feira, 18 de janeiro de 2012 18:30
  • Bom dia Guilherme,

    Obrigado primeiramente.Fiz o procedimento,não funcionou, na verdade não sei o que eu ainda não fiz..rsrs - Desconfio da possibilidade do meu hardware não poder virtualizar, também fiz um teste instalando o Windows Server 2008>habilitei o hyper-v, e deu a mesma mensagem.Então tentei habilitar o DEP, mas janele aparece como a imagem abaixo, não deixando eu mexer.Se houver mais algum procedimento ficarei agradecido.

    quinta-feira, 19 de janeiro de 2012 13:37
  • Marcelo,

    Estou procurando no site da Intel e não achei este modelo do seu processador, confira qual é para que podemos ver se ele tem suporte a Virtualização e DEP.

    Para sanarmos uma solução.

    [ ]'s


    ITIL V3 Foundations | http://guilhermemaia.org
    quinta-feira, 19 de janeiro de 2012 13:43
  • Certo, farei isso agora mesmo.
    quinta-feira, 19 de janeiro de 2012 13:44
  • Segue o diagnóstico da ferramenta que a Intel disponibiliza:

    quinta-feira, 19 de janeiro de 2012 13:51
  • quinta-feira, 19 de janeiro de 2012 13:51
  • Olá Marcelo, beleza

    que forma que voce instalou o Hyper-V: Server Core ou instalar o role (função) de Hyper-V em um servidor Windows 2008 ?

    O hardware que voce aparentemente(Intel Xeon 64 bit) suporta a função.

    Voce pode entrar na bios do servidor na hora de fazer boot e verificar que Hardware Virtualization está habilitado(uma propriedade do processador).

     

    Abraço, Nassim


    http://tekniblog.wordpress.com
    quinta-feira, 19 de janeiro de 2012 14:04
  • Marcelo,

    Seu processador suporta sim, virtualização

    Confira o que o nossa amigo NassimJD disse, que deve estar desabilitado na placa mãe de seu servidor.

    Aguardamos respostas.

    [ ]'s


    ITIL V3 Foundations | http://guilhermemaia.org
    quinta-feira, 19 de janeiro de 2012 14:12
  • Então, respondendo a pergunta do nosso amigo NassimJD, primeiro instalei o Hyper-V Server = não deu.

    Dai instalei o Windows Server 2008, habilitei a função hyper-v e dava o mesmo erro, ou seja, tentei das duas formas.Agora estou novamente com o hyper-v instalado nele.

    Na BIOS, a única função que encontrei é a Intel Virtualization(nenhuma outra faz referência a virtualização) que já esta habilitada, mesmo assim, já tentei desabilita-la>desligar o server>tirar da tomada e depois habilitar tudo novamente.O erro permanece.x-|

    quinta-feira, 19 de janeiro de 2012 15:15
  • Complementando minha análise anterior, segue link utilizado:

    http://itbod.wordpress.com/2009/10/07/how-to-enable-the-intel-vt-virtualisation-feature-on-a-supported-hp-proliant-server-running-esx-3-5-so-that-64-bit-guest-vm%E2%80%99s-can-run/

     

    quinta-feira, 19 de janeiro de 2012 15:33
  • Amigos, alguma novidade?

    Desde já muito obrigado.

    quinta-feira, 19 de janeiro de 2012 18:44
  • Marcelo

    da um tasklist /s 10.0.0.1

    onde no lugar do 10.0.0.1 voce digita o IP do seu hypervisor.

    Cole aqui para gente ver os serviços rodando no seu servidor.

    Abraço, Nassim
    http://tekniblog.wordpress.com
    sexta-feira, 20 de janeiro de 2012 14:16
  • Marcelo,

    Execute o comando bcdedit /set hypervisorlaunchtype auto reinicie o servidor e verifique se o problema persiste.

    Antes de executar o comando você pode executar o comando bcdedit e verificar se a entrada hypervisorlaunchtype existe e está configurada para auto.

     

    domingo, 22 de janeiro de 2012 02:41
  • Certo amigos.

    Farei os testes.

    domingo, 22 de janeiro de 2012 14:50
  • E ai Aloisio blz, o comando deu executado com êxito, mas o erro permaneceu o mesmo.
    segunda-feira, 23 de janeiro de 2012 13:29
  • E ai Nassim, segue imagem:

    segunda-feira, 23 de janeiro de 2012 13:30
  • marcelo,

    o software parece ok.

    um teste rápido antes de voltar para o hardware , vamos verificar se  DEPde hardware está ok, digite o comando

    wmic OS Get DataExecutionPrevention_Available

    se dê true então ok, se não vamos voltar para o hardware

    na BIOS verifique o seguinte

    • HW Prefetcher: Habilitado
    • Adjacent Sector Prefetch: Habilitado
    • No-Execute Memory Protection: Habilitado
    • Intel (R) Virtualization Technology: Habilitado
    • Expansion Card Caching Optimization: Desabilitado
    • Low Power Halt State (Intel C1E): Habilitado
    • Intel Core C3 State: Habilitado
    • Processor Core Disable: todos os cores Habilitado

    sette essas e se de certo entre no windows e execute o DEP do windows no hyper-V server.

    Abraço, Nassim

     


    http://tekniblog.wordpress.com
    segunda-feira, 23 de janeiro de 2012 18:03
  • Ola NassimJD, o resultado deu FALSE.

    Da verificação de hardware que você solicitou apenas a opção: No-Execute Memory Protection não consigo deixar habilitado, ou seja, se eu habilito ela, no momento que o meu server vai carregar o SO da tela azul...Mencionei na primeira postagem, será que neste caso o problema é com  hardware?

    segunda-feira, 23 de janeiro de 2012 18:20
  • Marcelo,

    Essa opção deve ficar habilitada. Qual a mensagem da tela azul?

    Se o computador reiniciar rapidamente durante a tela azul, no próximo boot aperte F8 e desabilite o reinicio automático em caso de erro, para poder visualizar a mensagem.

    segunda-feira, 23 de janeiro de 2012 18:49
  • Certo, farei o teste e postarei o mais rapido possivel.
    segunda-feira, 23 de janeiro de 2012 18:56
  • olá Marcelo, do que eu li sobre esse servidor que ele suporta virtualização (Vmware) e deve (más não necessariamente) suportar o Hyper-V. Parece que esse servidor foi feito para storage, caso o HD de boot é SCSI etnão Hyper-V não vai dar certo, te que ser IDE.

    se o servidor ainda está com garantia , conversa com o pessoal da HP ou o representante sobre a situação

    Abraço, Nassim


    http://tekniblog.wordpress.com
    terça-feira, 24 de janeiro de 2012 13:32
  • Nassim,

    Essa informação é verdadeira para as VMs e não para o Host. As VMs precisam de disco IDE para o boot.

    Para o Host ainda não existe essa limitação.

    Aloisio

    terça-feira, 24 de janeiro de 2012 13:38
  • Olá pessoal, de fato o HD do server é SCSI como na imagem gerada pelo Everest que segue abaixo.

    Neste caso, o que o amigo Aloisio quis dizer, é que na minha interface de gerenciamento do hyper-v, devo configurar meu HD Virtual para do tipo IDE é isso amigo Aloisio?

    Desde já obrigado pela atenção.


    quarta-feira, 25 de janeiro de 2012 11:00
  • Marcelo,

    A questão disco que eu comentei sobreo disco IDE não se aplicao ao seu caso.

    O disco IDE é obrigatoriamente usado para o boot das máquinas virtuais, ou seja, o disco virtual que tem o SO da VM instalado tem que ser IDE.

    Para o Host (a máquina física) isso não se aplica.

    quarta-feira, 25 de janeiro de 2012 11:38
  • Olá amigos

    Aloisio, obrigado pela correção que o "Hyper-V"precisa bootar por IDE, deveria ter completado "Hyper-V vm's".

    No caso do Marcelo, ele não tem nem um disco IDE para bootar as VM's, talvez isso que está causando os probs.

     

    Abraço, Nassim


    http://tekniblog.wordpress.com
    quarta-feira, 25 de janeiro de 2012 18:12
  • Então amigos, desculpe a demora.

    O server foi levado para uma empresa parceira nossa, os mesmos solucionaram o problema de a máquina virtual não startar atualizando a BIOS e a Firmware.Foram 3 horas baixando e instalando as atualizações.

    No entanto, a máquina virtual trabalha por cerca de 20 minutos e após da tela azul no server, possivel que dai em diante seja hardware.

    Mas fica aqui meu agradecimento á todos vocês!

    sexta-feira, 27 de janeiro de 2012 13:48
  • Marcelo, tente o que o Douglas está falando no post anterior ai em cima.

    Parece que deu essa tela azul com muitas pessoas para ter um hotfix.

    Douglas +1.

     

    Abraço, Nassim


    http://tekniblog.wordpress.com
    quarta-feira, 1 de fevereiro de 2012 17:04
  • Para mim, funcionou habilitando a primeira opção em negrito!

    Obrigado!

    sábado, 14 de dezembro de 2013 15:08
  • Nossa cara, que post grande, todo mundo ajudando, eu li todas respostas e procurei se alguém falava de atualizar bios, porque o problema não é o processador e sim a placa mãe, porque se o DEP não liga e dá tela azul, é da placa mãe. Mas já que deu certo então só fechar o tópico.
    sábado, 14 de dezembro de 2013 15:29