none
Cannot drop database because its begin used for replication RRS feed

  • Pergunta

  • Fiz o seguinte:

     

    Fiz um backup full

     

    Tirei as replicações e publishers, ditributors.

     

    Restaurei o backup com os datafiles em outro disco.

     

    Agora não consigo excluir o banco de dados

     

    Que eu faço ?

    terça-feira, 5 de junho de 2007 19:23

Respostas

  • Eita tinha esquecido do meu post, desculpem-me.

     

    Fiz o seguinte:

     

    em master.sysdatabases alterei o campo category para 0 onde o nome do banco é igual ao banco com problema. (hehehe)

     

    Aí consegui dar um detach no banco.

     

    Movi os datafiles para outro disco (essa era a idéia inicial) e dei um attach.

     

    Bom ainda permaneci com o problema de replicação, pois o crm da microsoft é bem chatinho nisto.

     

    Consegui através de uma consultoria uns tutoriais, onde encontrei um script que recria a replicação para o Ms-CRM.

     

    Tudo funcionando agora.

    quarta-feira, 13 de junho de 2007 14:11

Todas as Respostas

  •  

     

    use a

     

    sp_removedbreplication  'nome_banco'

     

    Abs;

    quarta-feira, 6 de junho de 2007 10:43
  • Rick,

     

    Todo processo de replicação foi excluído sem problemas!!!

     

    Neste caso você deverá remover o status de banco replicado, para isso execute esta stored procedure, na máquina que esta configurada como Publisher.

     

    sp_removedbreplication 'seubanco'

     

     

    quarta-feira, 6 de junho de 2007 11:08
    Moderador
  • Eu tentei rodar essas sps, mas não deu certo.

     

    Então eu fiz o seguinte, entrei no master, abri a tabela sysobjects, achei o banco e alterei o tipo de banco para 0.

    Agora consegui excluir (ou melhor desatachar) o banco.

     

    Agradeço a ajuda, vlw pessoal.

    quarta-feira, 6 de junho de 2007 11:39
  • Rick,

     

    Neste caso é melhor excluir o banco e criar tudo novamente, desta forma, o SQL Server vai refazer todas as entradas deste banco.

    quarta-feira, 6 de junho de 2007 11:59
    Moderador
  • Eita tinha esquecido do meu post, desculpem-me.

     

    Fiz o seguinte:

     

    em master.sysdatabases alterei o campo category para 0 onde o nome do banco é igual ao banco com problema. (hehehe)

     

    Aí consegui dar um detach no banco.

     

    Movi os datafiles para outro disco (essa era a idéia inicial) e dei um attach.

     

    Bom ainda permaneci com o problema de replicação, pois o crm da microsoft é bem chatinho nisto.

     

    Consegui através de uma consultoria uns tutoriais, onde encontrei um script que recria a replicação para o Ms-CRM.

     

    Tudo funcionando agora.

    quarta-feira, 13 de junho de 2007 14:11