none
FORMULA MATRICIAL EXCEL RRS feed

  • Pergunta

  • LI algumas postagens ... mas ainda não consegui resolver meu problema

    tenho uma tabela  de vendas, separadas por regiões e cidades. é uma tabela com 400 cidades separadas por cinco regiões de vendas. postei apenas uma parte para facilitar.

    Preciso ordenar os 5 maiores vendedores por região. 

    exemplo: quais os 5 cidades com maior número de vendas da região 5?

    preciso de uma tabela com o nome da cidade e o total de vendas. na tabela abaixo as cidades de são miguel e xanxere estão empatadas em número de vendas no segundo lugar, bem como as cidades de pinhaliznho e abelardo. O desempate tem que ser por ordem alfabética. O ideal é usar um fórmula matricial para que não precise ficar escondendo colunas.

    REGIÃO CIDADE VENDAS
    1 floripa 426
    3 blumenau 98
    1 são josé 57
    1 palhoça 32
    3 rio do sul 26
    5 chapecó 24
    3 jaraguá do sul 20
    3 itajaí 15
    4 lages 12
    3 canoinhas 12
    2 imbituba 12
    5 são miguel 11
    5 xanxere 11
    5 pinhalzinho 9
    5 abelardo 9
    5 xaxim 7
    5 dionísio 5
    5 itapiranga 6

    domingo, 10 de abril de 2016 18:56

Respostas

  • Boa tarde

    Considerando que teus dados se encontrem nas colunas A, B e C, na coluna na célula G2 copie e cole a formula abaixo e arrste até a célula G6, já que você só quer os 5 maiores.

    =MAIOR(C2:C19;LIN(A1))

    Na célula G2 copie e cole a afomrula baixo e arraste até a célula F6:

    =ÍNDICE($B$2:$B$19;MENOR(SE($C$2:$C$13=G2;LIN($1:$12));CONT.SE($G$2:G2;G2))) --> como esta fórmula é matricial não se esqueça de clicar em CTRL+SHIFT+ENTER

    Dê retorno.

    Caso seja útil vote e coloque como resposta!



    • Editado Patropi segunda-feira, 11 de abril de 2016 20:09
    • Marcado como Resposta FORMULA MATRICIAL terça-feira, 12 de abril de 2016 23:53
    segunda-feira, 11 de abril de 2016 20:09

Todas as Respostas

  • Boa tarde,

    Crie uma tabela dinâmica sobre os dados:

    - Em rótulos de linha insira o a coluna CIDADE

    - Em valores insira a coluna VENDAS (na configuração do campo, defina como produto)

    - Na tabela dinâmica criada, vá até o filtro de valores (Rótulos de Linhas) e selecione a opção de 10 primeiros, irá abrir uma caixa de dialogo, nesta caixa troque 10 por 5

    - Insira a segmentação de dados sobre a tabela dinâmica e clique sobre a opção REGIÃO

    segunda-feira, 11 de abril de 2016 17:00
  • Boa tarde

    Considerando que teus dados se encontrem nas colunas A, B e C, na coluna na célula G2 copie e cole a formula abaixo e arrste até a célula G6, já que você só quer os 5 maiores.

    =MAIOR(C2:C19;LIN(A1))

    Na célula G2 copie e cole a afomrula baixo e arraste até a célula F6:

    =ÍNDICE($B$2:$B$19;MENOR(SE($C$2:$C$13=G2;LIN($1:$12));CONT.SE($G$2:G2;G2))) --> como esta fórmula é matricial não se esqueça de clicar em CTRL+SHIFT+ENTER

    Dê retorno.

    Caso seja útil vote e coloque como resposta!



    • Editado Patropi segunda-feira, 11 de abril de 2016 20:09
    • Marcado como Resposta FORMULA MATRICIAL terça-feira, 12 de abril de 2016 23:53
    segunda-feira, 11 de abril de 2016 20:09
  • pATROPI.. .VOCÊ é muito fera... deu certinho... 

    abraço.

    terça-feira, 12 de abril de 2016 23:54
  • Patropi... deu um probleminha... quando tentei aplicar a fórmula para um número maior de dados ocorreu o seguinte: 

    quando eu peço os cinco maiores vendedores, por exemplo, da região 1, ela acaba me trazendo a cidade de blumenau como segundo maior vendas.. quando na verdade deveria ser são josé.

    a fórmula está buscando sempre a primeira referência. quando as referencias estão na mesma região de vendas... sem problemas... mas quando estão em regiões diferentes faz uma diferença enorme.

    REGIÃO CIDADE VENDAS
    1 floripa 426
    3 blumenau 57
    1 são josé 57
    1 palhoça 32
    3 rio do sul 26
    5 chapecó 24
    3 jaraguá do sul 20
    3 itajaí 15
    4 lages 12
    3 canoinhas 12
    2 imbituba 12
    5 são miguel 11
    5 xanxere 11
    5 pinhalzinho 9
    5 abelardo 9
    5 xaxim 7
    5 dionísio 5
    5 itapiranga 6




    quarta-feira, 13 de abril de 2016 01:22
  • Bom dia

    Poste uma planilha de exemplo, demonstrando manualmente os resultado esperados num site gratuito como 

    www.sendspace.com

    Depois cole link da planilha aqui.

    []s

    domingo, 17 de abril de 2016 13:16