locked
Net Framework 3.5 para SQL Server 2008 RRS feed

  • Pergunta

  • Pessoal,

    Estou tentando instalar o sql server 2008 no Server 2008 mas toda vez ele pede para instalar o net framework 3.5. Até aí eu entendi, mas fui na lista de ítens instalados e eu vejo o 3.5 sp1 e o 3.5 linguage pack - ptb.

    Mas mesmo assim ele não instala !!

    Aí baixei o tal 3.5, pedi para executar...abre a tela de instalação.. e quando acaba o download aparece uma tela seguinte dizendo somente "SETUP ERROR" e mais nada no resto. O botão embaixo está escrito "exit"

    Desinstalei os demais e instalei este pacote que eu não conseguia instalar... aí instalou.

     

    Mas quando tento instalar o sql dá o mesmo erro, que precisa de um netframwork 3.5.

    O que pode ser ??

    terça-feira, 25 de janeiro de 2011 14:33

Respostas

  • Olá Cíntia

    Tenho boas novidade :)

    SQL Server supports all languages that are supported by Windows operating systems.

    Cross-Language Support

    • The English-language version of SQL Server is supported on all localized versions of operating systems.

    • Localized versions of SQL Server are supported on localized operating systems with the corresponding language or on English-language versions of supported operating systems by using the Windows Multilingual User Interface Pack (MUI) settings. For more information, see How to: Change Operating System Settings to Support Localized Versions.

    • Localized versions of SQL Server can only be upgraded to localized versions of the same language, and cannot be upgraded to the English-language version.

    • Localized versions of SQL Server can also be installed side by side with English-language instances of SQL Server.


    Você precisa instalar o Language Pack de Português em seu sistema operacional para depois efetuar a instalação do SQL em Português

    Qualquer duvida me procure!!!

    Ref.: http://msdn.microsoft.com/en-us/library/ee210665.aspx


    Fábio Oliveira Support Engieer | Microsoft Enterprise and Developer Support
    sexta-feira, 28 de janeiro de 2011 18:50

Todas as Respostas

  • Cintia,

     

    Foi efetuado um boot na maquina? creio que possa ajudar....

    terça-feira, 25 de janeiro de 2011 14:48
    Moderador
  • Sim, várias vezes.
    terça-feira, 25 de janeiro de 2011 14:50
  • CIntia,

     

    Da uma olhadinha neste link, é um pouco extenso mas achei bem legal, creio que possa ajuda:

    http://blogs.msdn.com/b/psssql/archive/2008/08/11/sql-server-2008-visual-studio-2008-sp1-and-net-framework-3-5-sp1-explained.aspx

    terça-feira, 25 de janeiro de 2011 15:10
    Moderador
  • Não vi onde esse link poderia me ajudar.

     

    Msm assim, obrigada pela resposta.

    terça-feira, 25 de janeiro de 2011 16:10
  • Cintia,

     

    Link errado desculpe, o correto é:

    http://www.sqlservercentral.com/Forums/Topic623168-391-1.aspx

     

    Tente não apenas instalar o .net 3.5, mas sim o .net 3.5 sp1....

    ou seja, este link aqui -> http://www.microsoft.com/downloads/en/details.aspx?FamilyID=ab99342f-5d1a-413d-8319-81da479ab0d7&displaylang=en

     

    ------------------------------------------------------------------------------------------

    Para dicas em SQL Server e mais: www.onlywhatmatters.wordpress.com

    quarta-feira, 26 de janeiro de 2011 10:28
    Moderador
  • Eu já havia mencionado acima que instalei o sp1...

     

    E não teve solução este caso do link.

    quarta-feira, 26 de janeiro de 2011 16:35
  • estava com este mesmo problema, rodei a atualização do windows e marquei todos aqueles que faziam referencia ao .net. depois da instalação da atualização reiniciei a máquina e tudo certo! ;)
    +MCDBA +MCSE
    • Sugerido como Resposta Diogo Pettres quarta-feira, 26 de janeiro de 2011 18:47
    • Não Sugerido como Resposta Cíntia Simões quinta-feira, 27 de janeiro de 2011 11:16
    quarta-feira, 26 de janeiro de 2011 17:34
  • Cintia,

    Faça o procedimento realizado e indicado pelo Diogo, acredito que você esta sofrendo com conflitos de versões do .Net Framework instalados na máquina.


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário | MSIT.com]
    quarta-feira, 26 de janeiro de 2011 18:09
    Moderador
  • Junior e Diogo,

     

    É para baixar todos as atualizações que tenha o net framework ?

    Se é isso eu já baixei. Aliás, nem tem mais nada pra atualizar. Já baixei todas elas.

    quinta-feira, 27 de janeiro de 2011 11:10
  • Oi Cintia,

    Vamos lá! durante o processo de instalação você recebe uma msg de error que falha pois existe uma dependência do .Net 3.5 certo.

    Mande nos o sumary.txt da sua ultima tentativa de  instalação (C:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\Log) para que possamos verificar qual objeto está falhando e como podemos te ajudar.

    preencha os seguintes dados para que possamos entender seu ambiente:
    Operating System:
    Service Pack :
    SQL Version and Edition:
    Platform: x86/x64

    Just a Friendly reminder: Sei que você esta sobre pressão, mas tente ser um pouco mais sutil com nossos colegas que estão tentando te ajudar =)


    Fábio Oliveira Support Engieer | Microsoft Enterprise and Developer Support
    quinta-feira, 27 de janeiro de 2011 13:20
  • Fabio,

    Não tinha a pasta 100, tinha a 90, mas essa era do 2005 que eu tinha instalado.

    Explorando a pasta onde tem a instalação do 2008, achei uma chamada setup e abri o arquivo setup.exe. Acusou um erro dizendo que aquele não era instalador e tal, mas quando voltei para esta pasta que você indicou, vi que foi criada a pasta 100\setup bootstrap\log, mas dentro da pasta de log não tem o summary, mas tem uma pasta chamada watson_1 (dentro tem um arquivo chamado watson.mft) e dois arquivos "registry_software_microsoft_mssqlserver.reg_ e registry_software_microsoft_windows_currentversion_uinstall.reg_ .

    Na pasta lá do 2005 tem o arquivo summary e vem dizendo que a instalação foi concluída com sucesso.

    Estou tentando instalar sql server 2008 enterprise no server 2008 enterprise sp2.


    Será que tem haver pq estou instalando o sql em português e meu sistema está em inglês ? Nunca tive problema em instalar em diferentes linguagens.

     

    sexta-feira, 28 de janeiro de 2011 17:38
  • Oi Cíntia,

    Xiiiiiiii

    Estou atualmente envolvido em um chamado com o mesmo problema SO em Inglês e SQL em Pt-Br e até o momento só foi possível efetuar a instalação do SQL em inglês, não sei se há alguma incompatibilidade do Native client e support Tools em relação ao idioma.

    Estamos trabalhando para tentar identificar a causa, mas se você puder tentar efetuar a instalação do SQL em inglês para verificarmos se o mesmo problema ocorre também com o SQL em inglês ...

    Se quiser pode me chamar através do msn que assim que tiver uma solução eu te aviso !!!

    Obrigado, :)

     


    Fábio Oliveira Support Engieer | Microsoft Enterprise and Developer Support
    sexta-feira, 28 de janeiro de 2011 18:37
  • É... então.. estou baixando o sql em inglês agora mas não sei pq o msdn tá leeeento demais e são 2.2 GB... estou há dois dias baixando e ainda está em 57% ... Então vou aguardar concluir o download e testar. Se funcionar em inglês tá jóia, retorno assim que instalar.

    Abraços

    sexta-feira, 28 de janeiro de 2011 18:40
  • Olá Cíntia

    Tenho boas novidade :)

    SQL Server supports all languages that are supported by Windows operating systems.

    Cross-Language Support

    • The English-language version of SQL Server is supported on all localized versions of operating systems.

    • Localized versions of SQL Server are supported on localized operating systems with the corresponding language or on English-language versions of supported operating systems by using the Windows Multilingual User Interface Pack (MUI) settings. For more information, see How to: Change Operating System Settings to Support Localized Versions.

    • Localized versions of SQL Server can only be upgraded to localized versions of the same language, and cannot be upgraded to the English-language version.

    • Localized versions of SQL Server can also be installed side by side with English-language instances of SQL Server.


    Você precisa instalar o Language Pack de Português em seu sistema operacional para depois efetuar a instalação do SQL em Português

    Qualquer duvida me procure!!!

    Ref.: http://msdn.microsoft.com/en-us/library/ee210665.aspx


    Fábio Oliveira Support Engieer | Microsoft Enterprise and Developer Support
    sexta-feira, 28 de janeiro de 2011 18:50
  • Fábio.. Dá uma luz !!!

    Não sei se eu estou lerdando ou o quê...

    Segui os passos do site :

     

    To change the operating system user interface setting

    1. If not already installed, install the operating system MUI that matches your localized version of SQL Server.

    2. In Control Panel, open Regional and Language Options.

    3. On the Languages tab, for Language used in menus and dialogs, select a value from the list

      Nesse n.3 é que complicou...

      Quando abri regional and language options apareceu a tela com as seguintes abas : Formats | Location | Keyboard and Languages | Administrative

      Não tem a aba de languages...então eu fui na keyboard and languages mas não achei nada parecido com o solicitado acima.

    sexta-feira, 28 de janeiro de 2011 19:10
  • Qual o teu msn ?

    sexta-feira, 28 de janeiro de 2011 19:11
  • Esse é pro R2 !
    sexta-feira, 28 de janeiro de 2011 19:19
  • Oi Cintia,

    Sorry for the delay :)

    Meu msn é (f a b i o b o at m s n "ponto" c o m)

    O artigo é para SQL 2008 R2, mas conforme meu mentor a regra é a mesma para o SQL 2008

    Me chama que a gente conversa

    Att,

     


    Fábio Oliveira Support Engieer | Microsoft Enterprise and Developer Support
    segunda-feira, 31 de janeiro de 2011 12:05
  • Este post foi encerrado por ser considerado um post antigo.

    Pedro Antonio Galvão Junior [MVP | MCC | MSTC | MIE | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | Professor Universitário | @JuniorGalvaoMVP | http://pedrogalvaojunior.wordpress.com]

    terça-feira, 5 de junho de 2018 17:57
    Moderador