none
Erro diferente após rodar SP3 (Replicação) RRS feed

  • Pergunta

  •  

    Pessoal,

     

    Rodei o SP3 (Build 4028) no distribuidor e no assinante (replicação Merge).

     

    Tenho percebido que às vezes quando ocorre alguma instabilidade no link (comunicação entre lojas) o SQL Server não consegue voltar a replicar após a estabilização do mesmo (isso não ocorria antes). Se eu reiniciar o distribuidor ou assinante eles voltam a replicar normalmente (antes de reiniciar eu testo a comunicação via ping, ou acesso remoto e tudo funciona). É como se o TCP negasse conexão on 1433. Muito doido. Segue mensagem:

     

    The merge process could not connect to the Publisher 'SERVERStick out tongueUBLICACAO. Check to ensure that the server is running. (Source: MSSQL_REPL, Error number: MSSQL_REPL-2147199368)

     

    Esse SP3 que rodei é uma versão beta (instalei e após poucos dias saiu a oficial), houve mudanças significativas entre o beta e a oficial? tem algum hotfix após o lançamento do sp3 para replicação?

     

    Forte abraço,


    Welkson Renny

     

    terça-feira, 13 de janeiro de 2009 12:35

Respostas

  • Welkson,

     

    Tudo beta é uma versão que ainda esta sendo testada e sofrerá mudança que para ser considerada instável, segura, com certeza tem muita coisa de diferente em a oficial e a beta.

     

    Inclusive existe um hotfix que deve ser instalado após o SP3, se possível remova esta SP3 beta, instale o oficial e depois o hotfix.

    terça-feira, 13 de janeiro de 2009 12:40
    Moderador
  • Welkson,

     

    Procure no website de downloads da Microsoft.

     

    Sobre instalar o SP3 oficial sobre o beta eu não sei, mas também não recomendo.

    terça-feira, 13 de janeiro de 2009 13:27
    Moderador

Todas as Respostas

  • Welkson,

     

    Tudo beta é uma versão que ainda esta sendo testada e sofrerá mudança que para ser considerada instável, segura, com certeza tem muita coisa de diferente em a oficial e a beta.

     

    Inclusive existe um hotfix que deve ser instalado após o SP3, se possível remova esta SP3 beta, instale o oficial e depois o hotfix.

    terça-feira, 13 de janeiro de 2009 12:40
    Moderador
  •  

    Júnior,

     

    Onde encontro esse hotfix? (e como sou informado sobre lançamentos de novos? kbalert.com?)

     

    Você fala em DESINSTALAR o beta... e é possível? se instalar o SP3 oficial direto por cima do BETA não funciona?

     

    Obrigado!

     

    Welkson

    terça-feira, 13 de janeiro de 2009 12:54
  • Welkson,

     

    Procure no website de downloads da Microsoft.

     

    Sobre instalar o SP3 oficial sobre o beta eu não sei, mas também não recomendo.

    terça-feira, 13 de janeiro de 2009 13:27
    Moderador
  • Júnior,

     

    Estou baixando o SP3 oficial e o CU 10 e 11 que saíram depois do SP3.

     

    Vou executar e ver o que ocorre.

     

    Muito obrigado pela atenção, vou marcar a resposta como útil.

     

    Welkson

    terça-feira, 13 de janeiro de 2009 14:56
  • Welkson,

     

    Isso mesmo, fico no aguardo, obrigado.

    terça-feira, 13 de janeiro de 2009 15:34
    Moderador