none
Intranet com certificado de uma CA interna do Windows server 2003 " Não consegue verificar a o certificado " RRS feed

  • Pergunta

  • Bom dia pessoal,

    estou com um problema com um certificado no site interno de teste aqui no meu ambiente, é o seguinte:

    tenho uma site (intranet) de testes e precisava colocar um certificado para fazer o acesso HTTPS. Subi um CA na mesma máquina, requisitei um certificado para o site, intalei o certificado e funcionou direitinho, o problema é que quando vou acessar o site ele fica dando erro e preciso apertar em continuar para fazer o acesso.

    Pelo que entendi ele não consegue verificar a integridade do certificado e veracidade do site pois o CA precisa certificar o site.

    Como faço para que este certificado funcione no meu site sem erros? Preciso instalar um certificado na minha máquina para que ele confie no CA? se sim, como faço isso?

    O site é somente de teste interno então creio eu que internamente consiga certificar este site. Se alguém tiver uma idéia...

    desde já obrigado a todos !!

     

    abraço

    sexta-feira, 25 de março de 2011 14:17

Respostas

  • Olá,

    Você realmente tem que instalar o certificado na sua máquina para funcionar sem o erro. Você precisa de uma cópia do certificado da sua CA e instalar no seu computador.

    Para instalar no computador você pode criar um MMC e adicionar o Snap-in de certificados, pede para conectar no computador e não no usuário. Na console de certificados você tem que importar o certificado na pasta de certificados de raiz confiáveis.

    Se você for instalar uma CA Enterprise você conseguiria distribuir esse certificado usando GPO.

    http://technet.microsoft.com/pt-br/library/cc875810(en-us).aspx

    Acima um artigo com mais detalhes e passos para a configuração.

    • Marcado como Resposta Peu_ quarta-feira, 30 de março de 2011 12:10
    segunda-feira, 28 de março de 2011 15:23
  • Aloisio muito obrigado....

    complementando, eu estava tentando fazer o acesso ao site digitando o IP da máquina no meu browser, e por IP vai dar erro mesmo.

    O certificado não funciona por IP e sim por nome de máquina ou um aliás.

    Mas agora esta funcionando direitinho sem erros, era somente instalar o certificado na máquina mesmo, como neste meu ambiente não tem AD não pude testar a instalação dos certificados via GPO mas já vi em outro ambiente funcionando deste jeito e funciona direitinho.

     

    Muito obrigado.

     

    • Marcado como Resposta Peu_ quarta-feira, 30 de março de 2011 12:10
    quarta-feira, 30 de março de 2011 12:09

Todas as Respostas

  • Olá,

    Você realmente tem que instalar o certificado na sua máquina para funcionar sem o erro. Você precisa de uma cópia do certificado da sua CA e instalar no seu computador.

    Para instalar no computador você pode criar um MMC e adicionar o Snap-in de certificados, pede para conectar no computador e não no usuário. Na console de certificados você tem que importar o certificado na pasta de certificados de raiz confiáveis.

    Se você for instalar uma CA Enterprise você conseguiria distribuir esse certificado usando GPO.

    http://technet.microsoft.com/pt-br/library/cc875810(en-us).aspx

    Acima um artigo com mais detalhes e passos para a configuração.

    • Marcado como Resposta Peu_ quarta-feira, 30 de março de 2011 12:10
    segunda-feira, 28 de março de 2011 15:23
  • Aloisio muito obrigado....

    complementando, eu estava tentando fazer o acesso ao site digitando o IP da máquina no meu browser, e por IP vai dar erro mesmo.

    O certificado não funciona por IP e sim por nome de máquina ou um aliás.

    Mas agora esta funcionando direitinho sem erros, era somente instalar o certificado na máquina mesmo, como neste meu ambiente não tem AD não pude testar a instalação dos certificados via GPO mas já vi em outro ambiente funcionando deste jeito e funciona direitinho.

     

    Muito obrigado.

     

    • Marcado como Resposta Peu_ quarta-feira, 30 de março de 2011 12:10
    quarta-feira, 30 de março de 2011 12:09