none
[DBNETLIB][ConnectionOpen (Connect()).]SQL Server inexistente ou acesso negado -- SOMENTE EM UMA MAQUINA NA REDE RRS feed

  • Pergunta

  • Ola, tenho um aplicacao em vb6 acessando um banco de dados sqlserver 2008 , sao 3 computadores tudo configurado com liberacoes e porta e tudo mais, sem mais nem menos, um dos computadores da rede nao consegue acessar o sistema, aparece a msg de erro dbnetlib - acesso negado. Teria alguma configuração especifica na maquina que ta tentando acessar o servidor que impedisse ele conectar ou nesse caso é sempre partindo do proprio servidor o problema?

    grato a todos


    Programe o mundo para uma vida melhor!

    sexta-feira, 5 de fevereiro de 2016 12:47

Respostas

  • Como não encontrei uma solucao prática, resintalei novamente o sql server e configurei novamente. Aí voltou a funcionar em todas as maquinas cliente.

    Programe o mundo para uma vida melhor!

    • Marcado como Resposta Sebastiao Freitas quarta-feira, 17 de fevereiro de 2016 01:08
    quarta-feira, 17 de fevereiro de 2016 01:08

Todas as Respostas

  • Sebastiao,

    Verifique se o SQL Server Native Client está instalado.

    Dê uma conferida no link abaixo para tentar solucionar este seu problema:

    https://support.microsoft.com/pt-br/kb/907264


    Felipe Lauffer
    MCSA: SQL Server | MCP

    [ Blog ] - [ Profile ] - [ Wiki ] - [ Gallery ] - [ LinkedIn ]

    sexta-feira, 5 de fevereiro de 2016 12:58
  • Sebastião,

    Por acaso, você esta utilizando alguma aplicação desenvolvida em Delphi?

    Ou que utilize algum Provider ODBC que necessite da dll ntwdblib.dll?


    Pedro Antonio Galvao Junior [MVP | MCC | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | Professor Universitario | SoroCodigos | @JuniorGalvaoMVP | http://pedrogalvaojunior.wordpress.com]

    quinta-feira, 11 de fevereiro de 2016 14:08
    Moderador
  • Nao, acesso direto via ADO, o problema é que um outro computador acessa normal, de repente uma das maquinas parou de acessar e dá  esse erro. ja desinstalei o sistema e continua somente nessa maquina.

    Programe o mundo para uma vida melhor!

    quinta-feira, 11 de fevereiro de 2016 14:38
  • Felipe, a bronca é que essa mesma maquina estava acessando normal e agora nao acessq mais. e outro computador na mesma rede ta normal. Eu nunca instalo o Sql Server Native Client nos computadores. Instalo o sql server, libero as permissoes em rede e no computadores da rede instalo somente a aplicacao. O que poderia ta impedindo somente um determinado computador acessar, ja que o outro consegue?

    grato pela atencao.


    Programe o mundo para uma vida melhor!

    quinta-feira, 11 de fevereiro de 2016 14:41
  • Sebastião,

    Ok, nestas outras máquinas esta dll que eu destaquei esta presente?


    Pedro Antonio Galvao Junior [MVP | MCC | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | Professor Universitario | SoroCodigos | @JuniorGalvaoMVP | http://pedrogalvaojunior.wordpress.com]

    quinta-feira, 11 de fevereiro de 2016 14:42
    Moderador
  • Junior Galvão, mas eu não estou usando a aplicacao com delphi nao, mesmo assim precisa dela?

    Programe o mundo para uma vida melhor!

    quinta-feira, 11 de fevereiro de 2016 14:50
  • Sebastião,

    Ok, eu entendi, não estou falando que você precisa dela, a minha outra pergunta foi referente ao arquivo .dll?

    Você entendeu?


    Pedro Antonio Galvao Junior [MVP | MCC | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | Professor Universitario | SoroCodigos | @JuniorGalvaoMVP | http://pedrogalvaojunior.wordpress.com]

    quinta-feira, 11 de fevereiro de 2016 16:41
    Moderador
  • Junior, procurei e nao encontrei. O estranho é o seguinte, É um sevidor sql 2008 R no windows 7 e 3 computadores na rede acessando o sistema. Agora o segundo computador tambem nao consegue acessar o sistema, ou seja, parou 1 de acessar, agora o 2 e só tem um acessando...que mistério é esse??? chequei novamente as permissoes, porta tudo ok no servidor daqui a pouvo  vai parar o cliente. Ai pra testar instalei o sql server na maquina q nao ta acessando, ai como ta local ele acessa o sistema, mas quando volta a configuracao pra acessar o servidor mesmo ele dá o erro.  Tem alguma ideia, teste que eu possa fazer? ja to na agonia vendo a hora parar a loja.

    grato.


    Programe o mundo para uma vida melhor!

    quinta-feira, 11 de fevereiro de 2016 19:29
  • Como não encontrei uma solucao prática, resintalei novamente o sql server e configurei novamente. Aí voltou a funcionar em todas as maquinas cliente.

    Programe o mundo para uma vida melhor!

    • Marcado como Resposta Sebastiao Freitas quarta-feira, 17 de fevereiro de 2016 01:08
    quarta-feira, 17 de fevereiro de 2016 01:08