none
Problema troca de Login RRS feed

  • Pergunta

  • Pessoal,

    estou com um problema.

    Um funcionario usava o login xxxx_estag porem o mesmo foi contratado e foi feito a troca no AD para xxxx

    Fiz a troca do login usando o powershell e funcionou tudo certo, porem quando o mesmo entra no perfil dele e faz alguma alteração na conta(foto ou nome) volta para _estag.

    Ja fiz a exclusão e o import e o problema persiste.

    Ja fiz este mesmo processo diversas vezes.

    sexta-feira, 16 de maio de 2014 18:01

Respostas

  • Vinicius,

    Criaram um novo usuário para ele ou alteraram o usuário antigo?

    Faça uma busca no User Profile e verifique se existe somente um dos perfis, ou se existe os dois.

    Verifique se o usuário antigo ainda existe dentro das permissões do site em questão.

    Execute os seguintes cmdLet para as duas contas e veja os resultados:

    Get-SPUser -Web http://siteusuario dominio\usuario

    Caso a conta antiga apareça remova ela do site.

    Execute os seguintes cmdLet para a conta nova:

    Set-SPUser -identity dominio\usuario -Web http://siteusuario -SyncFromAd

    Veja se resolve seu problema.

    Abraços,


    Carlos Citrangulo - SharePoint Server MVP
    http://www.carloscitrangulo.com.br

    sexta-feira, 16 de maio de 2014 20:27

Todas as Respostas

  • Vinicius,

    Criaram um novo usuário para ele ou alteraram o usuário antigo?

    Faça uma busca no User Profile e verifique se existe somente um dos perfis, ou se existe os dois.

    Verifique se o usuário antigo ainda existe dentro das permissões do site em questão.

    Execute os seguintes cmdLet para as duas contas e veja os resultados:

    Get-SPUser -Web http://siteusuario dominio\usuario

    Caso a conta antiga apareça remova ela do site.

    Execute os seguintes cmdLet para a conta nova:

    Set-SPUser -identity dominio\usuario -Web http://siteusuario -SyncFromAd

    Veja se resolve seu problema.

    Abraços,


    Carlos Citrangulo - SharePoint Server MVP
    http://www.carloscitrangulo.com.br

    sexta-feira, 16 de maio de 2014 20:27
  • A principio funcionou.

    Obrigado pela ajuda ;)

    segunda-feira, 19 de maio de 2014 15:38
  • Vinicius,

    Criaram um novo usuário para ele ou alteraram o usuário antigo?

    Faça uma busca no User Profile e verifique se existe somente um dos perfis, ou se existe os dois.

    Verifique se o usuário antigo ainda existe dentro das permissões do site em questão.

    Execute os seguintes cmdLet para as duas contas e veja os resultados:

    Get-SPUser -Web http://siteusuario dominio\usuario

    Caso a conta antiga apareça remova ela do site.

    Execute os seguintes cmdLet para a conta nova:

    Set-SPUser -identity dominio\usuario -Web http://siteusuario -SyncFromAd

    Veja se resolve seu problema.

    Abraços,


    Carlos Citrangulo - SharePoint Server MVP
    http://www.carloscitrangulo.com.br

    O problema persiste.

    Rodei a sincronizacao hoje e quando entrei no meu perfil restaurou a configuracao do _estag

    terça-feira, 20 de maio de 2014 12:37
  • Vinicius,

    Execute o seguinte comando no console Windows PowerShell:

    Get-ADUser -Server NomeDC -Identity UsuarioEstagiario

    Poste aqui o retorno do comando.

    Abraços,


    Carlos Citrangulo - SharePoint Server MVP
    http://www.carloscitrangulo.com.br

    quarta-feira, 21 de maio de 2014 01:05
  • Vinicius,

    Execute o seguinte comando no console Windows PowerShell:

    Get-ADUser -Server NomeDC -Identity UsuarioEstagiario

    Poste aqui o retorno do comando.

    Abraços,


    Carlos Citrangulo - SharePoint Server MVP
    http://www.carloscitrangulo.com.br

    ______________________________________________________________________________________________________________________________________________________________________________________________
    PS C:\Users\sharepoint> Get-ADUser -Server xxx -Identity xxx_estag
    Get-ADUser : Cannot find an object with identity: 'xxx_estag' under: 'DC=xxxx,DC=net,DC=br'.
    At line:1 char:11
    + Get-ADUser <<<<  -Server xxx -Identity xxx_estag
        + CategoryInfo          : ObjectNotFound: (xxx_estag:ADUser) [Get-ADUser], ADIdentityNotFoundException
        + FullyQualifiedErrorId : Cannot find an object with identity: 'xxxx_estag' under: 'DC=xxxx,DC=net,DC=br'.,Microsoft.ActiveDirectory.Management.Commands.GetADUser
     

    ______________________________________________________________________________________________________________________________________________________________________________________________
    PS C:\Users\sharepoint> Get-ADUser -Server XXXX -Identity xxxx


    DistinguishedName : CN=xxx,OU=Sistemas de Informacao,OU=Contas de Usuarios,OU=Usuarios,OU=ION,DC=,DC=net,DC=br
    Enabled           : True
    GivenName         : Vinicius
    Name              : Vinicius Fernandes
    ObjectClass       : user
    ObjectGUID        : 6828fd56-7966-4e7d-beee-a27f10bf6369
    SamAccountName    : xxxx
    SID               : S-1-5-21-68633038-857355921-1349916565-46212
    Surname           : Fernandes
    UserPrincipalName : xxxx@


    quarta-feira, 21 de maio de 2014 14:29