none
E-mail Outbound - Envio de alertas #misterio RRS feed

  • Pergunta

  • Como um servidor sharepoint que não tem o serviço smtp instalado e configurado e na Administração Central encontra-se configurado ele mesmo como servidor SMTP enviar alertas com sucesso ?

    Danilo Toscano - http://danilotoscano.wordpress.com | Se foi útil, por que não votar? ;) | “Se não existe esforço, não existe progresso.”

    terça-feira, 13 de novembro de 2012 12:33

Respostas

  • Danilo,

    A questão é que se você não tem servidor de e-mail, ele está enviando os e-mails utilizando o gmail. Para utilizar o gmail, precisa de um servidor de smtp.

    Para você utilizar o gmail, você precisa de 2 procedimentos.

    1 - Instalar o smtp e configura-lo para utilizar o gmail.

    2 - Configurar o SharePoint e apontar para ele mesmo.

    Na minha opinião, existe algum servidor smtp nesse servidor SharePoint. Não necessáriamente o smtp do próprio windows.

    Simples teste, tira o acesso a internet do servidor sharepoint.


    Atenciosamente, Rafael Fausto


    • Editado Rafael Fausto quarta-feira, 14 de novembro de 2012 12:50
    • Marcado como Resposta Danilo Toscano sexta-feira, 23 de novembro de 2012 18:47
    quarta-feira, 14 de novembro de 2012 12:31

Todas as Respostas

  • Normalmente, a porta smtp é a 25.

    Já tentou usar o comando netstat para verificar se a porta está realmente sendo usada?

    netstat -an | find /i "25"

    Caso positivo, é quase certo de ter um servidor smtp rodando no servidor.

    Atenciosamente, Rafael Fausto

    terça-feira, 13 de novembro de 2012 12:57
  • Obrigado pelo retorno Rafael.

    Já sim, me retorna a porta, porém não existe o serviço SMTP instalado, como pode ? Meu servidor de email é gmail, ou seja, preciso ter um smtp virtual pra autenticar e nele nao tem instalado e na sua central administrion aponta que ele é o smtp de saida. Isso que me intriga. rs

    


    Danilo Toscano - http://danilotoscano.wordpress.com | Se foi útil, por que não votar? ;) | “Se não existe esforço, não existe progresso.”

    terça-feira, 13 de novembro de 2012 13:31
  • Danilo, estranho mesmo.

    Você já testo?

    telnet <servidor-email> 25

    Referência: http://technet.microsoft.com/en-us/library/aa995718%28v=exchg.65%29.aspx

    Veja o que aparece. Poste aqui por favor.


    Atenciosamente, Rafael Fausto

    terça-feira, 13 de novembro de 2012 16:44
  • Olá Rafael,

    O telnet não está instalado no server, com isso só poderei realizar o teste amanhã quando instalarei e reiniciarei o server. Adianto que o meu servidor de e-mail fica na nuvem, é o GMAIL, não tinha o porquê funcionar, mas ao executar netstat -an a porta 25 está habilitada escutando.

    Vamos nos falando...


    Danilo Toscano - http://danilotoscano.wordpress.com | Se foi útil, por que não votar? ;) | “Se não existe esforço, não existe progresso.”


    terça-feira, 13 de novembro de 2012 18:31
  • Combinado Danilo,

    Qualquer novidade, pode dizer.


    Atenciosamente, Rafael Fausto

    terça-feira, 13 de novembro de 2012 19:20
  • Rafael,

    Rodei telnet smtp.gmail 25 resultou na tela abaixo


    Danilo Toscano - http://danilotoscano.wordpress.com | Se foi útil, por que não votar? ;) | “Se não existe esforço, não existe progresso.”

    quarta-feira, 14 de novembro de 2012 10:56
  • Danilo,

    Era para você utilizar o telnet e apontando para o seu servidor na porta 25 e não a do smtp.gmail.com


    Atenciosamente, Rafael Fausto

    quarta-feira, 14 de novembro de 2012 11:07
  • Mas o meu servidor é o gmail, é web, não existe um exchange da vida local é na nuvem.

    Temos um dominio corporativo na google.



    Danilo Toscano - http://danilotoscano.wordpress.com | Se foi útil, por que não votar? ;) | “Se não existe esforço, não existe progresso.”

    quarta-feira, 14 de novembro de 2012 11:45
  • O SharePoint esta na nuvem?

    Atenciosamente, Rafael Fausto

    quarta-feira, 14 de novembro de 2012 11:55
  • Nao, o servidor de e-mail, no qual você pediu pra realizar o telnet.

    Danilo Toscano - http://danilotoscano.wordpress.com | Se foi útil, por que não votar? ;) | “Se não existe esforço, não existe progresso.”

    quarta-feira, 14 de novembro de 2012 11:59
  • Então, mas você disse que no outbound do SharePoint estava configurado para ele mesmo,não para o smtp do gmail e mesmo assim enviava e-mail. correto?

    O netstat você fez no servidor SharePoint e mostrou que a porta esta sendo utilizada. O que quero descobrir é se tem algum aplicativo de servidor de smtp nesse servidor sharepoint.


    Atenciosamente, Rafael Fausto

    quarta-feira, 14 de novembro de 2012 12:08
  • Para resumir, o que eu quero entender é, o porquê que meu servidor está funcionando outgoing mail se no próprio servidor não encontra-se instalado o serviço SMTP e não possuo no meu parque tecnologico servidores de e-mail instalados localmente.

     []s


    Danilo Toscano - http://danilotoscano.wordpress.com | Se foi útil, por que não votar? ;) | “Se não existe esforço, não existe progresso.”

    quarta-feira, 14 de novembro de 2012 12:09
  • Correto. Eis o mistério. Ja procurei e nada encontrei, verifiquei roles, features no server tbm. Vou dá uma olhada mais detalhada para ve se acho algum app do tipo.

    Danilo Toscano - http://danilotoscano.wordpress.com | Se foi útil, por que não votar? ;) | “Se não existe esforço, não existe progresso.”

    quarta-feira, 14 de novembro de 2012 12:20
  • Danilo,

    A questão é que se você não tem servidor de e-mail, ele está enviando os e-mails utilizando o gmail. Para utilizar o gmail, precisa de um servidor de smtp.

    Para você utilizar o gmail, você precisa de 2 procedimentos.

    1 - Instalar o smtp e configura-lo para utilizar o gmail.

    2 - Configurar o SharePoint e apontar para ele mesmo.

    Na minha opinião, existe algum servidor smtp nesse servidor SharePoint. Não necessáriamente o smtp do próprio windows.

    Simples teste, tira o acesso a internet do servidor sharepoint.


    Atenciosamente, Rafael Fausto


    • Editado Rafael Fausto quarta-feira, 14 de novembro de 2012 12:50
    • Marcado como Resposta Danilo Toscano sexta-feira, 23 de novembro de 2012 18:47
    quarta-feira, 14 de novembro de 2012 12:31
  • Obrigado pela ajuda Rafael, qualquer coisa que achar postarei.

    Se quiser, deixa teu contato no meu blog para trocarmos figurinhas.

    Abraço,


    Danilo Toscano - http://danilotoscano.wordpress.com | Se foi útil, por que não votar? ;) | “Se não existe esforço, não existe progresso.”

    quarta-feira, 14 de novembro de 2012 13:16
  • Para conhecimento,

    Foi identificado uma aplicação relay no servidor (acho que Mail Relay), onde estava escutando a porta 25, ou seja, não utilizando o IIS.

    [ ]s


    Danilo Toscano - http://danilotoscano.wordpress.com | Se foi útil, por que não votar? ;) | “Se não existe esforço, não existe progresso.”

    sexta-feira, 23 de novembro de 2012 18:47