none
ISA Server 2004 x IIS 6 RRS feed

  • Pergunta

  • Bom dia a todos,

    Estou com a seguinte situação e conto com a ajuda de todos para tentar resolve-la.

    Tenho um servidor no qual rodo IIS 6 + ISA Server 2004.

    Habilitei o serviço de TSWEB na mesma, e internamente consigo de qualquer estação pertecente a minha rede interna acessar o serviço, utilizando do IP interno ou externo.

    Porém, não obtenho o acesso se estiver acessando de um estação fora da minha rede interna, por exemplo, um notebook não pertecente ao meu domínio através de um conexao discada.

    Já tentei publicar um web server, mas não obtive nenhum resultado positivo com isso.

    Meu IP e fixo, e estou tentando acessar através de um browser através do mesmo IP.

    Será alguma configuração do IIS ou algum bloqueio ou configuração do ISA?

    Aguardo respostas e muito obrigado.

    • Movido Hengzhe Li quinta-feira, 29 de março de 2012 04:31 (De:ISA Server 2004)
    terça-feira, 31 de outubro de 2006 10:32

Todas as Respostas

  • Ola Gabriel,

    Bom dia.

    Não seria melhor publicar o RDP ao invés do TSWEB ?

    Segue links relacionados:

    Publicando TSWEB: http://www.isaserver.org/tutorials/Publishing-Remote-Desktop-Web-Connection-Sites-ISA-Firewall-Part2.html

    Publicando o RDP Server: http://www.itcentral.com.br/default.asp?ACT=5&content=139&id=17&mnu=17

    Qualquer duvida post.

    Abraços.

    terça-feira, 31 de outubro de 2006 11:22
  • Armindo,

    Consegui ter acesso via RDP, porem quando tenho acessar via tsweb digitando no meu browser o IP do meu server, a pagina nao e exibida.

    No ISA, o seguinte erro aparece.

    Description: The Web Proxy filter failed to bind its socket to x.x.x.x port 80. This may have been caused by another service that is already using the same port or by a network adapter that is not functional. To resolve this issue, restart the Microsoft Firewall service. The error code specified in the data area of the event properties indicates the cause of the failure.
     The failure is due to error: 0x8007271d

    terça-feira, 31 de outubro de 2006 11:51
  • Ola Gabriel,

    Bom dia.

    O aparente erro mostra que existe outras aplicações rodando na mesma porta. Você sabe me dizer se o auto descovery do ISA esta habilitado ?

    Abraços.

    terça-feira, 31 de outubro de 2006 12:08
  • O Autodiscovery não está habilitado.

    Não consigo de forma alguma ter acesso via browser, apenas via RDP

    terça-feira, 31 de outubro de 2006 12:12
  • Ola Gabriel,

    Bom dia.

    Você tem algum outro web server, tipo apache ?

    Abraços.

    terça-feira, 31 de outubro de 2006 12:55
  • Não,

    Estou apenas com um server com ISA 2004 e o IIS rodando.

    Tenho outro server na minha rede com ISA 2000 e nenhum servico alem disso, além que este utiliza sua propria conexao externa.

    Realmente está complicado a situacao

    terça-feira, 31 de outubro de 2006 13:48
  • Ola Gabriel,

    Bom dia.

    Então vamos filtrar alguns passos.

    Você fez qual publicação ? Seguiu qual dos links que te passei ?

    Me informe como esta a configuração das suas interfaces de rede.

    A ordem de binds das placas.

    Seu WebListener, me diga como esta sua confiduração.

    Abraços.

    quarta-feira, 1 de novembro de 2006 11:07
  • Caro Armindo.

    Estou com um server rodando IIS e ISA 2k4.

    Possui duas placas de rede, uma com acesso a minha rede interna e outra no meu link,.

    Me orientei seguindo aqueles artigos que voce mencionou alterando as seguintes situações.

    No Listerner:

    Em Networks, escolhi a rede externa e especifiquei meu IP Externo.

    Em preferencias, habilitei a porta HTTP 80 e utilizei o modo integrado para autenticação

    Na Web Access Rule:

    Especifiquei meu endereço interno (tanto ip como nome, ambos nao deram resultados positivos) e public name meu IP externo

    A ordem de acesso está primeiro a rede local, depois a rede externa (configuracoes de rede do windows).

    O acesso via RDP está funcionando perfeitamente, agora via TSWEB continua persistindo o erro

     

    quarta-feira, 1 de novembro de 2006 12:08
  • Ola Gabriel,

    Bom dia.

    O problema pode estar na sua publlicação do TSWEB.

    Você sitou Web Access Rule, você publicou ou criou uma regra de acesso ?

    Me descreva mais esta publicação, se puder informar o endereço para que possamos testar de fora.

    Abraços.

    quarta-feira, 1 de novembro de 2006 12:50
  • Armindo. Consegui descobrir o problema, mas agora estou com outro.

    Vou citar em exemplo para melhor entendimento:

    Possuo duas redes diferentes com domínios diferentes.

    A rede X no dominio X utiliza um server isa server 2000 ligado a um cable modem.

    A outra rede Y no dominio Y possui um server isa server 2004 ligado um link.

    Este server no dominio Y além de roda o isa server 2004, roda o IIS onde o serviço de TSWEB está funcionando (Meu caso)

    Pelo server no dominio X consigo acessar o site que eu publiquei da rede Y que contem a TSWEB, porém, so consigo acessar remotamente as maquinas da própria rede X e não da rede Y.

    Estou a um passo para resolver de vez meu problema.

    Aguardo sugestões

    quarta-feira, 1 de novembro de 2006 16:50
  • Ola Gabriel,

    Boa Tarde.

    Como resolveu seu problema ?

    A sua duvida é por que você consegue acessar o TSWEB da rede x e não consegue acessar da rede y ?

    Caso seja esta sua duvida, me responda uma outra, a rede x acessa o TSWEB internamente ou por fora ?

    Abraços.

    quarta-feira, 1 de novembro de 2006 17:03
  • Armindo,

    O problema na configuração do IIS. Como o meu server roda os dois serviços, tive que alterar a porta 80 do IIS para outro numero e fazer o mesmo na regra de publicação. Com isso funcionou.

    Quanto ao problema atual, eu preciso acessar da rede X, uma máquina na rede Y.

    O que acontece e que eu so consigo acessar as maquinas da minha propria rede utilizando o TSWEB que é da rede Y.

    Exemplo:

    Rede X:

    (1) Server ISA Server 2000 com acesso a internet via cable modem.

    Endereço IP Interno na rede X: 192.168.0.1

    Endereço Externo: 201.x.x.x

    Rede Y

    (2) Server ISA Server 2004 + IIS 6 rodando TSWEB com acesso a internet via link

    Endereço IP interno na rede Y: 192.168.0.4

    Endereço Externo:200.x.x.x

    Utilizando o server (1) da rede X, com acesso direto a internet, acesso com sucesso a página TSWEB hospedada no server (2) da rede Y, porém apenas consigo acesso a área de trabalho remota do server (2) da rede Y e das estações próprias estações da rede X da qual eu sou membro.

    O que eu preciso e acessar o server(2) da rede Y pelo server(1) da rede X e ter acesso remoto a outras estações da rede Y e não apenas ao server(2).

    quarta-feira, 1 de novembro de 2006 17:15
  • Gabriel,

    Não seria mais facil acessar o servidor e do servidor acessar as estações via VNC por exemplo ?

    Abraços.

    quarta-feira, 1 de novembro de 2006 18:20
  • Armindo, até seria, porém eu nao queria dar acesso diretamente ao meu servidor, mas apenas a estacao na qual o usuario ira trabalhar.

    Se fosse apenas para minha administração, concerteza seria, mas o meu objetivo e prover acesso a um sistema de peças da minha empresa, e com isso, várias pessoas terão acesso ao servidor, o que não seria interessante.

    Agora tive uma outra ideia, que pode ser interessante.

    Eu colocar uma máquina cliente na rede exclusivamente para isso e publica-la externamente

    O que acha da ideia?

    Com isso o acesso seria diretamente nela.

    Observação: Voltando ao caso anterior, seria possível realizar o que eu estava pensando anteriormente?

    []'s

    quarta-feira, 1 de novembro de 2006 19:05
  • Ola Gabriel,

    Bom dia.

    Então a sua necessidade é disponibilizar para usuarios externos um sistema interno da sua empresa, seria isto ?

    Caso seja a melhor forma que vejo é fazer da forma que estava pensando, os usuarios acessam via Terminal Service ( Remote Desktop ), logon no servidor de Terminal Service e a aplicação inicia.

    O que acha desta forma ?

    Quais as restrições quanto ao modelo acima ?

    Abraços.

    sexta-feira, 3 de novembro de 2006 12:58
  • Gabriel,

    Se você seguiu os passos da dica do Armindo, estaria tudo 0k. O artigo do Shinder é muito bom.

    Mas o detalhe no seu caso é o seguinte, você teria que publicar todos seus micros que seriam acessados remotamente!!! Como fazer isso sendo que todos eles usam a mesma porta do TS/Remote Desktop ?!? Você teria que mudar as portas dos micros e fazer a publicação uma a uma no seu ISA.

    Para contornar essa situação, poderia ser de duas formas:

    1) Usuário conecta pela VPN, a assim abre o TSWeb ou RDC com o IP/Nome do micro interno.

    2) Criar 1 servidor de TS, para hospedar sua aplicação e fazer com que todos usuários acessem esse único servidor. Podendo acessar via TSWeb (exemplo do artigo do Shinder)

    TechEd 2006, serão mais de 70 palestras de TI, vai ficar de fora ? Garanta sua vaga @ http://www.teched.com.br/IT

    Se esse post lhe ajudou, não esqueça de marca-lo como uma resposta/útil.

    Abraços,

    sexta-feira, 3 de novembro de 2006 14:05