locked
Erro Autenticação SQL! expert me ajuda! Urgente RRS feed

  • Pergunta

  • Bom pessoal, sou novo aqui, mas vou  direto ao ponto

    formatei a maquina do host q eu alugo para montar um servidor de RPG online
    antes de formatar tava tudo 100%

    fiz backup das dbs da pasta data (C:\Arquivos de programas\Microsoft SQL Server\MSSQL.1\MSSQL\Data) com o SQL desligado...

    antes de formatar, a instancia foi alterada para PT, mesmo assim era essa a principal que eu usava

    conexão ao SQL:

    para acessar as databases, este servidor utiliza 2 maneiras:
    [b]odbc (c8master) [/b]- esta acessa apenas os logins de usuarios, o que limita muito as funções... no caso apenas esta esta funcionando atualmente,  mas com a restrição de somente se conectar com Autenticação do Windows... não consigo conectar do jeito convencional (autenticação do SQL Server com logon e senha)

    [b]SQL.dll[/b]- este é configurado pelo SQL.dll Reg.reg, que tem a função de conectar o servidor.exe e game.exe as base de dados (todas). Só que como podem ver, nem pelo odbc, nem pelo SQL.dll (depois de mesclar o .reg) consigo acessar corretamente ao SQL.

    nas fotos abaixo vocês podem ver como estão as config. e estrutura do SQL
    me ajudem por favor... se for possivel ate abro o teamviewer para que alguém mais experiente me ajude
    pois se conseguir corrigir pretendo fazer um backup de imagem de disco

    agradeço desde já
    e estou disponivel para fornecer alguma informação
    MSN: suporte@live.ru

     

    como sao permitidas apenas 2 imagens, por favor olhem a pasta:

    http://www.friendspt.com.br/files/imagens

     

     


    • Movido Gustavo Maia Aguiar quarta-feira, 16 de novembro de 2011 12:03 (De:SQL Server - Desenvolvimento Geral)
    • Editado 403Forbidden quarta-feira, 16 de novembro de 2011 14:19
    quarta-feira, 16 de novembro de 2011 01:49

Respostas

  • Não sei se eu entendi corretamente, mas teu problema é que não conecta mais através do user SA, é isto?

     

    Se for este o caso, tenta ver esta configuração nas Propriedades do Servidor SQL Server.

    Através da Ferramenta vá em Propriedades e altere a configuração da imagem abaixo, provavelmente a tua esteja assim, somente Windows Authentication.

     

    Caso não seja isto retorne, se for, marque como resposta.

    Vlew.

    quarta-feira, 16 de novembro de 2011 12:21
  • 403Forbidden,

    Li e ficou meio confusa a sua situação:

    Vamos lá ns dúvidas sobre a instalação:

    Qdo vc instalou o SQL-Server você deu um nome para instancia ou deixou o nome da máquina?

    Qual o nome da máquina onde está instalado o SQL-Server

    Você consegue conectar via IP ?

       Exemplo 192.168.1.1\NomeInstacia (Caso nomeada) ou 192.168.1.1 (caso não seja nomeada)?

    Tente uma conexão UDL da seguinte forma:

    1- em uma máquina qualquer sem ser o servidor vai no desktop crie um arquivo Conexao.txt

    2 - Renomei o Arquivo para Conexao.UDL

    3 configure a conexão next next finish.(tente autenticação SQL-Server não windows ok)

    4 clique em testar conexão.

     

    Depois disso vamos falar sobre usuários e acesso aos bancos.

     


    Marquinhos Não esqueça de qualificar a resposta.
    quinta-feira, 24 de novembro de 2011 11:04

Todas as Respostas

  • quero ressaltar tambem
    que algumas scripts do meu site funcionam:
    www.friendspt.com.br

    e também que o nome da máquina antes de formatar era pt e depois de formatar PT
    não sei se da conflito na instância diferença entre letra maiúscula e minúscula

    exemplo de uma script no site que ta funcionando e acessando SQL normalmente:

    <?php $dbhost = 'DRIVER={SQL Server};SERVER=pt\SQLEXPRESS;
    DATABASE=rPTDB'; $dbuser = "sa"; $dbpass = "123456"; $connection = odbc_connect($dbhost, $dbuser, $dbpass); $verifica = "SELECT TOP 10 * FROM LevelList WHERE CharClass <
    'Unknown ID: 0' and CharName != '[Administrador]' and CharName !=
    'Administrador' and CharName != 'Admin' and CharName != 'GMLebon'
    and CharName != 'Google' and CharName != ' ' and CharName != 'Teste'
    and CharName != 'Dat' and CharName != 'FriendsPT' and CharName !=
    'GMLebonIV' and CharName != 'GMFloripa' and CharName !=
     'GMFriend'and CharName != 'Hacker' and CharName != 'xxxxxxxx' and
    CharName != 'xxxxxxxx' and CharName != 'xxxxxxxx' and CharName !=
    'xxxxxxxx' and CharName != 'xxxxxxxx' and CharName != 'xxxxxxxx' and
    CharName != 'xxxxxxxx' and CharName != 'xxxxxxxx' and CharName !=
    'xxxxxxxx' and CharName != 'xxxxxxxx' and CharName != 'xxxxxxxx' and
    CharName != 'xxxxxxxx' and CharName != 'xxxxxxxx' ORDER BY CharLevel
    DESC "; echo '<table align="center" ><tr><td class="STYLE8"></td><td width=
    100%" class="STYLE8">Nick</td><td width="100%" class="STYLE8">
    Level</td></tr>'; $rank = odbc_exec($connection, $verifica); if($pg == 1 or $pg == 0){ $i = 1; }elseif($pg > 1){ $i = $ini+1; } while($dados = odbc_fetch_array($rank)) { $id=$i+1; echo ($i % 2) ? "<tr>" : "<tr>"; echo '<td><Justify>'.$i.'</Justify></td>'; echo '<td><img src="class/'.$dados['CharClass'].'.gif" width="32"
    height="26">'.$dados['CharName'].'</td>'; echo '<td><Justify>'.$dados['CharLevel'].'</Justify></td>'; echo '</tr>'; $i++; } echo '</table>'; ?>


     

     


    • Editado 403Forbidden quarta-feira, 16 de novembro de 2011 02:08 mudança de conteudo
    quarta-feira, 16 de novembro de 2011 02:01
  • Não sei se eu entendi corretamente, mas teu problema é que não conecta mais através do user SA, é isto?

     

    Se for este o caso, tenta ver esta configuração nas Propriedades do Servidor SQL Server.

    Através da Ferramenta vá em Propriedades e altere a configuração da imagem abaixo, provavelmente a tua esteja assim, somente Windows Authentication.

     

    Caso não seja isto retorne, se for, marque como resposta.

    Vlew.

    quarta-feira, 16 de novembro de 2011 12:21
  •  

    agradeço desde já sua resposta, mas nessa parte esta marcado ja como SQL and Windows

    com alguns scripts e programas funcionam o acesso ao SQL via user sa

    apenas o client do  game (game.exe) nao se conecta usando as configurações do SQL.DLL, ele só funciona se eu ativo a odbc c8master (com autenticação do windows)

    o mapeamento do usuario SA esta assim:
    sera que ta errado?

     

     

    nessa parte de logins esta aparecendo esse login "universe..." que era o nome da maquina anterior, depois eu mudei para apenas "PT". Isso afeta algo?

     

     

     

     


    • Editado 403Forbidden quarta-feira, 16 de novembro de 2011 14:17
    quarta-feira, 16 de novembro de 2011 14:01
  • Primeiramente é importante você avaliar como sua aplicação faz o acesso ao SQL. Existe algum login especifico? Essa é a primeira verificação.

    De posse do login, tente acessar o SQL com ele. Este é o primeiro teste a ser feito.

    Este acesso está local? Ou seja, sua aplicação está tentando acessar o SQL na mesma máquina ou está na rede?

    Att.,
    Marco Antônio Pinheiro / MCTS - MCC http://marcoantoniopinheiro.blogspot.com
    quarta-feira, 16 de novembro de 2011 16:45
  • obrigado pela resposta amigo

    todo problema ocorreu apos formatação e restauração das databases via backup

    localmente eu acesso normalmente o SQL Server, como mostram as Screen Shots
    o usuario padrão é sa, senha 123456

    os scripts são locais e também funcionam no site (alguns atualmente)

    o aplicativo é via internet, game.exe (cliente) acessa o servidor quando o server.exe (maquina com IP fixo) está ligado!

    o que devia ser executado é o SQL.dll, quando o server.exe é ligado, configurado por um arquivo.reg, que é executado apenas no servidor

    e em tese sesse backup deveria funcionar, pois como meuservidor é novo e está em fase de criação, não tem um numero significatido de contas de usuarios e senhas armazenado, porem em poucos meses terá, e não poderá acontecer uma falha dessas

    antes de formatar funcionava tudo 100%

    :(


    • Editado 403Forbidden quarta-feira, 16 de novembro de 2011 17:32
    quarta-feira, 16 de novembro de 2011 17:29
  • O principal que é a conexão pelo SQL ocorre, então é menos complicado a solução.

    Quando vc tenta a conexão pelo aplicativo ocorre algum erro?

    Pode ser tb um problema com a instalação. A versão antes usada era a mesma? e tb tinha uma instancia nomeada?

    Att.,


    Marco Antônio Pinheiro / MCTS - MCC http://marcoantoniopinheiro.blogspot.com
    quarta-feira, 16 de novembro de 2011 18:37
  • não da nenhum erro amigo
    apenas nao conecta o game.exe ao servidor

    no mesmo instante se eu usar a odbc nomeada c8master, configurada para autenticar via windows, o game conecta normalmente, mas o problema é que com esse odbc fica com funções limitadas, pois ela so conecta na base accountdb!

    antes de formatar a instancia era "universe", depois mudei pra "pt" e configurei tudo pra usar "pt\SQLEXPRESS", e assim funcionava

    depois de formatar a instancia passou a ser "PT"
    agradeço muito se conseguir resolver isso
    pois to pagando aluguel do host la, e ja ta com esse problema há alguns dias

    te mandei um email pra marcoaspinheiro@...
    se puder me ajudar agradeço amigo
    alguns amigos ja tentaram ajudar, mas nenhum é expert em SQL...

    • Editado 403Forbidden quarta-feira, 16 de novembro de 2011 19:51
    quarta-feira, 16 de novembro de 2011 18:41
  • acabei de recriar todas as databases

    incrivel mas continua o mesmo erro

    o acesso ao SQL é feito atravez do server.exe
    que executa o SQL.DLL

    é preciso que esteja no registro do windows, e está assim:

     

     

     

    por favor, alguem que entena bem pode me ajudar?

    nem que seja via teamviewer

    quarta-feira, 16 de novembro de 2011 23:42
  • - Vc consegue logar normalmente no Management Studio com os logins que estão no seu print?
    - Vc consegue logar normalmente no Management Studio com os logins que estão no seu print em uma máquina diferente da máquina servidora?

    Depois faça os seguintes passos:

    1 - Vá em INICIAR - EXECUTAR e escreva cliconfg
    2 - Na primeira tela confirme se os protocolos estão do lado direito e o campo "Habilitar protocolo de memoria compartilhada" está marcado.
    3 - Na guia ALIAS crie um alias conforme seu print: PT\SQLEXPRESS
    4 - No servidor, acesse o Configuration Manager e verifique se todos os protocolos (menos o VIA) estçao HABILITADOS.
    5 - Firewall desativado ou com exceção para as portas 1433 e 1434 (UDP)
    6 - O serviço SQL browser deve estar iniciado.

    Faça estes 6 passos no client e no servidor.

    Outra verificação é qdo vc for se conectar no Management Studio. Na tela de login vai ter o botão "Options", ao clica-lo terá o campo "Tempo limite da conexão", altere para 60.
    Marco Antônio Pinheiro / MCTS - MCC http://marcoantoniopinheiro.blogspot.com
    sexta-feira, 18 de novembro de 2011 13:42
  • infelizmente não resolveu
    penso que formatar novamente é a única solução
    eu respondo aqui se resolver...

    obrigado a todos

    • Editado 403Forbidden segunda-feira, 21 de novembro de 2011 21:51
    segunda-feira, 21 de novembro de 2011 01:57
  • 403Forbidden,

    Li e ficou meio confusa a sua situação:

    Vamos lá ns dúvidas sobre a instalação:

    Qdo vc instalou o SQL-Server você deu um nome para instancia ou deixou o nome da máquina?

    Qual o nome da máquina onde está instalado o SQL-Server

    Você consegue conectar via IP ?

       Exemplo 192.168.1.1\NomeInstacia (Caso nomeada) ou 192.168.1.1 (caso não seja nomeada)?

    Tente uma conexão UDL da seguinte forma:

    1- em uma máquina qualquer sem ser o servidor vai no desktop crie um arquivo Conexao.txt

    2 - Renomei o Arquivo para Conexao.UDL

    3 configure a conexão next next finish.(tente autenticação SQL-Server não windows ok)

    4 clique em testar conexão.

     

    Depois disso vamos falar sobre usuários e acesso aos bancos.

     


    Marquinhos Não esqueça de qualificar a resposta.
    quinta-feira, 24 de novembro de 2011 11:04