none
Reinstalação do Sharepoint Service 3.0 com banco de dados de conteudo existente. RRS feed

  • Pergunta

  • Bem, desinstalei o Sharepoint Service 3.0, ele estava configurado no Banco de Dados Internal do Windows MICROSOFT##SSEE, a base de dados ainda esta alocada no referido servidor. Pergunto, qual passo-a-passo devo proceder para reinstalar novamente o Sharepoint Service 3.0 e recuperar os dados dessa base de dados do que foi desinstalado.

    Ficarei muito grato se alguém puder me ajudar.

    Manoel Neto

    quarta-feira, 19 de dezembro de 2012 16:35

Respostas

  • Olá Manoel,

    Vou aproveitar e dar minhas sugestões também ;p

    Aparentemente está com problemas para subir o conteúdo das bases nos seus sites SharePoint. Pelo que pude perceber, você consegue restaurar as bases mas o conteúdo não é refletido nos sites, é isso mesmo?

    Apenas para efeito de teste, subi uma VM com SharePoint 2007 e segui os seguintes procedimentos para restaurar os sites de uma web application à partir de um MDF do SQL. Sugiro que verifique se também poderá ajudar em seu cenário:

    - No novo ambiente SharePoint (o último que você configurou e deseja restaurar as bases), crie uma nova web application (Central Admin > Application Management > Create or Extend Web Application > Create a New Web Application). Será criado também um content database, algo como WSS_Content_ABCD.

    - No servidor do banco de dados (como mencionou estar utilizando uma instalação stand-alone, certamente deverá ser o mesmo servidor) restaure (ou de um 'attach') nas bases utilizadas anteriormente (algo como WSS_Content_XPTO). Com o SQL Management Studio fica bem mais fácil ;p

    - Com as bases restauradas, remova o content database criado anteriormente com a WebApplication (pode ser via stsadm OU Central Admin > Application Management > Content Databases > Web Application (Selecione a Web Application criada) > algo como WSS_Content_ABCD > Remove Content Database > OK).

    - Agora você precisa anexar essa base ao web application do SharePoint, que novamente pode ser feito via stsadm OU Central Admin > Application Management > Content Databases > Web Application (Selecione a Web Application criada) > Add a content Database > Entre com o Database Name (algo como WSS_Content_XPTO) > OK.

    - Para ficar com a consciência tranquila, execute um iisreset e faça um teste acessando a URL da WebApplication.

    Este é o procedimento que executei para restaurar um site sem customizações no SharePoint ou modificações no IIS. Espero que possa ajudá-lo também!

    Refente aos problemas de versão no restore, isso provavelmente está relacionado com o que o Rafael falou sobre versões, ou mais especificamente sobre as builds do SharePoint (que são alteradas a cada Service Pack, Cumulative Update, ...). 

    Segue abaixo uma lista que poderá ajudá-lo a se orientar sobre as builds e quais são os updates necessários para deixar diferentes ambientes equivalentes:

    http://todd-carter.com/sharepoint-versions/#WSS3

    Sobre restaurar os arquivos disponíveis em um site do SharePoint via backup do SQL, infelizmente nunca vi isso na prática. No entanto acredito que algumas ferramentas da AvePoint poderão ajudar nesta tarefa:

    http://www.avepoint.com/docave-recovery-manager-for-sharepoint/

    Obs.: eles possuem versões trial :)

    []'s


    Tarcísio Gambin | MCP, MCT, MCTS, MCITP, ITILv3
    www.tarcisiogambin.net


    • Editado Tarcisio Gambin quinta-feira, 27 de dezembro de 2012 09:54
    • Marcado como Resposta Richard Juhasz quinta-feira, 7 de fevereiro de 2013 15:01
    quinta-feira, 27 de dezembro de 2012 02:52

Todas as Respostas

  • Manoel,

    Segue os procedimentos

    - Instale o WSS
    http://office.microsoft.com/pt-br/help/instalacao-do-windows-sharepoint-services-3-0-HA010289366.aspx

    - Cria o web application
    http://technet.microsoft.com/en-us/library/cc287954%28v=office.12%29.aspx

    - Cria o site collection
    http://technet.microsoft.com/en-us/library/cc288969%28v=office.12%29.aspx

    - Remove o banco de conteúdo
    http://technet.microsoft.com/library/0a87c80e-1a47-4004-9541-11d5d5be5923.aspx

    - Adiciona o banco de conteúdo do sharepoint antigo
    http://technet.microsoft.com/library/d56a6e5b-a38b-482e-a13b-011665ffe5e6.aspx

    Lembrando que você o ideal é você remover os bancos de configuração antes de tentar instalar novamente o SharePoint, pois pode ter conflito. O importante é o banco de conteúdo.


    Atenciosamente, Rafael Fausto


    • Editado Rafael Fausto quarta-feira, 19 de dezembro de 2012 17:26
    quarta-feira, 19 de dezembro de 2012 17:25
  • Rafael, grato pela atenção, vou fazer direitinho que você mencionou. Vou remover os bancos de configuração para não dar conflito, assim que concluir o trabalho, volto para para falar do resultado, desde já agradeço demais seu retorno. Grato.

    quarta-feira, 19 de dezembro de 2012 17:38
  • Maqneto,

    Conseguiu resolver? Quando for instalar o SharePoint em produção, nunca instale com standalone como está esse seu servidor atual, prefira sempre a instalação completa. Para migrar as bases e fazer todas as demais tarefas é muito melhor, entre outros benefícios.


    Atenciosamente,

    Fabian André Gehrke
    MCITP e MCPD SharePoint 2010
    http://fabiangehrke.com.br

    quarta-feira, 19 de dezembro de 2012 20:04
  • os banco de dados da BDInternal encontra-se em c:\windows\sysmsi\sse\mssql2005\mssql\data depois so tens que fazer as instruçoes stsadm para adicionar a site collection.

    André Lage Microsoft SharePoint, CRM Consultant
    Blog:http://aaclage.blogspot.com
    Codeplex:http://spupload.codeplex.com/http://simplecamlsearch.codeplex.com/


    quarta-feira, 19 de dezembro de 2012 21:57
    Moderador
  • Reinstalei o Sharepoint com a mesma versão que era a anterior, infelizmente, Fabian, instalei em standalone pois quero recuperar os conteudo do site desinstalado. Pois bem, esta instalado e funcionando, qual o segundo passo para recuperar o site anterior, lembrando que tenho no banco de dados Internal do Windows o WSS_content_abcdefghijlmn.... do site desinstalado. Fausto, continuo com o procedimento que me passou ou tem alguma procedimento novo, antes de ir para o 2º passo (1º passo - instalado o sharepoint - funcionando). 

    quinta-feira, 20 de dezembro de 2012 12:12
  • André, grato por informar onde esta localizado os banco de dados do BD Internal, estava pesquisando isso e não encontrava, obrigado mesmo!!!!!
    quinta-feira, 20 de dezembro de 2012 12:14
  • Manoel,

    Conseguiu recuperar os bancos de conteúdo?


    Atenciosamente, Rafael Fausto

    quinta-feira, 20 de dezembro de 2012 12:35
  • Fausto, vou remover o banco de dados de conteudo instalado com esse comando: stsadm.exe -o deletecontentdb -url http://meusite -databasename WSS_Content_123456789... depois de removido, incluir o comando stsadm.exe -o addcontentdb -url http://meusite -assignnewdatabaseid - tenho que incluir isso!!! -clearchangelog - mais isso!!!! -databasename <nome do banco de dados> -databaseserver <nome do servidor do banco de dados>

     -databaseuser <nome do usuário do banco de dados> -databasepassword <senha do banco de dados> -sitewarning <contagem de aviso de site> -sitemax <contagem máx de site>], é só isso que tenho que fazer, tem como simplificar este ultimo comando?

    quinta-feira, 20 de dezembro de 2012 13:16
  • A minha duvida é, tenho que fazer esse procedimento em cima da aplicação web que foi implantada na reinstalação ou terei que excluir e criar outra?
    quinta-feira, 20 de dezembro de 2012 14:03
  • Fausto,

    Ao adicionar o banco de conteúdo do sharepoint antigo ao reinstalado, dá a seguinte mensagem: A SPContentdatabase name=WSS_Content_123456789 Parent=SPDatabaseserviceinstance name=MICROSOFT##SSEE especificada foi atualizada para uma versão mais recente no Sharepoint. Atualize este servidor de aplicativo do Sharepoint antes de tentar acessar este objeto, lembrando que estou utilizando o comando stsadm, você teria alguma solução para esta situação?

    quinta-feira, 20 de dezembro de 2012 14:54
  • Manoel,

    Parece que o ambiente atual não reflete o ambiente antigo. No ambiente antigo tinha algum service pack, hotfix ou algo do genero?

    A questão de remover e adicionar um novo banco de conteúdo é o seguinte.

    Remover:

    stsadm.exe -o deletecontentdb -url <Nome de URL> -databasename <nome do banco de dados>

    [-databaseserver] <nome do servidor de banco de dados>

    Adicionar

    stsadm.exe -o addcontentdb

       -url <Nome de URL> -databasename <nome do banco de dados> [-databaseserver <nome do servidor do banco de dados>]

    As outras propriedades não são obrigatórias, veja no site que passei.



    Atenciosamente, Rafael Fausto

    quinta-feira, 20 de dezembro de 2012 17:20
  • Fausto,

    Consegui adicionar o banco de dados de conteudo do ambiente antigo na nova instalação, ao acessar o o site não traz os dados, arquivos e listas do antigo e sim um site novo limpo, onde tenho que ir para acessar os conteudos do antigo ambiente?

    quinta-feira, 20 de dezembro de 2012 19:12
  • Então alguma coisa esta com problema. Tem certeza que você colocou o banco correto?

    Qual o nome do banco de conteúdo antigo? E qual o tamanho dele?

    http://technet.microsoft.com/en-us/library/cc288071%28v=office.12%29.aspx#section3

    Atenciosamente, Rafael Fausto

    quinta-feira, 20 de dezembro de 2012 19:21
  • Fausto,

    Na verdade existem dois bancos 1) WSS_Content_123456789 e 2)WSS_Content, o 1º tem em media 52MB e o 2º tem 180MB, terei que acrescentar o 2º então, recuperei o 1º pois quando vi pela ultima vez estava direcionado para esse banco, o que sugere?

    sexta-feira, 21 de dezembro de 2012 11:10
  • Corrigindo, o 1º tem 43,200kb e o 2º 132,288kb.
    sexta-feira, 21 de dezembro de 2012 11:37
  • Você já adicionou os dois bancos antigos no sharepoint novo para ver o conteúdo?

    Atenciosamente, Rafael Fausto

    sexta-feira, 21 de dezembro de 2012 12:28
  • Um eu consegui seria o 1º o 2º estou tentando...
    sexta-feira, 21 de dezembro de 2012 12:55
  • Mas está com problemas no segundo?

    Atenciosamente, Rafael Fausto

    sexta-feira, 21 de dezembro de 2012 13:19
  • É meu camarada, fiz coisas que não devia, não consegui, esta as duas bases de dados de conteudo e nada. Terei que jogar a toalha ou não?

    sexta-feira, 21 de dezembro de 2012 13:24
  • Jogar a toalha nunca!

    Então você ja adicionou as duas bases antigas na farm nova e não encontrou seus arquivos?


    Atenciosamente, Rafael Fausto

    sexta-feira, 21 de dezembro de 2012 13:53
  • Isso, as duas estão anexadas, mas continua o site padrão de instalação, lembrando que no site anterior ele tinha varias abas (setores), será que tem a ver com as configurações?
    sexta-feira, 21 de dezembro de 2012 14:00
  • Tem alguma solução, exemplo, acessar todos os conteudos da base de dados e recuperar os arquivos (word, excel, pdf) dos sites que estava instalado anteriormente?

    sexta-feira, 21 de dezembro de 2012 14:02
  • é isso mesmo, o que deverá estar acontecendo...
    sexta-feira, 21 de dezembro de 2012 16:22
  • Não conheço nenhuma solução para você acessar os dados diretamente do SQL.

    Sugiro que você faça novamente os passos para restauração dos bancos.


    Atenciosamente, Rafael Fausto

    sexta-feira, 21 de dezembro de 2012 17:24
  • Olá Manoel,

    Vou aproveitar e dar minhas sugestões também ;p

    Aparentemente está com problemas para subir o conteúdo das bases nos seus sites SharePoint. Pelo que pude perceber, você consegue restaurar as bases mas o conteúdo não é refletido nos sites, é isso mesmo?

    Apenas para efeito de teste, subi uma VM com SharePoint 2007 e segui os seguintes procedimentos para restaurar os sites de uma web application à partir de um MDF do SQL. Sugiro que verifique se também poderá ajudar em seu cenário:

    - No novo ambiente SharePoint (o último que você configurou e deseja restaurar as bases), crie uma nova web application (Central Admin > Application Management > Create or Extend Web Application > Create a New Web Application). Será criado também um content database, algo como WSS_Content_ABCD.

    - No servidor do banco de dados (como mencionou estar utilizando uma instalação stand-alone, certamente deverá ser o mesmo servidor) restaure (ou de um 'attach') nas bases utilizadas anteriormente (algo como WSS_Content_XPTO). Com o SQL Management Studio fica bem mais fácil ;p

    - Com as bases restauradas, remova o content database criado anteriormente com a WebApplication (pode ser via stsadm OU Central Admin > Application Management > Content Databases > Web Application (Selecione a Web Application criada) > algo como WSS_Content_ABCD > Remove Content Database > OK).

    - Agora você precisa anexar essa base ao web application do SharePoint, que novamente pode ser feito via stsadm OU Central Admin > Application Management > Content Databases > Web Application (Selecione a Web Application criada) > Add a content Database > Entre com o Database Name (algo como WSS_Content_XPTO) > OK.

    - Para ficar com a consciência tranquila, execute um iisreset e faça um teste acessando a URL da WebApplication.

    Este é o procedimento que executei para restaurar um site sem customizações no SharePoint ou modificações no IIS. Espero que possa ajudá-lo também!

    Refente aos problemas de versão no restore, isso provavelmente está relacionado com o que o Rafael falou sobre versões, ou mais especificamente sobre as builds do SharePoint (que são alteradas a cada Service Pack, Cumulative Update, ...). 

    Segue abaixo uma lista que poderá ajudá-lo a se orientar sobre as builds e quais são os updates necessários para deixar diferentes ambientes equivalentes:

    http://todd-carter.com/sharepoint-versions/#WSS3

    Sobre restaurar os arquivos disponíveis em um site do SharePoint via backup do SQL, infelizmente nunca vi isso na prática. No entanto acredito que algumas ferramentas da AvePoint poderão ajudar nesta tarefa:

    http://www.avepoint.com/docave-recovery-manager-for-sharepoint/

    Obs.: eles possuem versões trial :)

    []'s


    Tarcísio Gambin | MCP, MCT, MCTS, MCITP, ITILv3
    www.tarcisiogambin.net


    • Editado Tarcisio Gambin quinta-feira, 27 de dezembro de 2012 09:54
    • Marcado como Resposta Richard Juhasz quinta-feira, 7 de fevereiro de 2013 15:01
    quinta-feira, 27 de dezembro de 2012 02:52
  • Tarcisio, sei que é tarde, mas obrigado por responder, infelizmente abandonei esse projeto por não ter conseguido restaurar, te garanto que tentarei novamente restaurar essa base quando tiver tempo, e usarei seu passo-a-passo para tentar restaurar.

    Assim que voltar para essa missão, espero contar com você caso dê algo errado!!!

    Grato,

    Manoel Neto

    quarta-feira, 27 de março de 2013 00:32