none
Problema com report do Wsus após instalação do SCCM RRS feed

  • Pergunta

  • Opa blz,

    Estou com o seguinte problema, implantamos o SCCM e a principio iriamos utilizar o SCCM para updates, porém projeto de update pelo SCCM não foi aceito por causa do enorme trabalho em gerenciar os updates. Agora estou tentando voltar a utilizar o Wsus porém as máquinas não estão reportando para ele, tinha visto algo informando qure após habilitar o software updates as máquinas realmente não iriam mais reporta para o wsus. Já desabilitei meu softwares update no SCCM, verifico no client Windows e já consta como desabilitado, porém ainda máquinas não estão reportando.

    Teria alguma sugestão para meu problema.

    Abs,

     

     

    quinta-feira, 15 de abril de 2010 12:30

Respostas

  • ola,

    1- Altere a opcao do SUP para registar todos os eventos no wsus
    2- no wsus, vai até options, computers e selecione a opcção "Use Group policy or ...."
    3- selecione 2 clientes para teste
       no 1o,  execute: wuauclt.exe /resetauthorization /detectnow
       vai na console e veja se ele aparece
       depois vai no 2o e execute o mesmo comando, dai vai na console e veja se os 2 estão lah...
    4- se não estiverem, pode ser problema com o ComputerID no banco, para testar:
       no sql use: select IPAddress, ComputerID from tbComputerTarget
       depois vai no 1o cliente e execute novamente o wuauclt, aguarde alguns instantes e execute novamente o SQL...

    vc vai ter algo assim
    1o SQL = 10.0.0.1 a7620fbc-f675-426c-8fa6-e87167811143
    2o SQL = 10.0.0.3 a7620fbc-f675-426c-8fa6-e87167811143

    note que o ip é diferente e o ComputerID é o mesmo...

    para resolver, abra o registro (HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate) e apague as seguintes chaves 
    SusClientId, PingID*, AccountDomainSid*
    *PINGID e AccountDomainSid podem nao existir.

    reinicie o computador

    execute novamente o wuauclt

    aguarde alguns instantes e faça um refresh na console...agora deve aparecer correto...e no sql deve aparecer assim
    10.0.0.1 65b5cf3e-a899-4ba9-be58-28b0e9bdd85a
    10.0.0.3 a7620fbc-f675-426c-8fa6-e87167811143

    [EDITADO]
    esqueci de adicionar...

    no cliente, veja se as configuracoes estao ok usando o clientdiag
    ele pode ser baixado em
    http://technet.microsoft.com/en-us/wsus/bb466192.aspx


    espero ter ajudado,

    Raphael - MCP/MCSA Security/MCSE Security/MCTS/MCITP/MCT/MVP - http://www.dotnetwork.com.br
    • Marcado como Resposta Ulisses Felix terça-feira, 4 de maio de 2010 18:35
    sexta-feira, 16 de abril de 2010 09:25
    Moderador
  • Raphael,

     

    Então obrigado pela ajuda mais ou eu não acabei fazendo os procedimentos certo ou não funcionou mesmo executando os procedimentos. Então o que eu fiz foi habilitar o SUP novamente e colocar para report all WSUS, após todas máquinas reportarem eu desabilitei o SUP e atualmente está reportando normal para o WSUS novamente todas as máquinas mesmo com o SUP desabilitado.

    Abs

     

    • Marcado como Resposta Ulisses Felix terça-feira, 4 de maio de 2010 18:34
    terça-feira, 4 de maio de 2010 18:34

Todas as Respostas

  • ola,

    qdo vc desinstala o cliente sccm ou desabilita o software update dele, ele n atualiza a gpo local...

    vc pode alterar isso criando uma gpo para apontar pro teu wsus..
    blog.dotnetwork.com.br/?p=143

    lembre que 1o vc tem que desabilitar o agente do software update na console do sccm (site database->site management->codigo do site->site settings->client agents, abra o software update client agent e desabilite), deixar os clientes atualizarem as politicas e depois aplicar a gpo...

    espero ter ajudado,


    Raphael - MCP/MCSA Security/MCSE Security/MCTS/MCITP/MCT/MVP - http://www.dotnetwork.com.br
    quinta-feira, 15 de abril de 2010 14:24
    Moderador
  • Oh Raphael,

     

    Obrigado sim pela ajuda mais meu ambiente já está funcionando desta forma que você mencionou está configurado a GPO apontando para o WSUS, e eu já desabilitei no SCCM a opção de software update, teria eu que desinstalar o client do sccm da estação de trabalho? Porque se eu for na estação de trabalho e no painel de controle em configuration manager já aparece a opção de software update como desabilitado. Já reiniciei o server de Wsus pensando que iria mudar em algo mais nada por enquanto e tbm já atualizei a gpo gpupdate /force na estação de trabalho. O que poderiamos estar verificando levando em considerações esses itens.

    Desde já agradeço obrigado

     

    quinta-feira, 15 de abril de 2010 16:45
  • ola,

    1- Altere a opcao do SUP para registar todos os eventos no wsus
    2- no wsus, vai até options, computers e selecione a opcção "Use Group policy or ...."
    3- selecione 2 clientes para teste
       no 1o,  execute: wuauclt.exe /resetauthorization /detectnow
       vai na console e veja se ele aparece
       depois vai no 2o e execute o mesmo comando, dai vai na console e veja se os 2 estão lah...
    4- se não estiverem, pode ser problema com o ComputerID no banco, para testar:
       no sql use: select IPAddress, ComputerID from tbComputerTarget
       depois vai no 1o cliente e execute novamente o wuauclt, aguarde alguns instantes e execute novamente o SQL...

    vc vai ter algo assim
    1o SQL = 10.0.0.1 a7620fbc-f675-426c-8fa6-e87167811143
    2o SQL = 10.0.0.3 a7620fbc-f675-426c-8fa6-e87167811143

    note que o ip é diferente e o ComputerID é o mesmo...

    para resolver, abra o registro (HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate) e apague as seguintes chaves 
    SusClientId, PingID*, AccountDomainSid*
    *PINGID e AccountDomainSid podem nao existir.

    reinicie o computador

    execute novamente o wuauclt

    aguarde alguns instantes e faça um refresh na console...agora deve aparecer correto...e no sql deve aparecer assim
    10.0.0.1 65b5cf3e-a899-4ba9-be58-28b0e9bdd85a
    10.0.0.3 a7620fbc-f675-426c-8fa6-e87167811143

    [EDITADO]
    esqueci de adicionar...

    no cliente, veja se as configuracoes estao ok usando o clientdiag
    ele pode ser baixado em
    http://technet.microsoft.com/en-us/wsus/bb466192.aspx


    espero ter ajudado,

    Raphael - MCP/MCSA Security/MCSE Security/MCTS/MCITP/MCT/MVP - http://www.dotnetwork.com.br
    • Marcado como Resposta Ulisses Felix terça-feira, 4 de maio de 2010 18:35
    sexta-feira, 16 de abril de 2010 09:25
    Moderador
  • Raphael,

     

    Então comecei me perdendo pelo 1º passo ...rsrs o que seria "Altere a opcao do SUP para registar todos os eventos no wsus" não sei o que seria este SUP

    Como havia mencionado sou novato em WSUS e SCCM

    Obrigado,

     

     

     

    sexta-feira, 16 de abril de 2010 21:53
  • Raphael,

     

    Outra coisa que notei em seu procedimento para fazer testes com esses comandos do SQL onde devo executar até porque não tem SQL neste WSUS não entendi e não conheço, poderia me explicar mais detalhado porque realmente sou bem novato nestas ferramentas.

    Obrigadão

    Abs,

    sexta-feira, 16 de abril de 2010 22:12
  • ola...

    no passo 1, Expanda Site Database, Site Management, <Código do Site>, Site Settings, clique em Component Configuration e então selecione Software Update Point Component, vai na aba sync settings e selecione "Create all wsus reporting events"

     

    na parte dos comandos sql, vc pode usar o osql ou baixar o sql management studio express da MS (http://www.microsoft.com/downloads/details.aspx?FamilyId=C243A5AE-4BD1-4E3D-94B8-5A0F62BF7796&displaylang=en).

    espero ter ajudado,


    Raphael - MCP/MCSA Security/MCSE Security/MCTS/MCITP/MCT/MVP - http://www.dotnetwork.com.br
    sexta-feira, 23 de abril de 2010 13:07
    Moderador
  • Raphael,

     

    Então obrigado pela ajuda mais ou eu não acabei fazendo os procedimentos certo ou não funcionou mesmo executando os procedimentos. Então o que eu fiz foi habilitar o SUP novamente e colocar para report all WSUS, após todas máquinas reportarem eu desabilitei o SUP e atualmente está reportando normal para o WSUS novamente todas as máquinas mesmo com o SUP desabilitado.

    Abs

     

    • Marcado como Resposta Ulisses Felix terça-feira, 4 de maio de 2010 18:34
    terça-feira, 4 de maio de 2010 18:34