none
CÉLULA COM VARIÁVEIS RRS feed

  • Pergunta

  • BOM DIA, PRECISO DE AJUDA.

    QUERO USAR O EXCEL PARA UMA TAREFA, MAS SEM PRECISAR CONHECER O VBA.

    É O SEGUINTE: IMAGEM UMA PLANILHA P1 ONDE EU TENHA EM DUAS CÉLULAS A1 E A2 VALORES QUE DEVEM SER SOMADOS

    EM A3 [=SOMA(A1;A2)]. PORÉM QUERO QUE OUTRA PLANILHA P2 USE O RESULTADO DESSA SOMA MAS COM VALORES EM A1 E A2 PRODUZIDOS POR ELA E QUE P1 RETORNE O RESULTADO. POR EXEMPLO, EM P2 FARIA UMA CHAMADA PARA A SOMA EM P1 PASSANDO OS VALORES (ALGO COMO EM A1 DE P2 COLOCAR P1!(A1=3;A2=5) E EM P2 AINDA EM OUTRA CÉLULA A2 OBTER O RESULTO [=P2!A3] . O PROBLEMA É QUE QUERO FAZER A SOMA MAIS DE UMA VEZ SEM PERDER O RESULTADO ANTERIOR, POR EXEMPLO, EM B1 DE P2 TER ALGO COMO P1!(A1=1;A2=7) E EM B2 DE P2 TER O RESULTADO [=P2!A3] SEM PERDER A SOMA ANTERIOR. É POSSÍVEL ?????? MUITO OBRIGADO.

    quarta-feira, 7 de dezembro de 2016 12:38

Todas as Respostas

  • Olá. Como vai? Se possível, não utilize somente caixa alta (tudo em maiúsculo). Desculpe-me, mas sua necessidade não ficou clara. Talvez usando apenas exemplos numéricos para cada etapa do cálculo ficaria mais claro.
    quarta-feira, 7 de dezembro de 2016 13:09
  • Ola. Desculpe a falta de clareza. Vou tentar melhorar.

    Queria saber se é possível fazer o seguinte:

    Em uma planilha P1 do excel eu coloco uma função qualquer, por exemplo, em c1 coloco =SOMA(a1;b1).

    Digamos que eu queira usar mais de uma vez em outra planilha P2 o resultado produzido por essa soma mas com argumentos diferentes. Em P2 eu quero fazer em a1 a soma de 2 com 3 e em b1 a soma de 4 com 5.

    Teria como eu passa para a planilha P1 os argumentos (2 e 3 ; 4 e 5) e obter as duas somas através da mesma fórmula? Seria como se na planilha P1 eu tivesse variáveis em a1 e b1 e atribuísse valores diferentes a elas através da outra planilha várias vezes podemos obter os resultados de volta.

    Obrigado.

    quarta-feira, 7 de dezembro de 2016 13:38
  • Não tenho certeza se entendi, mas vamos lá.

    Em P1, supondo os valores 2 e 3 respectivamente em A1 e B1

    Em C1 a fórmula: =SOMA(A1:B1)

    Em P2, supondo os valores 4 e 5 respectivamente em A1 e B2

    Em C1 da P2 você poderia colocar a seguinte fórmula:

    =SOMA(P1!$C$1;A1:B1)

    Se não for isso, deixe-me saber.

    quarta-feira, 7 de dezembro de 2016 13:55
  • Ainda não fui claro o suficiente...desculpe.

    Entendi o que vc sugeriu, mas o que queria é algo diferente.

    Em P1 os valores em A1 e B1 seriam passados através da outra planilha P2.

    É como se em P1 tivéssemos uma variável X em A1 e outra Y em A2.

    Os valores de X e de Y seriam passados através da outra planilha P2.

    Como se houvesse em a1 de P2 algo como P1!a1=2;P1!b1=3 e em b1 de P2 aparecesse o resultado da soma (5)feita em P1.

    Mas queria poder usar isso em P2 várias vezes com outros argumentos (1 e 7) , (3 e 5) etc , sem alterar os resultados anteriores. Vejamos em a1,a2 e a3 de P2 algo como P1!a1=2;P1!b1=3 , P1!a1=1;P1!b1=7 , P1!a1=3;P1!b1=5 e pudesse obter em b1, b2 e b3 de P2 os resultados das três somas.

    quarta-feira, 7 de dezembro de 2016 14:16
  • Não tem como fazer isso, pois o valor da célula sempre assumirá o valor do momento, ou seja, a fórmula será processada e o valor final será sempre uma acumulação de valores. Usando apenas duas células não há como mantar um histórico de cada iteração.

    Se entendi direito, você está querendo um efeito de recursividade como o disponível em muitas linguagens de programação.

    Você terá que usar uma linha para cada combinação de valores.


    • Editado J. Maurício quarta-feira, 7 de dezembro de 2016 15:16
    quarta-feira, 7 de dezembro de 2016 15:13
  • Obrigado pela paciência Mauricio.

    Não é recursão que eu busco não. É mais ou menos como se em uma pasta eu tivesse uma

    função que devolvesse um resultado, dependo dos argumentos passados para ela.

    Assim, eu teria uma mesma função sendo usada várias vezes a partir de outra pasta com argumentos diferentes.

    Para cada argumento a mesma função poderia devolver um resultado diferente.

    Obrigado.

    quarta-feira, 7 de dezembro de 2016 15:41
  • Ok. Realmente não entendi seu problema, desculpe-me. Mesmo assim, fico à disposição.
    quarta-feira, 7 de dezembro de 2016 16:04
  • Boa tarde.

    Ainda não consegui resolver meu problema.

    Vamos tentar de novo?

    Imagine uma planilha com duas pastas: A e B .

    Na pasta A tenho uma função soma(a1;b1).

    Na pasta B quero usar o resultado da função soma algumas vezes

    mas mudando os valores de a1 e b1 a partir da pasta B.

    Ou seja, em B é feita uma chamada à função que está na pasta A passando de alguma forma

    os valores que devem ser somados.

    É possível?

    quinta-feira, 8 de dezembro de 2016 15:47
  • Olá, sem macro é impossível. A fórmula não é acessível, mas sim o conteúdo da célula, ou seja, aquilo que foi gerado ou não por uma função.

    quinta-feira, 8 de dezembro de 2016 16:15