none
OCS R2 - Ambiente de Testes RRS feed

  • Pergunta

  • Olá amigos.
    Fui incumbido de buscar uma ferramenta na qual atenda os seguintes requisitos abaixos:
    -Os usuários utilizem ferramentas de IM interna, podendo se comunicar com usuários externos(fora do meu domínio);
    -Os usuários (internos e externos) possam criar/visualizar reuniões e/ou treinamentos, diretamente a partir de seu computador. Caso for um treinamento, que o instrutor possa compartilhar seu computador com os demais usuários e após isso, gerar um vídeo com essa apresentação (Algo como um webcast da Microsoft);

    Após uma busca na Internet, li que o OCS 2007 R2 poderia atender esses requisitos (Pode mesmo?). Para avaliar o potencial da ferramenta, criarei uma infra de testes na qual irei fazer uma implantação mínima para atender esses requisitos.
    Busquei informações na Internet, porém todos os artigos que encontrei falam de um determinado tópico e não da implantação de uma infra completa. Resumindo:
    -Gostaria de saber se alguém aí conhece algum artigo ou tutorial no qual tenha um passo a passo para a implantação desses serviços.
    -Uma outra pergunta seria: qual a estrutura mínima de para eu poder criar esse ambiente de testes? 1, 2, 3 servidores?

    Grato!
    quarta-feira, 10 de junho de 2009 13:18

Respostas

  • Jean, vamos aos erros:

    Erro 1: Este aviso é porque no nível do pool o arquivamento está desabilitado enquanto no nivel global está habilitado. Para solucionar, verifique se você quer ou não ter arquivamento habilitado, se quiser, habilite arquivamento tanto no nível global, clicando com o botão direito do mouse sobre a floresta e acesse Propriedades, também habilite no nivel do pool, clicando com o botão direito do mouse sobre o pool (se for OCS EE) ou sobre o servidor (se for OCS ST),  acesse as propriedades e também habilite o arquivamento. Se você não quiser arquivamento desabilite nos dois niveis da mesma forma.

    Erro 2: Este aviso é porque existem usuários com a opção de federeção e acesso remoto habilitado sem que você tenha o servidor Edge (servidor que habilitaria estas funcionalidades). Para eliminar este aviso, selecione todos os usuários através da console do OCS, clique com o botão direito do mouse e selecione "Configure", vai dando next configurando os usuários porem não marque "federation"  e "remote access".

    []s,

    Bruno Estrozi - MCSE/MCTS/MCITP - Unified Communications Specialist
    quarta-feira, 17 de junho de 2009 21:39
  • Quanto ao erro, ele está indicando que você habilitou usuários com a funcionalidade de telefonia, e que não tem nenhum location profile associado ao pool. Neste caso, da mesma forma que você desmarcou os itens federation e remote access, durante o wizard de configuração do usuário, não marque a opção enterprise voice.

    Quanto a popular a lista de contatos existem duas formas:

    1- Manualmente, no communicator tem tem uma barra que você pode digitar o endereço sip do usuário ou o nome, e então adicionar o usuário a lista, +- como é feito no MSN.

    2- Popular a lista através de um script, ou ferramenta de terceiros:

    Script:
    1- Primeiro gere uma lista de usuários que estão com o OCS habilitado, no DOS execute:
    dsquery * "OU=Usuarios,DC=dominio,DC=com,DC=br" -attr msRTCSIP-PrimaryUserAddress -filter (msRTCSIP-UserEnabled=TRUE) > C:\Usuarios_OCS.txt
    

    2- Adicione os usuários da lista gerada a lista de contatos de todos os usuários do OCS, no DOS execute: CD "C:\Program Files\Microsoft Office Communications Server 2007\ResKit\WMI Samples" cscript.exe LCSAddContacts.wsf /usersfile:C:\Usuarios_OCS.txt /contactsfile:C:\Usuarios_OCS.txt
    Ferramenta de terceiros:
    Contact manager: http://www.andersonpatricio.org/Tutoriais/Tutoriais.asp?Tut=1105
    Bruno Estrozi - MCSE/MCTS/MCITP - Unified Communications Specialist
    quinta-feira, 18 de junho de 2009 14:24

Todas as Respostas

  • Ola Jean,

    Tu chegou a olhar no histórico ou ainda na documentaçao do produto, tem passo a passo o procedimento. Lá no site temos tutorial de implementaçao do OCS 2007 e OCS 2007 R2 eu estou trabalhando em terminar, tu pode olhar aqui: http://www.andersonpatricio.org/Tutoriais/Tutoriais.asp?Tut=1120

    Tem também uns tutoriais de OCS vindo do Emerson Moraes, vale a pena esperar :).

    Em relaçao a tua pergunta e do ambiente de testes.. depende do qu etu quer fazer. Se for só um UM interno, 1 servidor, se precisar de acesso externo , mínimo 2. Claro que tem dimensionar certifiados, servidores, número de usuarios e tudo mais como também hardware para suportar isso, eu costumo dizer que o time do produto recomenda 8GB mínimo por cada role.


    Grande abraço, Anderson Patricio http://www.andersonpatricio.org .:. http://blog.andersonpatricio.org http://msmvps.org/blogs/andersonpatricio
    quarta-feira, 10 de junho de 2009 14:26
  • Anderson, agradeço seu retorno. Desculpe a demora para postar, mas é que emendei o feriado.
    Eu já havia visto seu site (muito bom por sinal) e esse tutorial. Fiz os passos executados nessa primeira parte do tutorial, ou seja, ja estou com meu AD configurado para o OCS R2.
    Continuando, procedi com a instalação utilizando o instalador do aplicativo. Segue os passos que executei:

    - Instalei o MSMQ no meu servidor (Win2008x64). Creio que seja um pré-requisito, pois sem isso não será possivel levantar os serviços de Agente de Monitramento;
    - Fiz a instalação do servidor de Front End e de conferência (Etapa 1);
    - Fiz a configuração do Servidor, DNS e validação (Etapa 2);
    - Fiz a configuração dos certificados (Etapa 3). Configurei um servidor de certificados em meu Controlador de AD e usei ele para gerar o certificado para o OCS;
    - Configurei o certificado no IIS (Etapa 4);
    -Iniciei os serviços (Etapa 6);

    Teoricamente, esta tudo instalado. Entretanto, se vou na ferramenta de validação de funcionalidades, e vou validar meu servidor de Front-End (Etapa 1), os seguintes erros ocorrem:

    Erro: A configuração de arquivamento no nível do pool não está consistente com a configuração de arquivamento global. O arquivamento no nível global é Habilitado, mas o arquivamento no nível do pool é Desabilitado. Habilite ou desabilite o arquivamento nos dois locais.

    Aviso: Um ou mais usuários hospedados do pool estão habilitados para federação ou acesso remoto, mas nenhum servidor de borda de webconferência está especificado para o pool.
    Erro: Um ou mais usuários hospedados do pool estão habilitados para federação, acesso remoto ou conectividade pública de mensagens instantâneas, mas a federação global está desabilitada.


    Alguma idéia do motivo disso ocorrer?
    segunda-feira, 15 de junho de 2009 19:40
  • Jean, vamos aos erros:

    Erro 1: Este aviso é porque no nível do pool o arquivamento está desabilitado enquanto no nivel global está habilitado. Para solucionar, verifique se você quer ou não ter arquivamento habilitado, se quiser, habilite arquivamento tanto no nível global, clicando com o botão direito do mouse sobre a floresta e acesse Propriedades, também habilite no nivel do pool, clicando com o botão direito do mouse sobre o pool (se for OCS EE) ou sobre o servidor (se for OCS ST),  acesse as propriedades e também habilite o arquivamento. Se você não quiser arquivamento desabilite nos dois niveis da mesma forma.

    Erro 2: Este aviso é porque existem usuários com a opção de federeção e acesso remoto habilitado sem que você tenha o servidor Edge (servidor que habilitaria estas funcionalidades). Para eliminar este aviso, selecione todos os usuários através da console do OCS, clique com o botão direito do mouse e selecione "Configure", vai dando next configurando os usuários porem não marque "federation"  e "remote access".

    []s,

    Bruno Estrozi - MCSE/MCTS/MCITP - Unified Communications Specialist
    quarta-feira, 17 de junho de 2009 21:39
  • Bruno, muito obrigado pelas respostas, realmente me ajudou aqui.
    Agora, existe apenas mais uma mensagem de erro ocorrendo nesta validação:

    Erro: Um ou mais usuários hospedados do pool estão habilitados para telefonia, mas o perfil do local padrão não foi especificado para o pool.

    Continuando, nesse ambiente de testes, configurei uma estação com XP. Neste equipamento, loguei com um usuário que esta configurado para usar o OCS. Instalei o Office Communicator no equipamento. O Communicator, autenticou automaticamente o usuário e ficou online. Entretanto, nenhum outro usuário aparece na lista de usuários no Communicator.
    Como eu configuro Grupos e Usuários para popularem automaticamente nos clientes?
    quinta-feira, 18 de junho de 2009 12:51
  • Quanto ao erro, ele está indicando que você habilitou usuários com a funcionalidade de telefonia, e que não tem nenhum location profile associado ao pool. Neste caso, da mesma forma que você desmarcou os itens federation e remote access, durante o wizard de configuração do usuário, não marque a opção enterprise voice.

    Quanto a popular a lista de contatos existem duas formas:

    1- Manualmente, no communicator tem tem uma barra que você pode digitar o endereço sip do usuário ou o nome, e então adicionar o usuário a lista, +- como é feito no MSN.

    2- Popular a lista através de um script, ou ferramenta de terceiros:

    Script:
    1- Primeiro gere uma lista de usuários que estão com o OCS habilitado, no DOS execute:
    dsquery * "OU=Usuarios,DC=dominio,DC=com,DC=br" -attr msRTCSIP-PrimaryUserAddress -filter (msRTCSIP-UserEnabled=TRUE) > C:\Usuarios_OCS.txt
    

    2- Adicione os usuários da lista gerada a lista de contatos de todos os usuários do OCS, no DOS execute: CD "C:\Program Files\Microsoft Office Communications Server 2007\ResKit\WMI Samples" cscript.exe LCSAddContacts.wsf /usersfile:C:\Usuarios_OCS.txt /contactsfile:C:\Usuarios_OCS.txt
    Ferramenta de terceiros:
    Contact manager: http://www.andersonpatricio.org/Tutoriais/Tutoriais.asp?Tut=1105
    Bruno Estrozi - MCSE/MCTS/MCITP - Unified Communications Specialist
    quinta-feira, 18 de junho de 2009 14:24
  • Grato mais uma vez.
    Agora, vou abusar mais um pouquinho rs...
    Gostaria de testar o recurso de reunião com compartilhamento de Desktop. Algo parecido como um Webcast da Microsoft. Ou seja, um usuário "levanta" a sessão e compartilha sua tela, com algumas pessoas.
    Como devo proceder? Ao final, é gerado algum arquivo de vídeo como é feito através do Webcast? Quantas pessoas podem acessar simultaneamente uma apresentação desse tipo? Todas as pessoas precisam estar cadastradas no meu AD, ou usuários externos podem participar dessa reunião?

    Grato!
    segunda-feira, 22 de junho de 2009 17:31
  • Vamos lá:

    Como devo proceder?
    Com o Front-End do OCS você já tem esta funcionalidade, basta instalar o Live Meeting cliente, e fazer a reunião.

    Ao final, é gerado algum arquivo de vídeo como é feito através do Webcast?
    Somente se o apresentador pedir para gravar a sessão, existe um botão para isso.

    Quantas pessoas podem acessar simultaneamente uma apresentação desse tipo?
    250 pessoas na mesma sala, porem fique atento ao consumo de banda é isso que geralmente pega.

     Todas as pessoas precisam estar cadastradas no meu AD, ou usuários externos podem participar dessa reunião?
    Usuários externos podem participar, porem você precisará o OCS Edge, é um servidor que fica na DMZ e faz este proxy entre a internet e sua LAN.



    Bruno Estrozi - MCSE/MCTS/MCITP - Unified Communications Specialist
    segunda-feira, 22 de junho de 2009 20:21
  • Caro Bruno.
    Fiz as instalações conforme seu comentário anterior. Agora as dúvidas tangem ao gerenciamento das permissões para iniciar a sessão.
    Instalei o Add-In do Outlook de um client, porém, quando clico no botão Agendar Reunião ou mesmo em Reunir Agora recebo uma mensagem informando que este usuário não tem privilégios necessários para Iniciar uma Reunião.

    Outra pergunta: consigo iniciar uma reunião pelo Live Meeting Client?
    Tentei iniciar uma reunião também diretamente através do Live Meeting Client 2007, porém não sei quais parâmteros devo colocar no itens solictados:

    Id da reunião: pode ser qualquer coisa? ou deixar em branco?
    Local:  ele sugere que eu ponha algo como meet:sip:user1@labcesup.com:gruu; etc....

    Como sei quais informações por neste local?
    terça-feira, 23 de junho de 2009 12:36
  • As permissões você altera nas propriedades da floresta (na console do OCS) lá vai ter um aba chamada "Meeting" coloque no Nível 1 (permite tudo, audio, video etc.) e tem um campo que especifica se esta configuração será aplicada a todos ou por usuário, coloca para todos para testar e depois se quiser muda estas configurações.

    No LM Cliente para inicia um sessão clica no botão "Reunir Agora", se este botão não estiver aparecento é porque você não o configurou ainda, para isso insira o usuário e senha assim como você fez no Coomunicator cliente.

    Existem basicamente três formas de iniciar uma sessão de LM.

    1- Pelo Outlook como você fez.
    2- Pelo próprio LM cliente.
    3- Quando você estiver "conversando" com alguem no Communicator, clicar no botão "Compartilhar Informações usando o LM".


    Bruno Estrozi - MCSE/MCTS/MCITP - Unified Communications Specialist
    terça-feira, 23 de junho de 2009 12:59
  • As permissões você altera nas propriedades da floresta (na console do OCS) lá vai ter um aba chamada "Meeting" coloque no Nível 1 (permite tudo, audio, video etc.) e tem um campo que especifica se esta configuração será aplicada a todos ou por usuário, coloca para todos para testar e depois se quiser muda estas configurações.

    No LM Cliente para inicia um sessão clica no botão "Reunir Agora", se este botão não estiver aparecento é porque você não o configurou ainda, para isso insira o usuário e senha assim como você fez no Coomunicator cliente.

    Existem basicamente três formas de iniciar uma sessão de LM.

    1- Pelo Outlook como você fez.
    2- Pelo próprio LM cliente.
    3- Quando você estiver "conversando" com alguem no Communicator, clicar no botão "Compartilhar Informações usando o LM".


    Bruno Estrozi - MCSE/MCTS/MCITP - Unified Communications Specialist

    Fiz as alterações de permissão e funcionou.
    Até a título de documentação para futuras referências, esta opção do "Reunir Agora" não estava aparecendo no LM Client porque faltava uma atualização da Microsoft. Eu identifiquei isso através do Communicator. Após instalar o LM Client, o Communicator ficou com um ponto de exclamação. Acessando ele, vi essa mensagem informando que era necessário instalar um update da Microsoft.
    Após instalar ele e reiniciar o micro essa opção apareceu.

    Entretanto, ainda existe uma mensagem de erro no Communicator. A mensagem é: "Erro de Interação com o Outlook." Ao clicar em mais detalhes, a mensagem é:
    "Problema ao conectar ao Microsoft Office Outlook. Seu perfil de Outlook não esta configurado corretamente."
    O caso é que configurei uma conta de teste no Outlook, lembrando que nessa infra de testes eu não tenho Exchange configurado.
    terça-feira, 23 de junho de 2009 14:57
  • Na verdade são duas coisas diferentes, o botão era configuração mesmo, já o patch é para permitir que o cliente se integre ao Outlook para isso precisa deste path que você já instalou.

    Porem se a exclamassão ainda está lá então verifique os itens que eu postei nesta tread.

    http://social.technet.microsoft.com/Forums/pt-BR/ocslivcommpt/thread/94b5269d-6277-4bb1-9771-d2748e665026 

    Bruno Estrozi - MCSE/MCTS/MCITP - Unified Communications Specialist
    terça-feira, 23 de junho de 2009 15:05
  • Caro Bruno,
    desculpe a insistência, mas segui as alternativas do seu post na outra thread e não houve jeito de resolver o problema. Cheguei inclusive a fazer a mudança pelo registro e depois de reiniciar e testar. Testei também através do arquivo de Template. Habilitei a opção através do GPEdit.msc, porém não funcionou.
    Será que isso esta ocorrendo porque não tenho o Exchange configurado no Lab?
    terça-feira, 23 de junho de 2009 19:06
  • Com certeza sim.

    Bruno Estrozi - MCSE/MCTS/MCITP - Unified Communications Specialist
    terça-feira, 23 de junho de 2009 19:11
  • Imaginei que fosse isso. Mas por exemplo, no meu caso, que a minha organização não tem Exchange, existe alguma maneira de eu desabilitar isso?
    terça-feira, 23 de junho de 2009 20:01
  • Não conheço, mas creio que não.

    Bruno Estrozi - MCSE/MCTS/MCITP - Unified Communications Specialist
    terça-feira, 23 de junho de 2009 20:08
  • Jean,

    Dentro do Communicator, --> Tools --> Options

    Lá, desmarque as seguintes opções:

    Personal Information Manager --> Update My Presence Based on my Outlook calendar information
      e Display my out of office information .......

    É necessário fechar e abrir o Communicator. Se a exclamação continuar, desabilite totalmente a integração com o Outlook.


    Emerson Moraes
    quinta-feira, 3 de setembro de 2009 11:56
  • Boa Noite Bruno.

    Estou com um problema, mas não consigo resolver. No término validação do front-end, o erro abaixo foi apresentado, mas todos os outros testes de validação foram concluidos com sucesso:

    Erro: Um ou mais usuários hospedados do pool estão habilitados para telefonia, mas o perfil do local padrão não foi especificado para o pool.

    Poderia me dar alguma dica sobre a situação?

    Aos que postaram no forúm, peço a colaboração se possivel.

    Obrigado


    Se Útil, Por Favor Marque Como Resposta - Alexandre Falcão - http://azfalcao.spaces.live.com/ - @alexandrezera - Microsoft Certified Professional
    terça-feira, 13 de julho de 2010 01:18
  • Não existe nenhum usuário habilitado para enterprise voice?
    Bruno Estrozi - MVP | MCTS | MCITP - http://brunoestrozi.com.br
    terça-feira, 13 de julho de 2010 13:16
  • Boa Tarde Bruno,

    Estou somente com 2 usuários para testes. Ambos estão com a opção "Habilitar Comunicação Somente PC-PC" habilitada.

    A versão é Standard Edition.

    No aguardo!

    Desde já agradeço.


    Se Útil, Por Favor Marque Como Resposta - Alexandre Falcão - http://azfalcao.spaces.live.com/ - @alexandrezera - Microsoft Certified Professional
    terça-feira, 13 de julho de 2010 15:39