none
Não conecto remotamente meu SQL Server pelo IP RRS feed

  • Pergunta

  • Quando vou conectar o meu banco de dados através de outro computador na mesma rede e domínio eu só consigo conectar pelo nome do computador (LPG-11\SQLEXPRESS2012) ou pelo IP + PORTA (10.139.1.32,1433\SQLEXPRESS2012). 

    Apenas pelo IP (10.139.1.32\SQLEXPRESS2012) eu não consigo.

    Já fui no SQL Configuration Manager e coloquei para a instância SQLEXPRESS2012 utilizar a porta 1433, mas mesmo assim não vai.

    Alguém sabe o que ta faltando?

    quinta-feira, 20 de novembro de 2014 15:41

Respostas

  • Syd,

    Não sei se você já fez esta verificação, mas segue: 

    Veja o protocolo TCP/IP e ative o escolhendo a opção "Yes" para a propriedade Enabled, como na imagem abaixo.

    Obs: Dependendo do caso pode ser que seja necessário habilitar também o protocolo Named Pipes.

    Logo à seguir, clique na aba "IP Addresses" e em IPALL no campo "TCP Port" informe a porta 1433.

    Reinicie o serviço do SQL Server da sua instância e tente se conectar novamente em uma outra máquina.


    Se ajudou na sua solução, não esqueça de marcar como resposta !

    Abraços,

    Durval Ramos
    Microsoft Partner | MTA | MCSA - SQL Server 2012 | MCSE - Data Platform
    ----------------------------------
    Se foi resolvido clique "Marcar como resposta" e se foi útil "Votar como Útil"

    sexta-feira, 21 de novembro de 2014 11:48
  • Syd,

    Se você tiver mais de uma instância do SQL Server instalado no mesmo servidor, você terá que especificar qual a porta ou nome da instância que esta querendo conectar...



    Tulio Rosa | http://tuliorosa.com.br | Se resolveu seu problema, marque como resposta ou vote

    • Marcado como Resposta Syd Franco quarta-feira, 21 de janeiro de 2015 13:50
    segunda-feira, 29 de dezembro de 2014 11:30

Todas as Respostas

  • Syd, Depois que você alterou a porta você reiniciou o serviço do SQL Server ? Senão, você precisa reiniciar...

    Tulio Rosa | http://tuliorosa.com.br | Se resolveu seu problema, marque como resposta ou vote

    quinta-feira, 20 de novembro de 2014 17:39
  • Reiniciei sim. Inclusive ele não conectava nem assim:

    10.139.1.32,1433\SQLEXPRESS2012

    Depois que eu coloquei a porta ele passou no Configuration Manager e reiniciei o serviço ele passou a funcionar, mas somente assim.

    quinta-feira, 20 de novembro de 2014 19:17
  • Reiniciei sim. Inclusive ele não conectava nem assim:

    10.139.1.32,1433\SQLEXPRESS2012

    Depois que eu coloquei a porta ele passou no Configuration Manager e reiniciei o serviço ele passou a funcionar, mas somente assim.

    Teria que funcionar somente com 10.139.1.32,1433 ...

    Verifique se você tem duas instancia do SQL Server nesse mesmo servidor com a mesma porta, se tiver coloque cada um em uma porta diferente ....


    Tulio Rosa | http://tuliorosa.com.br | Se resolveu seu problema, marque como resposta ou vote

    sexta-feira, 21 de novembro de 2014 10:43
  • Ehh... vou trocar de porta, pq tenho 2 SQL Server instalados aqui. Pode ser isso.
    sexta-feira, 21 de novembro de 2014 11:05
  • Syd,

    Não sei se você já fez esta verificação, mas segue: 

    Veja o protocolo TCP/IP e ative o escolhendo a opção "Yes" para a propriedade Enabled, como na imagem abaixo.

    Obs: Dependendo do caso pode ser que seja necessário habilitar também o protocolo Named Pipes.

    Logo à seguir, clique na aba "IP Addresses" e em IPALL no campo "TCP Port" informe a porta 1433.

    Reinicie o serviço do SQL Server da sua instância e tente se conectar novamente em uma outra máquina.


    Se ajudou na sua solução, não esqueça de marcar como resposta !

    Abraços,

    Durval Ramos
    Microsoft Partner | MTA | MCSA - SQL Server 2012 | MCSE - Data Platform
    ----------------------------------
    Se foi resolvido clique "Marcar como resposta" e se foi útil "Votar como Útil"

    sexta-feira, 21 de novembro de 2014 11:48
  • Eu pesquisei na internet e já tinha achado algo parecido com isso, Durval. Foi exatamente isso que eu fiz e aí passou a funcionar assim: (10.139.1.32,1433\SQLEXPRESS2012) mas não assim, como deveria: (10.139.1.32\SQLEXPRESS2012)
    sexta-feira, 21 de novembro de 2014 16:06
  • Eu pesquisei na internet e já tinha achado algo parecido com isso, Durval. Foi exatamente isso que eu fiz e aí passou a funcionar assim: (10.139.1.32,1433\SQLEXPRESS2012) mas não assim, como deveria: (10.139.1.32\SQLEXPRESS2012)

    Syd,

    Então se o SQL esta forçando o uso da porta "1433" tente inverter a configuração para remover esta necessidade, apague a referência da porta na propriedade "TCP Port" e adicione um número "X" na propriedade "TCP Dynamic Ports" para definição da porta dinâmica.

    Veja na imagem abaixo:

    Reinicie o serviço desta instância e tente executar conectar novamente.

    Se ajudou na sua solução, não esqueça de marcar como resposta !

    Abraços,

    Durval Ramos
    Microsoft Partner | MTA | MCSA - SQL Server 2012 | MCSE - Data Platform
    ----------------------------------
    Se foi resolvido clique "Marcar como resposta" e se foi útil "Votar como Útil"

    segunda-feira, 24 de novembro de 2014 17:17
  • Syd,

    Um detalhe, quando você fala de conexão remota, você esta se referindo a conexão na mesma rede ou através de alguma VPN?

    O IP deste Servidor esta configurado como fixo? Por acaso você já fez uso do comando ping informando o nome deste servidor com o parâmetro -a para verificar com é o IP que esta sendo retornado?

    Recentimente tive um problema parecido, e o que estava acontecendo era que o IPv6 esta sendo utilizado como IP para respostas e solicitações de rede.


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | Professor Universitário | SoroCódigos] @JuniorGalvaoMVP | pedrogalvaojunior.wordpress.com

    quarta-feira, 26 de novembro de 2014 12:41
    Moderador
  • Olá Junior Galvão!

    É na mesma rede sim. O ping está OK, consigo pingar. Vou checar o IPv6 pra ver se é isso. Valeu!

    terça-feira, 23 de dezembro de 2014 17:48
  • Syd,

    Se você tiver mais de uma instância do SQL Server instalado no mesmo servidor, você terá que especificar qual a porta ou nome da instância que esta querendo conectar...



    Tulio Rosa | http://tuliorosa.com.br | Se resolveu seu problema, marque como resposta ou vote

    • Marcado como Resposta Syd Franco quarta-feira, 21 de janeiro de 2015 13:50
    segunda-feira, 29 de dezembro de 2014 11:30
  • Foi exatamente isso que estava acontecendo. 

    Valeu Tulio.

    quarta-feira, 21 de janeiro de 2015 13:50