none
Windows Server 2008 + firewall + SQL Server 2008 RRS feed

Respostas

  • Alexandre,


    Já tive um problema parecido com esse... A resolução é simples... Além dessas configurações normais de acesso remoto, você precisa fazer uma configuração no firewall  para aceitar exceptions.


    Na guia Exceptions, adicionar esses dois serviços: sqlbrowser e sqlservr. Para isso, clique em Add Program, Browse:

    C:\Program Files\Microsoft SQL Server\90\Shared\sqlbrowser.exe

    C:\Program Files\Microsoft SQL Server\MSSQL10.NOVO2008\MSSQL\Binn\sqlservr.exe

     

    Obs : Dependendo da Instância default ou nomeada, o diretório das pastas pode mudar. Então, basta alterá-las de 90 para 100 por exemplo para o serviço browser e MSSQL10.NOVO2008 para MSSQL para por exemplo MSSQL10.OUTRO para o serviço sqlserver .



    Att,
    De Lima - MCTS SQL Server
    segunda-feira, 6 de abril de 2009 14:07
  • Estava com um problema semelhante, porém no Windows 7, e resolvi com este documento que encontrei na busca:

     http://www.linglom.com/2009/03/28/enable-remote-connection-on-sql-server-2008-express/


    MCP - Microsoft Certified Professional
    quinta-feira, 30 de setembro de 2010 19:58

Todas as Respostas

  • Caro,

     A instância do SQL Server instalada é a default ou nomeada? Se for nomeada, verifique qual porta dinâmica foi "alocada" para o SQL Server, e libere ela tb no firewall.

    Abraços
    Gilberto Neto
    Gilberto Neto
    segunda-feira, 6 de abril de 2009 12:54
  • Alexandre,


    Como foi o processo de instalação desta instância SQL Server?

    Você liberou na parte de segurança o acesso remoto para esta instância através do protocolo TCP/IP?
    Pedro Antonio Galvão Junior - MVP - Windows Server System - SQL Server/Coordenador de Projetos/DBA
    segunda-feira, 6 de abril de 2009 13:01
    Moderador
  • Junior,

    Aparentemente sim, ja que ele informa que quando o firewall do WIndows é desabilitado totalmente, ele tem acesso... :)

    Abraços
    Gilberto Neto
    Gilberto Neto
    segunda-feira, 6 de abril de 2009 13:10
  • Quais features?  Se não me engano você está com o SSMS do Express não é isso?

    Abraços
    Gilberto Neto
    Gilberto Neto
    segunda-feira, 6 de abril de 2009 13:15
  • Alexandre,


    O problema está nas propriedades dos serviços referentes ao SQL Server!!!!

    Com qual conta de usuário você esta conectado ao seu Windows!!!
    Pedro Antonio Galvão Junior - MVP - Windows Server System - SQL Server/Coordenador de Projetos/DBA
    segunda-feira, 6 de abril de 2009 13:29
    Moderador
  • A pergunta do Junior é pertinente.  Verifique se a conta que você está logado no Vista teria permissões de efetuar essas operações.

    Abraços
    Gilberto Neto
    Gilberto Neto
    segunda-feira, 6 de abril de 2009 13:37
  • Só deixando mais claro, verifique se a conta logado no vista tem permissões no servidor SQL Server.  E, caso não esteja, tente abrir o SSMS do Vista, usando o RUN AS Administrator...

    Abraços
    Gilberto Neto


    Gilberto Neto
    segunda-feira, 6 de abril de 2009 13:39
  • Alexandre,


    Já tive um problema parecido com esse... A resolução é simples... Além dessas configurações normais de acesso remoto, você precisa fazer uma configuração no firewall  para aceitar exceptions.


    Na guia Exceptions, adicionar esses dois serviços: sqlbrowser e sqlservr. Para isso, clique em Add Program, Browse:

    C:\Program Files\Microsoft SQL Server\90\Shared\sqlbrowser.exe

    C:\Program Files\Microsoft SQL Server\MSSQL10.NOVO2008\MSSQL\Binn\sqlservr.exe

     

    Obs : Dependendo da Instância default ou nomeada, o diretório das pastas pode mudar. Então, basta alterá-las de 90 para 100 por exemplo para o serviço browser e MSSQL10.NOVO2008 para MSSQL para por exemplo MSSQL10.OUTRO para o serviço sqlserver .



    Att,
    De Lima - MCTS SQL Server
    segunda-feira, 6 de abril de 2009 14:07
  • Caro, Acredito que o problema esteja em liberar as portas utilizadas pelo Protocolo RPC. Verifica no google quais são as portas utilizadas pelo windows server para esse protocolo. Tenta liberar a 445, 389, 135. Não tenho certeza se são essas. Abraços Gilberto Neto
    Gilberto Neto
    segunda-feira, 6 de abril de 2009 14:57
  • Pessoal,

    Tive um problema muito similar a esse aqui. Consegui resolver desbloqueando no Firewall do 2008 as portas:
    - TCP:1433;
    -UDP:1434.
    Resolveu, consigo acessar o SQL mesmo com o firewall habilitado.

    Abraços.

    Iles Vilela
    sexta-feira, 24 de abril de 2009 18:32
  • o sql browser esta ativo ?, quando as portas vc. pode testar com telnet tambem. vc. esta em dominio se sim altere o usuario do vista para um usuario de dominio com direitos para suber e parar servicos.

    Abs
    mcolla@bol.com.br
    terça-feira, 28 de abril de 2009 10:30
  • Valeu mesmo, Iles Vilela!!

     

    Depois de muitas horas perdidas procurando Internet à fora, sua dica foi fundamental para que eu resolvesse o problema!

     

    Att,




    ASO
    quarta-feira, 28 de julho de 2010 21:49
  • Estava com um problema semelhante, porém no Windows 7, e resolvi com este documento que encontrei na busca:

     http://www.linglom.com/2009/03/28/enable-remote-connection-on-sql-server-2008-express/


    MCP - Microsoft Certified Professional
    quinta-feira, 30 de setembro de 2010 19:58