none
TWAIN e Server 2008 RRS feed

  • Pergunta

  • Pessoal, boa tarde..

    tenho um projeto em .Net que faz uso da DLL TWAIN_32 e está ocorrendo um erro ao abrir o sistema no Windows Server 2008. Eu já adicionei o recurso Desktop Experience, e também já instalei o driver twainds.win32.installer.2.0.9.

    Porém continua ocorrendo um erro genérico, apenas sei que ocorre nessa rotina:

    var result = DSMident(_appID, IntPtr.Zero, TwDG.Control, TwDAT.Identity, TwMSG.GetDefault, _srcDS);
    
            [DllImport("twain_32.dll", EntryPoint = "#1")]
            private static extern TwRC DSMident([In, Out] TwIdentity origin, IntPtr zeroptr, TwDG dg, TwDAT dat, TwMSG msg, [In, Out] TwIdentity idds);

    o mais esquisito, que fiz um teste da instalação numa outra máquina com o mesmo SO.. e não deu problema...

    estou sem opções para solução..

    segunda-feira, 25 de setembro de 2017 17:24

Respostas

  • Boa tarde kngipa

    Verifique se não é gerado algum log de erro no Event Viewer.

    Atenciosamente,


    Guilherme Macedo S

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    TechNet Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    sexta-feira, 29 de setembro de 2017 19:12

Todas as Respostas

  • Olá Kngipa,

    Não sou muito da área de DEV, mas como funcionou em outro 2008 Server, veja se não está faltando algum update, service pack do Windows Server ou pacth de instalação da aplicação.

    Espero que ajude.


    Vinicius Mozart || MVP - Cloud and Datacenter Management || vinicius.mozart@terra.com.br || http://www.wenz.com.br || Skype:vinicius.mozart || www.wenzcursos.com.br

    terça-feira, 26 de setembro de 2017 01:53
    Moderador
  • olá, obrigada!

    em outra oportunidade já havia feito esse procedimento de atualizar o windows e não resolveu também.. quanto aos patch da aplicação, ela mesma já instala tudo que é necessário para seu funcionamento.. 

    :(

    terça-feira, 26 de setembro de 2017 11:36
  • Boa tarde kngipa

    Verifique se não é gerado algum log de erro no Event Viewer.

    Atenciosamente,


    Guilherme Macedo S

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    TechNet Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    sexta-feira, 29 de setembro de 2017 19:12