locked
passa o dia, exchange não inicia RRS feed

  • Pergunta

  • Bom dia Amigos,

         Estou novato neste forum e espero trocar ideias interessantes. Estou com um problema sério em um exchange aqui...

         S.O.: Windows 2000 server sp4

         Exchange: Exchange 2003 sp2

     

         Tivemos alguns problemas para uma migração porém no final tudo certinho, acontece que está acontecendo algo estranho. O server fica ligado 24h porém quando chega por volta das 22h o mesmo começa a apresentar uma série de erros conforme informado abaixo

          Porém quando reinicio o servidor o mesmo volta a funcionar normalmente, já tentei reiniciar somente o serviço de information store mas apresenta um erro informando que não consegue levantar o serviço por não ser um serviço microsoft (error 0)

     

    Tipo de evento: Erro
    Fonte de evento: MSExchangeSA
    Categoria do evento: (2)
    Id. do evento: 9097
    Data:  11/6/2007
    Hora:  21:41:04
    Usuário:  N/A
    Computador: <<servidor>>
    Descrição:
    A descrição para Event ID ( 9097 )  na fonte ( MSExchangeSA ) não pode ser encontrado. O computador local pode não ter as informações de registro ou arquivos DLL de mensagem necessários para exibir mensagens de um computador remoto. Talvez você possa usar o sinalizador /AUXSOURCE= para recuperar esta descrição; consulte a 'Ajuda e suporte' para obter detalhes. As informações seguintes são parte do evento: 0x800706ba.


    Tipo de evento: Erro
    Fonte de evento: Userenv
    Categoria do evento: Nenhuma
    Id. do evento: 1000
    Data:  11/6/2007
    Hora:  23:13:39
    Usuário:  AUTORIDADE NT\SYSTEM
    Computador: <<servidor>>
    Descrição:
    Windows cannot determine the user or computer name. Return value (1722).

    Para obter mais informações, visite o Centro de ajuda e suporte em http://go.microsoft.com/fwlink/events.asp.

     

    Tipo de evento: Informações
    Fonte de evento: MSExchangeSA
    Categoria do evento: (2)
    Id. do evento: 9095
    Data:  12/6/2007
    Hora:  07:51:19
    Usuário:  N/A
    Computador: <<servidor>>
    Descrição:
    A descrição para Event ID ( 9095 )  na fonte ( MSExchangeSA ) não pode ser encontrado. O computador local pode não ter as informações de registro ou arquivos DLL de mensagem necessários para exibir mensagens de um computador remoto. Talvez você possa usar o sinalizador /AUXSOURCE= para recuperar esta descrição; consulte a 'Ajuda e suporte' para obter detalhes. As informações seguintes são parte do evento: O arquivo de log de eventos está corrompido..

     

    terça-feira, 12 de junho de 2007 12:50

Respostas

  • Oi Anderson,

       Obrigado pelo interesse...

        Tive que fazer uma operação ninja mesmo, fiz um backup offline do exchange e formatei a maquina, coloquei ela novamente no dominio e blza, testei replicação, etc.

        Logo depois cruzei o dedo e parti para o adsedit, limpando tudo que encontrava de exchange......após isso, ainda com o coração não mão reiniciei a maquina e tudo ok.

        Rodei o foresprep e domainprep normalmente e instalei novamente o Ex2k3, funcionando (até o momento) normalmente.

     

    Abraços & Sucesso.

    Leonardo.

    terça-feira, 19 de junho de 2007 14:36

Todas as Respostas

  • Ola  Leonardo,

     

    Este tipo de erro pode ser de várias fontes, a melhor coisa é analisr o problema, ver o que foi feito no servidor (historico das alteracoes), derrepente uma reinstalaçao do produto possa vir a calhar. Pq todas mensagens que tu enviaste tá me parecendo que nem a máquina que é o exchange server entende os logs gerados pela ferramenta, isto é não é normal da máquina que tem o serviço. Pode estar faltando dll registradas e tudo mais.. mas como te disse só com um aprofunda análise para validar a real situação, podemos te passar links mas será no teste e a acerte.

     

     

    terça-feira, 12 de junho de 2007 12:56
  • Opa Anderson,

         Boa Noite.

                Eu ativei alguns logs q julguei importante lá no exchange, aumentei o espaço pra gravar os logs e vou ver o que acontece. Tem algum log em especial no exchange que você acha importante ativar ?

               

     

       Abraços & Sucesso.

       Leonardo.

    quinta-feira, 14 de junho de 2007 03:44
  •  

    Leonardo...

     

    O que ocorre de especial nesse horário?

     

    Alguma tarefa agendada?

     

    Backup ?  Replicação?

     

    Algum software terceiro ?

     

    De repente nem é o exchange que está dando erro, o que acontece é que ele é meio sensível, se o servidor não estiver redondo ele começa a dar uma bambeadas, começar a mancar...

     

    Dá uma olhada nisso....

     

     

     

     

     

    o.0 Post' Re'ze

    quinta-feira, 14 de junho de 2007 21:22
    Moderador
  • Ola Filipe,

     

    mancada, bambeadas, sensível? Replicação do que?

     

    Cara depende muito da arquitetura, não seja generalista, dizendo que isto é problema de qq exchange que não é por ai.

    quinta-feira, 14 de junho de 2007 21:30
  • Ola Leonardo,

     

    Qual log que habilitaste o Diagnostics Logging? ele vai aparecer no teu eventviewer em application tudo que foi definido por ti. Apos a tua analise, posta os logs relacionados ao erro com eventid aqui que a galera te ajuda.

     

    quinta-feira, 14 de junho de 2007 21:37
  •  

    Anderson...

     

    Realmente, dependendo da estrutura, não dá problema, mas dependedo da estrutura, nada dá problema.

     

    Não me entenda mal, eu sou Microsoftiano nato, gosto bastante do exchange....

     

    Mas é fato, se vc tem problemas com o sistema, o exchange não funciona corretamente, ele se integra bastante no sistema, principalmente no 2003 né, que permite maior flexibilidade...

     

    E ali em cima quando eu cite a replicação estava falando o AD, e DFS...

     

    Eu tenho agendado por exemplo a replicação do meu AD todo dia às 12:30 e 0:30 pelo volume ele consome um bom tempo, processamento e tráfego na rede... nesse horário eu não programa mais nada..

     

    Dessa replicação que eu estava falando...

    tendeu....

     

     

     

    o.0

     

     

     

     

     

     

    o.0 Post'e Re'ze

    sexta-feira, 15 de junho de 2007 20:47
    Moderador
  • Ola Filipe,

     

    Mais uma vez eu volto ao ponto do design do produto, Exchange e File Sever e DFS trabalhando junto, nao.. isto não é boa prática MS.. logo estamos falando de exceções, pode ser o problema dele mas nao acredito que seja este o caso.

     

    Em relação a uma replicaçao neste horário que vc comentou é claro qu ea performance vai ser afetada mas nao para um servidor.

     

     

    sexta-feira, 15 de junho de 2007 22:08
  •  

    ??

     

    Como assim ?

     

    Não disse que seja este o problema, disse pra ele verificar, se há algum agendamento nesse horário, pq se ele para só nessa hora algo está influenciando nisso...

     

    Se não fosse algo que roda sempre nessa hora, ele teria problemas em horários exporádicos...

     

    o.0

     

    E também não entendi essa frase:  " Em relação a uma replicaçao neste horário que vc comentou é claro qu ea performance vai ser afetada mas nao para um servidor."

     

    A performance é afetada, por isso que se agenda prar um horário em que a rede está com pouco ou nenhuma utilização.

     

    "A performance é afetada mas não para um servidor"   ??  Se eu me referi à replicação do AD e DFS que ficam no servidor.... A performance de que seria afetada senão a do servidor ??? o.0

     

     

    o.0

    segunda-feira, 18 de junho de 2007 16:00
    Moderador
  • Olá Leonardo,

     

    conforme já dito anteriormente pode estes evento pode ser proveniente de diversas fontes, mas dê uma olhada no seguinte:

     

    Geralmente o evento ocorre qdo o Exchange perde comunicação com o Global Catalog.

     

    Sendo assim, vc sabe me dizer se neste site q o Exchange está existe um GC pelo menos? Caso exista mais de 1 faça o seguinte.

     

    Abrao o ESM

    propriedades do server exchange

    TAB directory Access

    force o um outro GC manualmente para ver se o sintoma será o mesmo...

     

    Além disso continue procurando eventos no event viewer em application, pois algo deve aparecer por lá q nos ajudará.

     

    Até,

    terça-feira, 19 de junho de 2007 02:33
  • Ola Leonardo,

     

    Bom vamos voltar ao teu post, algum sucesso dos logs?

     

     

    terça-feira, 19 de junho de 2007 03:19
  • Ola Filipe,

     

    Podemos conversar isto via e-mail sem problema algum, ou se quiseres abre um tópico no forum de AD. Mas para este caso nao foi disto em nenhum lugar que tem DFS ou ainda que este servidor é realmente é um DC. É a mesma coisa que eu falar, cara se tu tiver CRM faz isso e aquilo, entende?

     

    Em relação a frase o "para" o correto seria "pára", nao vou me desculpar pelo portugues que este não está sendo o forte dos posts Smile

     

     

     

     Filipe - RJ - SoftCorp wrote:

     

    ??

     

    Como assim ?

     

    Não disse que seja este o problema, disse pra ele verificar, se há algum agendamento nesse horário, pq se ele para só nessa hora algo está influenciando nisso...

     

    Se não fosse algo que roda sempre nessa hora, ele teria problemas em horários exporádicos...

     

    o.0

     

    E também não entendi essa frase:  " Em relação a uma replicaçao neste horário que vc comentou é claro qu ea performance vai ser afetada mas nao para um servidor."

     

    A performance é afetada, por isso que se agenda prar um horário em que a rede está com pouco ou nenhuma utilização.

     

    "A performance é afetada mas não para um servidor"   ??  Se eu me referi à replicação do AD e DFS que ficam no servidor.... A performance de que seria afetada senão a do servidor ??? o.0

     

     

    o.0

    terça-feira, 19 de junho de 2007 10:18
  • Oi Anderson,

       Obrigado pelo interesse...

        Tive que fazer uma operação ninja mesmo, fiz um backup offline do exchange e formatei a maquina, coloquei ela novamente no dominio e blza, testei replicação, etc.

        Logo depois cruzei o dedo e parti para o adsedit, limpando tudo que encontrava de exchange......após isso, ainda com o coração não mão reiniciei a maquina e tudo ok.

        Rodei o foresprep e domainprep normalmente e instalei novamente o Ex2k3, funcionando (até o momento) normalmente.

     

    Abraços & Sucesso.

    Leonardo.

    terça-feira, 19 de junho de 2007 14:36