locked
Problema com conectores. RRS feed

  • Pergunta

  • Olá amigos,

     

    estou com um problema com conectores...O cenário é o seguinte: Dois servidores, mesma organização, grupos de roteamento diferentes. Enviando mensagens entre mailboxes de um armazenamento do mesmo servidor tudo tranquilo, entre servidores que ocorre o problema. Tentei utilizar SMTP connector, Routing Group Connector mas o problema é o mesmo, a mensagem fica presa na fila. Validei todas as informações possíveis de acordo com os meus conhecimentos, informações do tutorial de resolução de fluxo de mensagens do Anderson, além de informações gerais encontradas na Internet exceto uma. Ao tentar conectar via telnet em qualquer um dos dois servidores ele faz a conexão, porém não consigo efetuar o teste, já que ao digitar o primeiro caractere ele sai do telnet. As mensagens ficam presas na fila Unreachable destination independente do conector que eu uso. Não há firewalls entre os servidores, estão em sites diferentes no AD. Não há erros no Event Viewer.

     

    Obrigado pela atenção.

    segunda-feira, 17 de março de 2008 16:18

Respostas

  • Ola Deivid,

     

    Se estao no mesmo adminsitrative group e routing group conector nao há necessidade de criar smtp connecter e nem smtp connector nem nada.

     

    Se tu nao escuta na porta 25 é pq algum serviço está bloqueando, entao nenhuma mensagem chegará, se tu nao conseguir um simples telnet nem adianta ir mais além.

     

    Nao estou local no servidor, mas procura ver quem é que tá escutando na porta 25 e qual endereço ip, tenta local e por ai vai..

     

     

    segunda-feira, 17 de março de 2008 18:44
  • Ola Deivid,

     

    Junto com a dica do Anderson, passa um netstat -an para ver quem está escutando na porta 25.

     

    Abs.

     

    segunda-feira, 17 de março de 2008 18:57

Todas as Respostas

  • Deivid Foggi,

     

    Tu está com problema no antivirus provavelmente. Valida esta configuracao.

     

     

     

     

    segunda-feira, 17 de março de 2008 17:26
  • Olá Anderson,

     

    não atingi a fase de implementação de anti-vírus ainda, os mesmos estão sem anti-vírus.

     

    segunda-feira, 17 de março de 2008 17:32
  •  

    Entao é firewall.

     

    segunda-feira, 17 de março de 2008 18:17
  • Olá,

     

    como disse no primeiro tópico, não ha firewall entre os servidores. do Windows está desativado.

     

    Obrigado.

     

    segunda-feira, 17 de março de 2008 18:25
  • Eu exclui os conectores SMTP e criei Routing Group Connectors. Quando selecione a fila em que as mensagens ficam, aparece a seguinte mensagem em Aditional queue information:

     

    The connection was dropped by the remote host.

     

    Não sei o que pode estar bloqueando a conexão no host remoto (o outro servidor), e isso aparece nos dois. Imaginei que seria alguma configuração em nível de grupo administrativo, mas não encontrei nada. Alguma sugestão?

     

    segunda-feira, 17 de março de 2008 18:36
  • Ola Deivid,

     

    Se estao no mesmo adminsitrative group e routing group conector nao há necessidade de criar smtp connecter e nem smtp connector nem nada.

     

    Se tu nao escuta na porta 25 é pq algum serviço está bloqueando, entao nenhuma mensagem chegará, se tu nao conseguir um simples telnet nem adianta ir mais além.

     

    Nao estou local no servidor, mas procura ver quem é que tá escutando na porta 25 e qual endereço ip, tenta local e por ai vai..

     

     

    segunda-feira, 17 de março de 2008 18:44
  • Estão no mesmo grupo administrativo, mas em grupos de roteamento diferentes. Fiz o teste de SMTP via telnet localmente em cada servidor, porém deu na mesma. pensei em reinstalar o serviço...

    segunda-feira, 17 de março de 2008 18:52
  • Ola Deivid,

     

    Junto com a dica do Anderson, passa um netstat -an para ver quem está escutando na porta 25.

     

    Abs.

     

    segunda-feira, 17 de março de 2008 18:57
  • Ola Deivid,

     

    Tu nao pode reinstalar o SMTP pq vai ter que reinstlar o Exchange as well.

     

    A sysinternals tem um software para ver quem está uando cada porta se nao quisers usar o netstat.

     

    Faz o seguinte para o serviço de SMTP, agora roda um netstat -an | find ":25" tu viu alguma porta aberta? Se tu ver é pq tem outro software utilizando.

     

    Quais outros serviços nao Microsoft tu tem rodando neste server, nenhum antipsam ou coisa do genero? O Smtp virtual server está escutando em algum ip especificio ou todos ips? Tem algum event sink desenvolvido e implementando neste servidor?

     

     

     

    segunda-feira, 17 de março de 2008 19:05
  • Opá, aconteceu uma coisa que achei estranha, em ambos os servidores executei o netstat -an e a reposta quanto à escuta na porta TCP 25 foi a seguinte:

     

    Protocolo: TCP

    Local address: 0.0.0.0:25

    Foreign address: 0.0.0.0

    State: Listening

     

    O que achei incorreto foi o local address, não deveria estar o endereço IP corretamente ao ínves do 0.0.0.0? Meu raciocínio está correto ou estou viajando?

    segunda-feira, 17 de março de 2008 19:08
  • se o smtp tá all ip address isto é normal, dá uma olhada no meu post acima e posta os resultados.

     

     

    segunda-feira, 17 de março de 2008 19:10
  • Em ambos os servidores o servidor virtual SMTP está configurado com um IP específico. Parei o serviço e a escuta também pára.

     

    segunda-feira, 17 de março de 2008 19:15
  • Parece que o problema é realmente estranho...Movi um dos servidores para o outro grupo de roteamento de forma a deixar os dois no mesmo grupo de roteamento. O status em ambos os servidores passou para Available. Porém as mensagens continuam permanecendo na fila Unreachable.

    segunda-feira, 17 de março de 2008 20:49
  • Cara de novo.. enquanto o telnet nao for bem sucedido nao vai importar onde os servidores estao.

     

    Este erro do telnet acontece em ambos? Tu nao tem isa firewall client instalado neles né? tu nao configurou nenhum smtp connector entre eles, correto?

     

     

    segunda-feira, 17 de março de 2008 21:43
  • Não uso ISA, agora estão no mesmo grupo de roteamento. O problema do Telnet ocorre em ambos. Na fila aparece a mensagem "The connection was dropped by the remote host.".

     

    Não existe nada além do Exchange instalado nestes servidores.

     

    Obrigado pela ajuda.

     

    terça-feira, 18 de março de 2008 03:48
  • bom já temos uma mensagem diferente, no início tu disse que já desconectava na hora.

     

    So por vida das duvidas, olha nas propriedades do smtp e verifica se tu nao criou uma regra de allow e deny conexao neste smtp server, pela mensagem de erro parece ser isto..

     

     

    terça-feira, 18 de março de 2008 05:29
  • Validei isso também...tô ficando maluco...

    terça-feira, 18 de março de 2008 05:36
  •  

    Abre um chamado na MS
    terça-feira, 18 de março de 2008 13:57
  • Pessoal, pura falta de atenção natural da pouca experiência com o Exchange Server. Pensando que os acontecimentos eram absurdos, já que validei todas as informações e nada parecia bater, decidi esquecer tudo o que tinha feito e validar todas as configurações de ambos os servidores, do zero. E percebi um erro absolutamente simples que passou despercebido por várias vezes. Nas propriedades do servidor SMTP virtual de um dos servidores, guia Access, botão Connection, a configuração estava no radio button Only the list below sendo que eu não especifiquei nenhum servidor abaixo. Bastou eu alterar para All except list below na revalidação para a fila andar.

     

    Obrigado pela atenção de ambos, e desculpe "amolar" com um erro tão primário. Mais uma vez obrigado pelas dicas.

    terça-feira, 18 de março de 2008 17:35
  • Ola Deivid,

     

    Isto foi te passado em 3 posts acima, verificar se no allow deny do smtp server tinha algo Sad

     

    Mas isto não é definido desta forma por padra, vc deve ter cliado e acabou esquecendo.

     

    Que bom que resolvemos, boa sorte e vamos para a proxima,

     

    So nao esquece de marcar os posts que foram validos para te ajudar na resolucao do problema.

     

    Abracao,

     

     

    terça-feira, 18 de março de 2008 17:54