none
"LogFolderPath is not on a fixed drive" - DAG Exchange 2013 RRS feed

  • Pergunta

  • Senhores, boa tarde.

    Tentando configurar a cópia de meus 3 servidores de DB do Exchange 2013 na recem criada DAG, recebo a mensagem:

    "LogFolderPath is not on a fixed drive"

    Buscando a internet descobri que isso se dava pelo fato da pasta de log estar em discos de letras diferentes nos meus 3 servers DB. Ex: Em dois estava em F: e em outro, em E:

    Criei uma letra U: nos tres servers DB e rodei o comando nos três:

    Move-Databasepath "Mailbox Database SRV-XYZ" -LogFolderpath "U:\pasta_criada"

    Concluiu com exito, o exchange passou a registrar os logs nestas pastas.

    Agora, ao tentar fazer o mesmo de antes recebo a seguinte mensagem:

    "Um banco de dados existente já está configurado com o mesmo local "U:\pasta_criada" para LogFolderPath"

    Ferrou o.O Este erro não encontro na internet nem nas KBs da Microsoft, para entende-lo.

    Algum ninja do Exchange pode interpretar isso e me indicar o que estou fazendo de errado?

    terça-feira, 22 de setembro de 2015 18:41

Respostas

Todas as Respostas

  • Boa tarde,

    No caso você está tentando criar as cópias para os outros servidores correto?

    Se for tenta usar esse comando no console do powershell:

    Add-MailboxDatabaseCopy -Identity "database" -MailboxServer "Servidor" -ActivationPreference 2

    Se der erro em seguida utilize esse:

    Update-MailboxDatabaseCopy -Identity "database"\"mailboxserver" -DeleteExistingFiles -Force

    Poste os erros que possam vir a dar.

    Lembre de retirar as aspas.

    att

    Fernando do Vale

    • Sugerido como Resposta Cristopher C I_ quarta-feira, 23 de setembro de 2015 19:00
    terça-feira, 22 de setembro de 2015 18:58
  • Atualização:

    Depois de alterar os paths dos 3 servidores mailbox para que todos estejam com as mesmas letras de unidade, estou com o seguinte status:

    Mailbox server 1 - Copiado para os outros 2 com sucesso!
    Mailbox server 2 - Copiado apenas para o server 1!
    Mailbox server 3 - Sem copia para nenhum dos outros 2.

    Quando tento continuar a copia no server 2, ou quando tento fazer a copia do server 3 recebo a mensagem de erro abaixo:
    "Um banco de dados existente já está configurado com o mesmo local "V:\MailLog" para LogFolderPath." (V:MailLog é o path que defini para os logs)

    quarta-feira, 23 de setembro de 2015 12:14
  • Execute o comando abaixo em um dos Exchanges e retorne aqui o resultado:

    Get-MailboxDatabase | FL Name,*path*

    • Sugerido como Resposta Cristopher C I_ quarta-feira, 23 de setembro de 2015 19:53
    quarta-feira, 23 de setembro de 2015 12:19
  • Olá Lacerda,

    Isso acontece porque você está tentando montar as Databases em Shared Folders do Windows. Provavelmente, mapeamentos que você criou no servidor, e está alocando as cópias Ativa e Passiva juntas.

    O recomendado é que você use discos fixos para isto, ou mesmo discos compartilhados através de uma storage, como iSCSI ou CSVs. Ou use Mount Points para tal. Veja abaixo a documentação:

    Exchange 2013 storage configuration options
    https://technet.microsoft.com/en-us/library/ee832792%28v=exchg.150%29.aspx

    Abaixo, uma thread do fórum en-us, onde vemos um problema semelhante, onde a sugestão é alterar o local de armazenamento das databases:

    Do DAG members have to have the same drive letters for mailbox database copy to work?
    https://social.technet.microsoft.com/Forums/exchange/en-US/4781c704-4cd1-4ed2-aad3-444681abde10/do-dag-members-have-to-have-the-same-drive-letters-for-mailbox-database-copy-to-work?forum=exchange2010

    Abços,


    sexta-feira, 25 de setembro de 2015 20:09