none
Exchange 2010 - receive connector porta 465 RRS feed

  • Pergunta

  • Srs,

    Preciso configurar em algumas contas principalmente de sistemas,  um SMTP para envio de mensagens, criei um conector no exchange para receber conexão de todos IP's na autenticação marquei Transport Layer TLS e basic authentication e em permissões anonymous e exchange users.

    ao configurar um client externo funciona utilizando autenticação TLS porta 587, porem no client interno nao funciona diz que tem erro de autenticação,  quero configurar a porta 465 tambem, fiz a mesma coisa porem utilizei somente autenticação Transport Layer TLS e anonymous  users e o client nao envia, configurei o smtp no outlook para usar mesma config. do servidor de entrada, coloquei porta 465 e tipo de conexão TLS, só que fica pedindo senha do smtp e nao conecta.

    alguem tem uma dica de como fazer isso rodar?


    Fabiano Pires

    terça-feira, 1 de novembro de 2016 15:52

Respostas

Todas as Respostas

  • Olá Fabiano,

    Primeira recomendação; criar um novo conector, e configurar para porta 25 mesmo. A maioria dos serviços usa a default SMTP, que é a porta 25, como envio. Depois que você validar que está funcionando, aí troca a porta para a de sua preferência, e já elimina a chance da aplicação/sistema não ter esta limitação.

    Para criar e configurar o conector de relay:

    New-ReceiveConnector -Name "Anonymous Relay" -Usage Custom -Bindings 0.0.0.0:25 -RemoteIpRanges 0.0.0.0-255.255.255.255

    Set-ReceiveConnector "Anonymous Relay" -PermissionGroups AnonymousUser

    Após a criação e configuração dos grupos de envio com Anonymous, basta definir as permissões de usabilidade do novo conector criado, usando este cmdlet:

    Get-ReceiveConnector "Anonymous Relay" | Add-ADPermission -User "NT AUTHORITY\ANONYMOUS LOGON" -ExtendedRights "Ms-Exch-SMTP-Accept-Any-Recipient"

    Acredito que isso já lhe ajudará a resolver o problema. Se atente a deixar o atributo RemoteIPRanges com todas as redes possíveis, e depois vá fechando o escopo de abrangência. É uma boa dica de troubleshooting tbém.

    Allowing application servers to relay off Exchange Server
    https://blogs.technet.microsoft.com/exchange/2006/12/28/allowing-application-servers-to-relay-off-exchange-server-2007/

    New-ReceiveConnector
    https://technet.microsoft.com/en-us/library/bb125139(v=exchg.141).aspx

    Adicional:

    Allow anonymous relay on new Exchange servers
    https://technet.microsoft.com/en-us/library/mt668454(v=exchg.160).aspx

    Abços,


    Bruno Lopez | Technical Trainer
    MCP Certification Profile | Linkedin | Twitter http://blogdolopez.com 

    Facebook Page




    terça-feira, 1 de novembro de 2016 16:38
  • Boa tarde Bruno, cara não esta reconhecendo o comando acima : -TransportRole

    acho que esse comando serve somente para o 2016

    New-ReceiveConnector -Name "Anonymous Relay" -TransportRole......


    Fabiano Pires


    • Editado Fabiano Pires terça-feira, 1 de novembro de 2016 17:05
    terça-feira, 1 de novembro de 2016 17:02
  • Já atualizei a resposta, corrigindo as diferenças de versão. ;)

    Bruno Lopez | Technical Trainer
    MCP Certification Profile | Linkedin | Twitter http://blogdolopez.com 

    Facebook Page

    terça-feira, 1 de novembro de 2016 17:38
  • Na ultima parte de permissoes não encontra o grupo

    User or group "NT AUTHORITY\ANONYMOUS LOGON" wasn't found. Please make sure you've typed it correctly.
        + CategoryInfo          : InvalidData: (:) [Add-ADPermission], ManagementObjectNotFoundException
        + FullyQualifiedErrorId : 3285C1D6,Microsoft.Exchange.Management.RecipientTasks.AddADPermission


    Fabiano Pires

    terça-feira, 1 de novembro de 2016 18:21
  • Bom dia Bruno,  tenho 2 regras para porta 587 como abaixo,  se eu desativar a regra 2 a 1 funciona perfeitamente tanto internamente quanto externamente, se eu habilitar a 2 a regra 1 internamente para de funcionar, porem preciso das duas, temos um ERP que envia e-mail, nele configuramos somente uma conta SMTP, porem no campo from o ERP coloca o nome do usuário logado, se eu desativo o envio anonimo teríamos que configurar smtp com usuário e senha para cada conta de usuário no ERP, não sei se deu para entender, será que tem algum conflito, pois na regra 2 deixei somente o IP do servidor que dispara os e-mails.

    --Regra1--

    Network:

    Use these local IP addresses to receive mail:  ip do exchange

    Recevei mail from remote servers that have these IP addresses: 0.0.0.0-255.255.255.255

    Authentication

    Transport layer security (TLS)

    Basic Authentication

    Permission Groups

    Exchange Useres

    --Regra2--



    Network:

    Use these local IP addresses to receive mail:  ip do exchange

    Recevei mail from remote servers that have these IP addresses: 192.168.0.2-255.255.255.0  - ip de um servidor



    Authentication

    Externally Secured


    Permission Groups

    Anonymous users

    Exchange Servers


    Fabiano Pires

    quinta-feira, 3 de novembro de 2016 13:05
  • Entendi sim, Fabiano. Já tive casos bem semelhantes, onde a configuração de um Sistema impactava a do outro. Neste cenário, só resta criar um terceiro conector, e usar uma porta totalmente diferente das já existentes, pois você não pode repetir portas que já estejam ativas.

    Recomendo que deixe como está atualmente, para o ambiente que está funcional, e crie um novo conector para atender sua nova aplicação. Use uma porta diferente e pouco usual, e valide se sua nova aplicação irá exigir uma porta específica como 25 ou 587, ou se aceita portas manuais.

    Abços,


    Bruno Lopez | Technical Trainer
    MCP Certification Profile | Linkedin | Twitter http://blogdolopez.com 

    Facebook Page

    • Marcado como Resposta Thales F Quintas sexta-feira, 4 de novembro de 2016 11:37
    quinta-feira, 3 de novembro de 2016 20:45
  • Bom dia Bruno, não tenho saída mesmo, vou fazer isso.

    Fabiano Pires

    sexta-feira, 4 de novembro de 2016 11:50
  • Fabiano,

    Ele pode dar essa mensagem de não encontrar o conector por conta da linguagem do Sistema Operacional ou do Active Directory. Se estiver em PT-BR, o grupo deve ficar "AUTORIDADE NT\LOGON ANÔNIMO".

    Abços,


    Bruno Lopez | Technical Trainer
    MCP Certification Profile | Linkedin | Twitter http://blogdolopez.com 

    Facebook Page


    sexta-feira, 4 de novembro de 2016 12:45