none
Problemas com Tarefas Agendadas RRS feed

  • Pergunta

  • Estou com um problema parecido,agendo para o servidor rodar um script em determinado horário para fazer o backup dos arquivos de log de determinada pasta,compacta-los,salva-los em outra pasta e apagar o conteúdo da pasta log,só que ele tenta rodar e aparece como se tivesse feito o backup cria uma pasta do dia com o tamanho de 1kb,quando o script é executado manualmente ele funciona normal,ou se eu estiver logado no momento e utilizar a tarefa agendada para executar no horário que eu estiver logado que é no caso no momento ele executa normal.

    Então cheguei a conclusão que o problema é que ele só executa a tarefa agendada se tiver logado momento da mesma.

    quarta-feira, 27 de fevereiro de 2013 18:43

Todas as Respostas

  • Jorge, não seria a opção marcada: Executar somente quando o usuário estiver conectado

    ?

    Se estiver assim, mude para opção de baixo:

    Executar estando o usuário conectado ou não

    Isso na aba GERAL.


    Gustavo Valle | http://grvalle.com
    LinkedInWordPressTwitter


    quarta-feira, 27 de fevereiro de 2013 18:59
    Moderador
  • Gustavo aqui só me mostra duas opções:

    Aba Tarefa

    Executar somente se conectado - Desabilitada

    Ativada (a tarefa agendada será executada na hora especificada) - Ativada

    E ele não me mostra a aba Geral e sim Tarefa/Agenda/Configurações/Segurança.

    O que eu mudei foi em Executar como: estava com o usuário administrador do domínio eu tirei e adicionei o usuário administrador local,vamos ver o que acontece amanhã na hora dos backups dos logs.

    O windows ainda tem um bug em permissões de tarefas agendadas,que quando você tenta fazer uma alteração na mesma ela dá que vc não ter permissão,ele só libera depois que eu rodo um script de premissão.


    Windows Server 2003

    quarta-feira, 27 de fevereiro de 2013 19:58
  • É que olhei aqui no meu Win 7 (aplicaria se fosse 2008).

    No 2003 não lembro, mas procura esta opção de execução.

    Se for o caso, crie uma nova para simular e veja se acha a opção.

    Não tenho um 2003 aqui para verificar pra ti...


    Gustavo Valle | http://grvalle.com
    LinkedInWordPressTwitter

    quarta-feira, 27 de fevereiro de 2013 20:02
    Moderador
  • Blz Gustavo vou verificar aqui,obrigado pela força,qualquer coisa volta a postar as novidades.
    quarta-feira, 27 de fevereiro de 2013 20:44