none
Windows 8 Pro em um domínio LINUX RRS feed

  • Pergunta

  • Olá a todos !

    Estive lendo em alguns fóruns, inclusive aqui no TechNet, sobre um erro que há quanto tento ingressar uma estação com Windows 8 PRO em um domínio LINUX.

    Já fiz alterações de registro conforme sugerido, mas não surtiu efeito. As alterações foram as seguintes:

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanManWorkstation\Parameters]
    "DNSNameResolutionRequired"=dword:00000000
    "DomainCompatibilityMode"=dword:00000001

    O erro é sempre o mesmo:

    Observação: estas informações se destinam a administradores de rede. Caso você não seja um, contate o administrador de rede e notifique-o de que recebeu estas informações, que estão registradas no arquivo C:\Windows\debug\dcdiag.txt.

    Erro ao consultar o DNS para obtenção de registro do recurso de serviço local (SRV) usado para localizar um Controlador de Domínio do Active Directory para o domínio "xxx":

    Erro: "O nome DNS não existe."
    (código de erro 0x0000232B RCODE_NAME_ERROR)

    A consulta foi feita para o registro SRV para_ldap._tcp.dc._msdcs.xxx

    As causas mais comuns deste erro são:

    -Os registros SRV de DNS, necessários para localizar um Controlador de Domínio do Active Directory não estão registrados no DNS. Esses registros são automaticamente registrados em um servidor DNS quando um Controlador de Domínio do Active Directory é adicionado a um domínio. Eles são atualizados pelo Controlador de Domínio do Active Directory em intervalos predefinidos. O computador é configurado para usar servidores DNS com os seguintes endereços IP:

    xxx.xxx.xxx.xxx
    xxx.xxx.xxx.xxx

    -  Uma ou mais das zonas a seguir não incluem delegação à zona filho:

    xxx
    rj
    . (a zona raiz)

    Onde xxx é o meu domínio

    A quem puder ajudar, obrigado.

    quarta-feira, 26 de junho de 2013 14:38

Respostas

  • Estou com esse mesmo problema, mas com uma diferença:

    Apenas com essa alteração no registro o ingresso de WIN7 e WIN8 ocorre com suceso:

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\LanmanWorkstation\Parameters]
    "DomainCompatibilityMode"=dword:00000001
    "DNSNameResolutionRequired"=dword:00000000

    No entanto, quando removi um WIN8 do dominio o mesmo da esse erro ao tentar re-ingressar com outro nome.

    Tentei com os parâmetros que o Junior Ramos nos apresentou mas o erro persistiu.

    OBS: Aqui não tenho o WINBIND.

    Meu nsswitch.conf esta assim:

    passwd:         compat ldap
    group:          compat ldap
    shadow:         compat ldap

    hosts:          files dns
    networks:       files

    protocols:      db files
    services:       db files
    ethers:         db files
    rpc:            db files

    netgroup:       nis

    quinta-feira, 26 de setembro de 2013 18:19

Todas as Respostas

  • Boa tarde Amigo!

    Faltou mais dois passos a serem resolvidos.

    • HKLM\System\CCS\Services\Netlogon\Parameters
      DWORD RequireSignOrSeal = 1
      DWORD RequireStrongKey = 1

    Reveja esse procedimento acima e volte a postar.


    Júnior Ramos

    Consultor em TI.

    MCITP | MCTS | MCC |

    Fone: (47) 8417-3475

    E-mail: consultoriaemredes@live.com


    quarta-feira, 26 de junho de 2013 15:42
  • Com a dica que te falei acima, resolveu ai o teu problema?

    Júnior Ramos

    Consultor em TI.

    MCITP | MCTS | MCC |

    Fone: (47) 8417-3475

    E-mail: consultoriaemredes@live.com

    quarta-feira, 26 de junho de 2013 17:03
  • Olá Júnior Ramos,

    Fiz a alteração sugerida, mas o erro continua o mesmo.

    A versão do meu SMB é 3.4.9

    Aguardando retorno.

    Pela atenção, obrigado

    quarta-feira, 26 de junho de 2013 17:16
  • Olá.

    Tente alterar o NTLM do Windows 8

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa]

    "LmCompatibilityLevel"=dword:00000001


    Qual é a versão do seu Winbind ?


    Júnior Ramos

    Consultor em TI.

    MCITP | MCTS | MCC |

    Fone: (47) 8417-3475

    E-mail: consultoriaemredes@live.com

    quarta-feira, 26 de junho de 2013 17:50
  • Júnior

    Não localizei esta chave no REGISTRO. Posso criar?

    Att

    quarta-feira, 26 de junho de 2013 18:25
  • Isso, crie e reinicie seu computador.
    Quando voltar, tente ingressar ao domínio.

    abs.


    Júnior Ramos

    Consultor em TI.

    MCITP | MCTS | MCC |

    Fone: (47) 8417-3475

    E-mail: consultoriaemredes@live.com


    • Editado Júnior Ramos quarta-feira, 26 de junho de 2013 18:33 voltar
    quarta-feira, 26 de junho de 2013 18:33
  • Júnior

    Registro criado, mas ainda não resolveu.

    Att

    quarta-feira, 26 de junho de 2013 18:41
  • Amigo.

    Qual é a versão do seu Winbind?


    Júnior Ramos

    Consultor em TI.

    MCITP | MCTS | MCC |

    Fone: (47) 8417-3475

    E-mail: consultoriaemredes@live.com

    quarta-feira, 26 de junho de 2013 18:42
  • Junior,

    Estou tentando ver a versão do winbind com o comando #wbinfo, o mesmo informa que ele não está instalado. Estou temeroso em instalar, já que tenho um parque de quase 250 máquinas. O LINUX sugere a instalação do pacote. A pergunta agora é:

    Posso instalar tranquilo?

    Att

    quarta-feira, 26 de junho de 2013 18:58
  • Cara o Winbind é necessário ter para que ele realize  a integração no controlador de domínio.
    Outro ponto, você deve ter o squid para integrar as regras de proxy certo ?

    Para ver se o Winbind esta instalado, rode o comando.

    • winbind -v

    E depois rode o comando para ver a verão do NTLM

    • wbinfo --ntlmv2

    Se não tiver instalado o Winbind, instale o mesmo e configure o arquivo /etc/nsswitch.conf
    Igual abaixo.

    passwd: compat winbind
    group: compat winbind
    shadow: compat winbind

    hosts: files dns
    networks: files

    protocols: db files
    services: db files
    ethers: db files
    rpc: db files

    netgroup: nis

    Reinicie o serviço do Samba e Winbind e faça o teste novamente.


    Júnior Ramos

    Consultor em TI.

    MCITP | MCTS | MCC |

    Fone: (47) 8417-3475

    E-mail: consultoriaemredes@live.com


    • Editado Júnior Ramos quarta-feira, 26 de junho de 2013 19:06 huuuihuhui
    quarta-feira, 26 de junho de 2013 19:05
  • Júnior,

    Desculpe a demora na resposta, tivemos um problema aqui na empresa. Não conseguimos achar a versão pelo comando sugerido.

    Segue o script do nosso winbind:

    # Example configuration of GNU Name Service Switch functionality.
    # If you have the 'glibc-doc-reference' and 'info' packages installed, try:
    # 'info libc "Name Service Switch"' for information about this file.

    # pre_auth-client-config # passwd:  compat
    passwd: compat ldap
    # pre_auth-client-config # group:  compat
    group: compat ldap
    # pre_auth-client-config # shadow:  compat
    shadow: compat ldap

    hosts:  files dns
    networks: files

    protocols: db files
    services: db files
    ethers:  db files
    rpc:  db files

    # pre_auth-client-config # netgroup:  nis
    netgroup: nis

    quinta-feira, 27 de junho de 2013 13:55
  • Estou com esse mesmo problema, mas com uma diferença:

    Apenas com essa alteração no registro o ingresso de WIN7 e WIN8 ocorre com suceso:

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\LanmanWorkstation\Parameters]
    "DomainCompatibilityMode"=dword:00000001
    "DNSNameResolutionRequired"=dword:00000000

    No entanto, quando removi um WIN8 do dominio o mesmo da esse erro ao tentar re-ingressar com outro nome.

    Tentei com os parâmetros que o Junior Ramos nos apresentou mas o erro persistiu.

    OBS: Aqui não tenho o WINBIND.

    Meu nsswitch.conf esta assim:

    passwd:         compat ldap
    group:          compat ldap
    shadow:         compat ldap

    hosts:          files dns
    networks:       files

    protocols:      db files
    services:       db files
    ethers:         db files
    rpc:            db files

    netgroup:       nis

    quinta-feira, 26 de setembro de 2013 18:19