locked
Problema Para Desfragmentar Base Exchange 2003 RRS feed

  • Pergunta

  • Pessoal, Boa Tarde!

    Estou com problema para desfragmentar a base do Exchange 2003.

    Estou executando o comando eseutil /d ... ao chegar em torno de 10% da base desfragmentada aparece a seguinte mensagem de erro:

    Retorno de chamada DLL não encontrado
    Não é possível localizar o retorno de chamada biblioteca jcb.dll (ou uma de suas dependências). Copiar no arquivo e clique em OK para tentar novamente ou pressione Cancelar para anular.
    Ao aperto o "OK" a mensagem continua aparecendo, tive que cancelar a desfragmentação.
    Este arquivo jcb.dll encontra-se na pasta bin.
    O que fazer agora ?
    Obrigado
    Rafael 
    terça-feira, 8 de março de 2011 21:03

Respostas

  • Fala David,

    Beleza...vou tentar fazer algo do tipo...

    Vlw
    Rafael

    • Marcado como Resposta Rafael Luz quarta-feira, 16 de março de 2011 15:35
    quarta-feira, 16 de março de 2011 15:32

Todas as Respostas

  • Rafael,

    Tente realizar o procedimento conforme estád escrito an url http://support.microsoft.com/kb/273087/pt-br

    Abs e boa sorte,


    David Chaves
    sexta-feira, 11 de março de 2011 12:40
    Moderador
  • David,
    Boa Tarde!

    Este link escreve junstamente para colocar o arquivo JCB.DLL na pasta Bin, o qual já encontra-se...Eu já tinha lido este KB, mas infelizmente não ajudou.

    Vlw..
    Rafael

     

    sexta-feira, 11 de março de 2011 17:34
  • Rafael,

    Pesquisei bastante sobre o seu problema e está difícil de encontrar algo, caso você tenha urgência em desfragmentar a base, nessa url http://www.networksteve.com/exchange/topic.php/Callback_Library_JCB.DLL_when_using_Eseutil/?TopicId=7231&Posts=0 informa como usar outro computador para realizar o defrag da base.  Como etapa para resolução do seu problema sugiro você fazer um backup do arquivo jcb.dll, copiar ele do cd do exchange e substituir na sua unidade e caso continue o problema, sugiro a atualização do exchange para o SP 2.

    Abs e boa sorte,


    David Chaves
    domingo, 13 de março de 2011 04:26
    Moderador
  • David,
    Boa Tarde!!

    Realmente este problema está dificíl de resolver...rs.

    Hoje a tarde eu copiei o arquivo jcb.dll do CD do Exchange e posteriormente tentei fazer o defrag da base e o erro foi o mesmo...infelizmente!!! não consegui...

    O que estou achando estranho é que consegui fazer o defrag da base "public folder" normalmente...
    Sobre fazer o defrag de outro computador não entendi.

    OBS: Tenho um Exchange 2003 SBS SP2.

    Vlw
    Rafael

    domingo, 13 de março de 2011 21:17
  • Fala Rafael,

    Esqueci de te falar, dê uma olhada para ver se você tem espaço suficiente no seu disco onde está instalado o Exchange ( é necessário pelo menos o dobro do espaço da sua base para realizar o defrag), teste também criar uma outra database limpa e testa o defrag (Faça isso para ve se não é nenhum problema com a base atual, se funcionar com essa nova que você criou você pode mover as mailbox para ela e esquecer a necessidade da desfragmentação)... Sobre o update que pedi, se certifique que o seu exchange tenha o update do service pack 2, pois pode ser que seu SBS tenha o service pack 2, mas o exchange não (Lembre-se que o Service pack do Exchange não vem com o Windows update)....

    OBS: Sobre a situação do defrag de outro computador, essa opção lhe permite rodar o eseutil de outro equipamento.

    Abs e boa sorte,


    David Chaves
    segunda-feira, 14 de março de 2011 02:17
    Moderador
  • Fala David,

    O Servidor tem 450 GB de HD e com a grande maioria de espaço livre.
    Boa idéia.. vou criar um base nova e testar o defrag., se funcionar pode ser que a base atual esteja corrompida ?

    A versão do Exchange é: 6.5.7638.1

    Obrigado novamente.. assim que eu tiver notícias sobre o teste eu lhe informo.

    Vlw
    Rafael

    terça-feira, 15 de março de 2011 00:18
  • David,
    Bom Dia...

    Agora pela manhã fui tentar criar uma nova mailbox store, mas não foi possível deu erro. procurei na net o erro e descobri que somente a versão Enterprise permite criar novas mailbox store...
    O que posso fazer agora ?

    Vwl
    Rafael

    terça-feira, 15 de março de 2011 12:03
  • Rafael,

    Existem algumas formas de contornar o seu problema, porém todas devem ser realizada em última instânica como  fazer um backup do seu database, criar um novo e restaurar... exportar e importar as mailbox  com o exmerge em um database nova (Caso elas tenha até 2GB), instalar uma VM  com o exchange migrar as databases para lá e depois criar um nova no server local e voltar as mailbox.... e por ae vai, até levar a database para outro computador para desfragmentar e depois voltar com ela (http://support.microsoft.com/kb/244525/pt-br) ... Te aconselho agora atualizar todo seu Windows, atualizar Exchange, desabilitar o antivírus no momento do eseutil e depois realizar novos testes. Caso continuei o problema, sugiro que você abra um chamado com a Microsoft ou procure uma consultoria Microsoft.

    Abs, caso útil classifique.


    David Chaves
    quarta-feira, 16 de março de 2011 01:50
    Moderador
  • Fala David,

    Beleza...vou tentar fazer algo do tipo...

    Vlw
    Rafael

    • Marcado como Resposta Rafael Luz quarta-feira, 16 de março de 2011 15:35
    quarta-feira, 16 de março de 2011 15:32