none
Não consigo abrir página inicial do Sharepoint RRS feed

  • Pergunta

  • Caros Colegas

    Estou com um problema, instalei um sharepoint em um servidor ( windows 2003 SP1) para substituir um antigo servidor. Porém ao instalar apareceu a seguinte mensagem :

    Warning: Sharepoint no longer customizes Integrated Authentication security settings. This virtual server may be using Kerberos, which can require manual configuration. See http://support.microsoft.com/?ida=832769 for more information

    Please acces the sharepoint Central administration site at http://servidor:21201

    Operation completed successfully

    Entretando ao tentar abrir a página inicial do site http://servidor

    ele pede nome e senha de usuário. Já coloquei todos os usuários e senhas possíves do domínio e ele não aceita. Acessei o link acima, pois pelo que entendi ele estaria usando autenticação Kerberos. Executei o comando descrito no artigo:

    cscript adsutil.vbs set w3svc/##/root/NTAuthenticationProviders "NTLM"

    resetei o iis , mas mesmo assim ele não abriu. O que pode estar acontecendo ?

     

     

     

     

     

    quarta-feira, 16 de agosto de 2006 16:54

Respostas

  • Olá Renato

    Desculpe não ter respondido antes. Estive envolvido em alguns projetos e não tive mais tempo de ver esse problema.  Instalei o Framework 2.0 e o problema foi resolvido. Nem precisei modificar as propriedades e funcionou. Mesmo assim as modifiquei e coloquei para 2.0. Agora é só fazer o backup do outro site. Valeu mesmo.

    Um grande abraço.

    segunda-feira, 25 de setembro de 2006 19:23

Todas as Respostas

  • Caro Márcio,

    vá até o IIS e abra as propriedades do teu SharePoint, depois vá na guia Directory Security e clique em Edit no Authentication. Deve estar marcado apenas Integrated Windows Authentication.

    Em IP address deves ter granted para o teu grupo do computadores e para o local host 127.0.0.1.

    Faz o teste e vê se já resolve.

    quarta-feira, 16 de agosto de 2006 20:31
  • Olá Carlos , eu já havia feito isso, mas não surtiu efeito. Mesmo assim,Obrigado pela dica. Tem alguma outra ???
    quarta-feira, 16 de agosto de 2006 20:55
  • Ok Márcio,

    vamos para a coleta de informações, então:

    1) você possui um firewall instalado neste servidor?

    2) obtém o mesmo erro quando tenta acessar o SharePoint de uma estação cliente e do servidor?

    3) o que aparece nos logs de seu servidor a cada vez que a sua senha não é aceita?

    4) se alterar o tipo de autenticação do site para Basic, funciona?

    quarta-feira, 16 de agosto de 2006 21:04
  • Olá Pessoal,

    A questão principal aqui seja a autenticação Kerberos habilitada, e não firewall ou outros pontos a serem mitigados.

    Durante a criação de um site Sharepoint, a partir do SP2 ele solicita a informação referente ao modelo de autenticação (NTLM ou Kerkeros).

    NTLM é o modelo padrão para as principais estruturas atualmente, visto que Kerberos esta relacionado a algumas mudanças implementadas na arquitetura do Windows Server 2003 e solicita, portanto, alguns passos a mais de configuração.

    Na maioria das vezes eu utilizo NTLM (principalmente por que funciona, rs); sendo Kerberos uma decisão do cliente frente a sua arquitetura.

    Márcio, Você esta tendo estes problemas provavelmente por que selecionou (ou deixou selecionado)  Kerberos durante a criação do site.

    PONTO 1: Se você estiver iniciando seu site agora, recomendo que você o apague e crie novamente. :-)


    Para mudar o modelo atual (Kerberos) para NTLM, deve ser usado o artigo que você mencionou no começo (832769).

    Vamos aos comandos: (Pasta: C:\inetpub\adminscripts)

    Ao executar este comando SET (cscript adsutil.vbs set w3svc/##/root/NTAuthenticationProviders "NTLM"), você trocou as ## pelo Site ID do IIS correto? (mto importante)

    Depois de executar o SET, execute o GET (cscript adsutil.vbs get w3svc/##/root/NTAuthenticationProviders) via CMD (trocando o ## pelo Site ID novamente.

    Qual é o output?

    Desta forma podemos avaliar se o seu site esta novamente funcionando com base no modelo de autenticação NTLM.


    Poste o output do comando GET (depois de executar o SET)! :-)

     

    Obs.: Considere a indicação existente no PONTO 1!


    Se precisar de mais alguma coisa, reply!

    Abraços

    quarta-feira, 16 de agosto de 2006 21:36
  • Olá Hélio

    Desculpe a demora em responder, pois estava  viajando, fiquei afastado da empressa por algum tempo e não tive mais como ver novamente o problema com a resposta que deu-me. Vamos aos pontos:

    Já perdi a conta de quantas vezes instalei e desinstalei o shaponit. Em nenhuma das vezes ele mostra algum local para instalar com o  kerberos.

    Tentei instalar o Sharepoint sem o SP2 integrado e com, em nenhuma das duas instalações ele funcionou, dá o mesmo problema. A única diferença é que sem  SP2 ele dá aquele aviso do artigo e com o integrado não dá nenhuma mensagem.

    o Output do comando é :

    C:\Inetpub\AdminScripts>cscript adsutil.vbs get w3svc/1/root/NTAuthenticationPro
    viders
    Microsoft (R) Windows Script Host Version 5.6
    Copyright (C) Microsoft Corporation 1996-2001. All rights reserved.

    NTAuthenticationProviders       : (STRING) "NTLM"

    Quando eu cancelo a caixa de login ou digito o nome e usuário 3 vezes aparece a seguinte mensagem:

    Server Error in '/_layouts' Application.

    Runtime Error

    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed.

    Details: To enable the details of this specific error message to be viewable on the local server machine, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "RemoteOnly". To enable the details to be viewable on remote machines, please set "mode" to "Off".

    <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="RemoteOnly"/>
        </system.web>
    </configuration>

    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

    <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="On" defaultRedirect="mycustompage.htm"/>
        </system.web>
    </configuration>

    O que ainda pode estar acontecendo ???

    segunda-feira, 21 de agosto de 2006 12:20
  • Fala Marcio...

    Para resolver seu problema basta você atualizar o seu Asp.Net de V1.0 para V2.0. Depois você tera que ir no IIS, selecionar o site SharePoint Central Administration ir nas propriedades dele e alterar a versão na aba ASP.NET de 1.1.4322 para 2.0.50727.

    Depois é só testar.

    Abraços..
    segunda-feira, 11 de setembro de 2006 23:50
  • Olá Renato

    Desculpe não ter respondido antes. Estive envolvido em alguns projetos e não tive mais tempo de ver esse problema.  Instalei o Framework 2.0 e o problema foi resolvido. Nem precisei modificar as propriedades e funcionou. Mesmo assim as modifiquei e coloquei para 2.0. Agora é só fazer o backup do outro site. Valeu mesmo.

    Um grande abraço.

    segunda-feira, 25 de setembro de 2006 19:23