none
Problema em fórmula no excel RRS feed

  • Pergunta

  • Bom dia,

     

    Possuo uma planilha com uma coluna com os seguintes valores ( listei apenas os primeiros):

    SE-101-AL CQS 01-CD 191
    SE-101-AL CQS 01-CD 191
    SE-101-AL CQS 01-CD 191
    SE-101-AL CQS 01-CD 191
    SE-101-AL CQS 01-CD 191
    SE-101-AL CQS 01-CN 193_195
    SE-101-AL CQS 01-CN 193_195
    SE-101-AL CQS 01-CN 193_195
    SE-101-AL CQS 01-CN 193_195
    SE-101-AL CQS 01-CN 193_195
    SE-101-AL CQS 01-RL 192
    SE-101-AL CQS 01-RL 192
    SE-101-AL CQS 01-RL 192
    SE-101-AL CQS 01-RL 192
    SE-101-AL CQS 01-RL 192
    SE-101-AL CQS 02-CD 181
    SE-101-AL CQS 02-CD 181

    Criei uma nova coluna com a seguinte fórmula:

    Na primeira coluna (B1): =A1

    Na segunda coluna(B2): =SE(A2=A1;"";A2)

    Na terceira coluna(B3): =SE(A3=A2;"";A3)

    e assim por diante (arrastei a segunda coluna até o final da planilha). Não deseja utilizar a remossão de duplicidade, apenas mostrar branco quando for, mas sempre retorna verdadeiro o teste lógico.  Apenas quando clico em cada linha da fórmula e dou enter é que o resultado fica correto.

    Estou utilizando o excel 2007 ( 12.0.6654.5003 ) SP3

    Alguma sugestão ?

     

    Att.

     

    Adilson
    • Editado AdilsonD quinta-feira, 12 de janeiro de 2012 14:31
    quinta-feira, 12 de janeiro de 2012 14:30

Respostas

  • Olá Fernando,

     

    Obrigado por seu interesse, mas, respondendo a sua questão, a opção está automática ( padrão ) e não possui macros.

    Apenas abro um nova planilha, recorto e colo os valores que incluí acima, crio as fórmulas para a B1 e B2, depois arrasto a B2 até o final e fica tudo em branco ( o teste lógico é verdadeiro, apesar de não ser ). Clico em cada célula B, depois clico na barra de fórmulas e dou enter e o valor vai corrigindo ( para esta planilha até posso fazer isso, mas para a original que possui milhares não dá ).

     

    Att.

     

    Adilson


    Omtem eu fiz todas as atualizações do windows 7 e de todos os produtos da microsoft. Hoje refiz a fórmula e funcionou ( não me pergunte como, pois a versão do excel continua a mesma ).

    Obrigado a todos que se despuseram a ler e responder.

     

    Att.

     

    Adilson Dutra

    • Marcado como Resposta AdilsonD terça-feira, 17 de janeiro de 2012 19:15
    terça-feira, 17 de janeiro de 2012 19:14

Todas as Respostas

  • Verifique em Opções Gerais, Cálculo, se está Automático. A descrição do erro no final indica que o cálculo está manual. Se a planilha possui macros, habilite o conteúdo no momento em que abrir o arquivo no 2010.
    Fernando Nishimura de Aragão
    Se a resposta foi útil, clique no ícone ao lado para avaliar positivamente o participante. Obrigado.
    sábado, 14 de janeiro de 2012 23:46
  • Olá Fernando,

     

    Obrigado por seu interesse, mas, respondendo a sua questão, a opção está automática ( padrão ) e não possui macros.

    Apenas abro um nova planilha, recorto e colo os valores que incluí acima, crio as fórmulas para a B1 e B2, depois arrasto a B2 até o final e fica tudo em branco ( o teste lógico é verdadeiro, apesar de não ser ). Clico em cada célula B, depois clico na barra de fórmulas e dou enter e o valor vai corrigindo ( para esta planilha até posso fazer isso, mas para a original que possui milhares não dá ).

     

    Att.

     

    Adilson

    terça-feira, 17 de janeiro de 2012 18:54
  • Olá Fernando,

     

    Obrigado por seu interesse, mas, respondendo a sua questão, a opção está automática ( padrão ) e não possui macros.

    Apenas abro um nova planilha, recorto e colo os valores que incluí acima, crio as fórmulas para a B1 e B2, depois arrasto a B2 até o final e fica tudo em branco ( o teste lógico é verdadeiro, apesar de não ser ). Clico em cada célula B, depois clico na barra de fórmulas e dou enter e o valor vai corrigindo ( para esta planilha até posso fazer isso, mas para a original que possui milhares não dá ).

     

    Att.

     

    Adilson


    Omtem eu fiz todas as atualizações do windows 7 e de todos os produtos da microsoft. Hoje refiz a fórmula e funcionou ( não me pergunte como, pois a versão do excel continua a mesma ).

    Obrigado a todos que se despuseram a ler e responder.

     

    Att.

     

    Adilson Dutra

    • Marcado como Resposta AdilsonD terça-feira, 17 de janeiro de 2012 19:15
    terça-feira, 17 de janeiro de 2012 19:14