none
Imprimir na rede via DOS RRS feed

  • Pergunta

  • Bom dia,

    Estou com uma dificuldade pra enviar uma impressão via DOS para uma impressora compartilhada na rede. Não responde nada. Vou descrever o cenário:

     (1) Computador1 com impressora instalada na porta USB001 e compartilhada com nome simples - ficou então \\computador1\impressora;

     (2) Computador2  com a impressora do computador1 instalada normalmente (também porta USB001), e feito o comando net use lpt1 \\computador1\impressora;

     (3) No DOS, foi dado o comando pra impressão do arquivo: TYPE TESTE.TXT > LPT1

    Obs1: Executei também no Computador2 o software DOS PRINT pra redirecionamento da LPT1 pra \\computador1\impressora, mas também não funcionou. 

    Obs2: No micro local imprime normal.

    Por favor, se alguém puder me orientar, agradeço.

    Diego RM Sales

    quarta-feira, 14 de setembro de 2016 14:23

Respostas

  • Bom dia,

    Por falta de retorno, esta thread será encerrada.

    Caso seja necessário, por gentileza, abra uma nova thread.

    Atenciosamente


    Thales F Quintas

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    TechNet Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    • Marcado como Resposta Thales F Quintas segunda-feira, 19 de setembro de 2016 13:52
    segunda-feira, 19 de setembro de 2016 13:52

Todas as Respostas

  • Olá, 

    As duas estações usam qual versão do Windows? ou somente DOS? Já testou desativar o firewall no computador com a impressora?

    Veja esses tópicos, podem ajudar:

    http://answers.microsoft.com/pt-br/windows/forum/windows_7-security/como-liberar-acesso-para-impress%C3%A3o-via-porta/98374796-ba78-46f6-8c75-aaf3d6185a59

    https://social.technet.microsoft.com/Forums/pt-BR/d22758b6-d026-4d67-9942-ebe3523aba64/imprimir-via-prompt-de-comando-no-funciona?forum=winvistapt

    No aguardo,


    Edinaldo Oliveira

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita.

    ** Por favor, lembre-se de “Marcar como Resposta” as respostas que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde. **

    ----------------------------------------------------------------------

    Convidem seus colegas para participarem do fórum Technet Brasil, assim todos ganham!!! Para entender melhor como, clique aqui.



    • Editado Edinaldo Junior quarta-feira, 14 de setembro de 2016 14:36 add links
    quarta-feira, 14 de setembro de 2016 14:27
  • Edinaldo, bom dia

    Computador1: Win Vista

    Computador2: Win 10

    Fiz o teste agora desativando o firewall do Computador1 e mesmo assim não funcionou.

    A impressão que dá é que o comando está certo, pois no DOS não dá msg de erro nenhuma.

    Grato e no aguardo,

    Diego

    quarta-feira, 14 de setembro de 2016 14:41
  • Veja esses tópicos, podem ajudar:

    http://answers.microsoft.com/pt-br/windows/forum/windows_7-security/como-liberar-acesso-para-impress%C3%A3o-via-porta/98374796-ba78-46f6-8c75-aaf3d6185a59

    https://social.technet.microsoft.com/Forums/pt-BR/d22758b6-d026-4d67-9942-ebe3523aba64/imprimir-via-prompt-de-comando-no-funciona?forum=winvistapt


    Edinaldo Oliveira

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita.

    ** Por favor, lembre-se de “Marcar como Resposta” as respostas que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde. **

    ----------------------------------------------------------------------

    Convidem seus colegas para participarem do fórum Technet Brasil, assim todos ganham!!! Para entender melhor como, clique aqui.

    quarta-feira, 14 de setembro de 2016 14:48
  • Boa tarde Edinaldo, 

    Nenhuma destas opções deram certo. Mas, me diga, este comando certo?

    att; Diego

    quarta-feira, 14 de setembro de 2016 18:36
  • Mas ao menos imprime arquivos do word por exemplo? O problema é somente no DOS?

    Edinaldo Oliveira

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita.

    ** Por favor, lembre-se de “Marcar como Resposta” as respostas que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde. **

    ----------------------------------------------------------------------

    Convidem seus colegas para participarem do fórum Technet Brasil, assim todos ganham!!! Para entender melhor como, clique aqui.

    quarta-feira, 14 de setembro de 2016 18:37
  • Bom dia,

    Por falta de retorno, esta thread será encerrada.

    Caso seja necessário, por gentileza, abra uma nova thread.

    Atenciosamente


    Thales F Quintas

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    TechNet Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    • Marcado como Resposta Thales F Quintas segunda-feira, 19 de setembro de 2016 13:52
    segunda-feira, 19 de setembro de 2016 13:52
  • Meu caro,

    Mesmo depois de muito tempo de aberto este tópico deixo aqui a resposta até pra base de consulta.

    Tive um problema parecido com o seu para conseguir imprimir via dos e fazer a impressão via sistema no qual ele só sai via LPT1. O problema que a impressora só funcionava com um cabo usb e isso me causou muito problema na hora de impressão no Protheus.

    Fiz o processo de instalação da impressora com driver genérico apontando normalmente para a USB001 e em seguida compartilhei. Depois disso precisei ir no DOS e colocar o seguinte comando abaixo:

    net use lpt1: \\nome_computador\nome_impressora /PERSISTENT:YES 

    Usei desta forma pois toda vez que era feito logoff/logon, eu dava net use e a merda do mapeamento não estava lá constando no DOS. Desta forma acima ficou permanente e o sistema identificava a impressora. O melhor é que tb funcionava no comando do Dos.

    O comando via dos (print teste.txt > lpt1)

    Abs,

    Wildson

    quinta-feira, 28 de junho de 2018 20:33