none
CONT.SE para duas colunas analisando linha a linha RRS feed

  • Pergunta

  • Boa tarde Senhores

    Quero realizar um CONT.SE para a Coluna H e a Coluna N. Preciso que o Excel me mostre quantos registros na Coluna H estão menores que os registro da Coluna N, linha a linha.

    Estou usando a formula =CONT.SE(H:H;">"&N:N) mas tenho o retorno sempre do valor zero.

    O CONT.SE faz esta analise linha a linha ou somente se o critério for fixo em uma célula?

    domingo, 16 de agosto de 2015 21:29

Respostas

  • Uma alternativa para seu problema é utilizar Fórmulas Matriciais. Suponha dados até a linha 12:

    {=SOMA(SE(H1:H12 < N1:N12;1;0))}

    O sinal de "{" é inserido pressionando "Ctrl + Shift + Enter" ao terminar a edição da célula.

    Abraço.


    Filipe Magno

    • Marcado como Resposta JuarezJr86 quarta-feira, 19 de agosto de 2015 12:22
    segunda-feira, 17 de agosto de 2015 02:58
  • Juarez,

    neste tipo de fórmula vc pode concatenar várias condições, tanto 'And' como 'Or', como por exemplo:

    {=SOMA(SE((H:H <= N:N )*(H:H <> "");1;0))}

    Funciona muito bem.

    Abraço.


    Filipe Magno

    • Marcado como Resposta JuarezJr86 quarta-feira, 19 de agosto de 2015 12:22
    terça-feira, 18 de agosto de 2015 01:45

Todas as Respostas

  • Uma alternativa para seu problema é utilizar Fórmulas Matriciais. Suponha dados até a linha 12:

    {=SOMA(SE(H1:H12 < N1:N12;1;0))}

    O sinal de "{" é inserido pressionando "Ctrl + Shift + Enter" ao terminar a edição da célula.

    Abraço.


    Filipe Magno

    • Marcado como Resposta JuarezJr86 quarta-feira, 19 de agosto de 2015 12:22
    segunda-feira, 17 de agosto de 2015 02:58
  • Boa noite Felipe,

    Muito obrigado pela resposta! Me ajudou muito! Não conhecia o conceito de Fórmulas Matriciais

    Tenho uma situação muito semelhante a essa que é a seguinte:

    {=SOMA(SE(H:H <= N:N;1;0))}

    Tenho que levar em consideração toda a coluna H e N neste processo pois a formula é baseada em uma tabela do SQL, então a quantidade de linhas sempre vai aumentar.

    Porém nesta situação, utilizando o igual, o sistema esta contando as células vazias, e exibindo um valor absurdo. É possível usar este critério, porém desconsiderando as células vazias ?

    Muito obrigado pela ajuda Felipe.

    terça-feira, 18 de agosto de 2015 00:28
  • Juarez,

    neste tipo de fórmula vc pode concatenar várias condições, tanto 'And' como 'Or', como por exemplo:

    {=SOMA(SE((H:H <= N:N )*(H:H <> "");1;0))}

    Funciona muito bem.

    Abraço.


    Filipe Magno

    • Marcado como Resposta JuarezJr86 quarta-feira, 19 de agosto de 2015 12:22
    terça-feira, 18 de agosto de 2015 01:45