none
Problema após instalar o C.U. out 2012 - KB2598355 RRS feed

  • Pergunta

  • Olá a todos!

    Estou com um problema após aplicar esse C.U. de outubro de 2012 e peço ajuda...

    Meu powershell não executa mais comandos de sharepoint!

    Sempre que abro o Sharepoint Management Shell, recebo essa msg:

    Add-PSSnapin : Could not load type 'Microsoft.SharePoint.SPFeatureActivateFlags

    ' from assembly 'Microsoft.SharePoint, Version=14.0.0.0, Culture=neutral, Publi
    cKeyToken=71e9bce111e9429c' due to value type mismatch.
    At C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\CONF
    IG\POWERSHELL\Registration\SharePoint.ps1:3 char:13
    + Add-PsSnapin <<<<  Microsoft.SharePoint.PowerShell
        + CategoryInfo          : NotSpecified: (:) [Add-PSSnapin], TypeLoadExcept
       ion
        + FullyQualifiedErrorId : System.TypeLoadException,Microsoft.PowerShell.Co
       mmands.AddPSSnapinCommand

    Como eu sei que foi o C.U.?

    Eu comparei o arquivo Sharepoint.ps1 desse ambiente com problema com o mesmo arquivo de um ambiente estável. Vi que a versão era diferente e a data foi exatamente a do dia em que apliquei esse update. Como não há maneira de removê-lo, preciso fazer com que o shell funcione de alguma maneira.

    Idéias?

    Agradeço.

    segunda-feira, 10 de dezembro de 2012 14:05

Respostas

Todas as Respostas

  • Olá Vitor, boa tarde.

    Antes da atualização o power shell estava funcional?

    Você chegou a realizar um backup antes de realizar a instalação caso sim, tente restaurar novamente.

    É importante verificar que itens são afetados por essa atualização, verifique mais informações neste endereço:

    http://support.microsoft.com/kb/2598355

    Verifique também se não nenhum job parada na Central administration relacionado a este processo, caso sim tente restartar.

    Referência:

    http://technet.microsoft.com/en-us/library/cc678870.aspx

    Observe estas correções disponibilizada pelo paulo neste thread:

    http://social.technet.microsoft.com/Forums/pt-BR/epmpt/thread/44fe63ec-64d3-45c2-9f01-c4b02c112f4c

    Espero ter ajudado.


    Hezequias Vasconcelos


    segunda-feira, 10 de dezembro de 2012 14:41
    Moderador
  • Oi Hezequias, boa tarde.

    O powershell funcionava sim.

    Eu já tinha visto os links da microsoft, mas esse do Paulo, não. Postei lá pra saber se ele está acessando o powershell.

    Esse SP do LanguagePack eu também não instalei. Tive o mesmo problema do instalador não achar o produto, ao tentar aplicar o último SP do Sharepoint. Assim que fizer, aplico também o mais recente do Sharepoint, testo o powershell e posto o resultado.

    Abraço

    segunda-feira, 10 de dezembro de 2012 19:15
  • Hezequias e Paulo, muito obrigado. Problema resolvido.

    Após instalar o SP1 do Language Pack, consegui instalar o último update do Sharepoint (out 2012) e o Powershell voltou a funcionar e executar comandos do Sharepoint.

    A farm ficou então com:

    último C.U. do Project, SP1 do LanguagePack pt-br e último update do Sharepoint.


    terça-feira, 11 de dezembro de 2012 13:33