none
Contar valor unicos dependendo da informação na coluna A RRS feed

  • Pergunta

  • O meu problema o seguinte:

    tenho um planilha com os dados

    Loja Nome Fornecedo
    1 Joao Vale
    2 Joao Vale
    3 Marcos Luminaria
    1 Pedro SBX
    1 Joao Vale
    3 Pedro SBX
    2 Marcos Luminaria
    1 Maria Viscus
    2 Ana Luminaria


    eu preciso contar os vamores unicos dependendo da coluna Loja

    Exemplo:

    loja 1: tem 3 nomes únicos e 3 empresas úncias

    loja 2: tem 3 nomes únicos e 2 empresas únicas

    hoje eu coloco cada empresa loja em uma aba e usos a formula:

    =SOMA(SE(FREQUÊNCIA(SE(NÚM.CARACT(A2:A10)>0;CORRESP(A2:A10;A2:A10,0);""); SE(NÚM.CARACT(A2:A10)>0;CORRESP(A2:A10;A2:A10;0);""))>0,1))

    so que esta impraticável colocar cada loja em uma aba a planilha ta ficando muito grande o ideal e deixar tudo junto e separar por formula



    quarta-feira, 1 de junho de 2016 11:51

Respostas

  • Paulo Henrique

    Basseado no teu exemplo, experimente usar a formula matricial:

    =SOMA(--(FREQÜÊNCIA(SE($A$2:$A$10=1;CORRESP($B$2:$B$10&$C$2:$C$10;$B$2:$B$10&$C$2:$C$10;0));
    CORRESP($B$2:$B$10&$C$2:$C$10;$B$2:$B$10&$C$2:$C$10;0))>0))

    Como a form,ula é matricial, portanto, no final, em vez de teclar ENTER, tecle CTRL+SHIFT+ENTER

    Dê retorno.

    Caso seja útil vote e coloque como resposta!

    quinta-feira, 2 de junho de 2016 23:59

Todas as Respostas

  • Olá!

    Criar uma única fórmula para fazer isso, creio que até e possível, mas será demasiadamente complexo, pois creio que terá que aplicar conceitos avançados matriciais.

    Uma sugestão para facilitar a visualização destes dados é a criação de tabelas dinâmicas. Veja um exemplo na imagem:

    Desta forma é fácil visualizar a quantidade de Nomes e fornecedores por loja.


    Rafael Kamimura - http://excelmaniacos.com

    quarta-feira, 1 de junho de 2016 14:25
  • Rafael o problema e que são mais de 190 empresas por loja são mais de 2mil registos por loja vai ficar uma tabela dinâmica enorme.

    eu só preciso na verdade a saber quantas empresas únicas já ajuda e muito

    quarta-feira, 1 de junho de 2016 17:44
  • Paulo Henrique

    Basseado no teu exemplo, experimente usar a formula matricial:

    =SOMA(--(FREQÜÊNCIA(SE($A$2:$A$10=1;CORRESP($B$2:$B$10&$C$2:$C$10;$B$2:$B$10&$C$2:$C$10;0));
    CORRESP($B$2:$B$10&$C$2:$C$10;$B$2:$B$10&$C$2:$C$10;0))>0))

    Como a form,ula é matricial, portanto, no final, em vez de teclar ENTER, tecle CTRL+SHIFT+ENTER

    Dê retorno.

    Caso seja útil vote e coloque como resposta!

    quinta-feira, 2 de junho de 2016 23:59
  • Muito obrigado pela ajuda.
    segunda-feira, 6 de junho de 2016 12:33