none
DUVIDA EXCEL RRS feed

  • Pergunta

  • Bom dia!

    Tenho uma planilha com mais de mil itens com descrições e códigos e uma com o dobro de itens porém somente com descrições.

    Preciso de um formula que se a descrição bater ele puxa os códigos para a planilha sem código.

    Ex:

    PLANILHA 1

    COLUNA A            COLUNA B

    CÓDIGO               DESCRIÇÃO

    13423                  MATERIAL X

    123123                MATERIAL Y 

    154687                MATERIAL Z

    PLANILHA 2

    COLUNA A            COLUNA B

    CÓDIGO               DESCRIÇÃO

                               MATERIAL Y

                               MATERIAL Z

                               MATERIAL X

    Obrigado

    terça-feira, 12 de junho de 2018 12:08

Todas as Respostas

  • Olá.

    Como a coluna de pesquisa está à direita do que deve ser retornado, não dá para usar PROCV.

    Teste a seguinte fórmula:

    =ÍNDICE(Plan1!$A$2:$B$n;CORRESP($B2;Plan1!$B$2:$B$n;0);1)

    Substitua o n em negrito com a linha do último elemento de cada tabela. Substitua Plan1 e Plan2 peles respectivos nomes.


    https://inframicrosoft.wordpress.com/


    • Editado J. Maurício terça-feira, 12 de junho de 2018 13:57
    terça-feira, 12 de junho de 2018 13:55