none
Problema com SMTP do IIS RRS feed

  • Pergunta

  • Pessoal, é o seguinte, procurei no forum e nao encontrei nada.

    Eu estou instalando em um servidor web o SMTP do IIS, ele esta funcionando, porem se tentar enviar um email para o proprio dominio então não funciona.

    Meu cenário é o seguinte, o servidor de email é hospedado em outro lugar (google apps) porem preciso configurar o SMTP em um servidor proprio nosso pois como temos um serviço de newsletter o smtp da google bloqueia quando enviamos muitos email. Enfim, este SMTP esta funcionando bem porem se tentar enviar para o nosso proprio dominio ele nao envia, as mensagens cai na pasta de "badmail", nao sei porque, pensei que seria talvez alguma coisa de DNS pois esta maquina tb é servidor DNS publico do nosso site, mas a configuração dele esta correta, no caso de email seria apenas o MX e o MX esta configurado perfeitamente, quando email enviado para o nosso dominio chega, menos se for enviado por este SMTP.

    Alguem tem alguma ideia? nao sei configurar muito bem o SMTP mas como esta funcionando acredito q esta tudo certo...

    Se puderem me ajudar.

    Muito obrigado.

    sábado, 13 de agosto de 2011 06:19

Respostas

  • Oi Erick,

    Descobri o problema, na verdade ao instalar o SMTP o POP3 tb foi instalado e ele instalou com o nome de dominio nosso, portanto como nao tinha nenhuma conta criado no pop3 ele dava erro pois nao havia o respectivo email (ja que as caixas postais são usando em um servidor externo).

    De qualquer forma muito obrigado pela ajuda.

    Não sei se posso aproveitar esse topico para tirar uma dúvida, como funciona a autenticação "Basic Authentication"? pois é o seguinte, o nosso site foi desenvolvido em PHP e com a autenticação do windows não funciona, ele só funciona se deixar sem autenticação e talvez com essa autenticação basica, mas nao sei como fazer funcionar isso, como que funciona e etc. alguem saberia me informar como que faz?

    Abraço.
    Marcel

    terça-feira, 16 de agosto de 2011 00:39

Todas as Respostas

  • Marcel,

     

    Faça um teste, mude o dominio do remetente e tente enviar novamente.

     

    []s


    Erick Albuquerque | Microsoft MVP
    MVP Profile | Twitter | Linkedin | http://iisbrasil.wordpress.com
    segunda-feira, 15 de agosto de 2011 20:49
    Moderador
  • Oi Erick,

    Descobri o problema, na verdade ao instalar o SMTP o POP3 tb foi instalado e ele instalou com o nome de dominio nosso, portanto como nao tinha nenhuma conta criado no pop3 ele dava erro pois nao havia o respectivo email (ja que as caixas postais são usando em um servidor externo).

    De qualquer forma muito obrigado pela ajuda.

    Não sei se posso aproveitar esse topico para tirar uma dúvida, como funciona a autenticação "Basic Authentication"? pois é o seguinte, o nosso site foi desenvolvido em PHP e com a autenticação do windows não funciona, ele só funciona se deixar sem autenticação e talvez com essa autenticação basica, mas nao sei como fazer funcionar isso, como que funciona e etc. alguem saberia me informar como que faz?

    Abraço.
    Marcel

    terça-feira, 16 de agosto de 2011 00:39
  • Olá, desculpe a demora!

    Ótimo que tenha resolvido o problema!! Referente a outra duvida recomendo que abra outra thread, pois desta forma mantemos a organização no fórum e facilita a busca!

     

    []s


    Erick Albuquerque | Microsoft MVP
    MVP Profile | Twitter | Linkedin | http://iisbrasil.wordpress.com
    quarta-feira, 17 de agosto de 2011 21:02
    Moderador